Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 1st Gen : 1981 - 1993 > General Discussions


General Discussions

Horn doesn't work 1985 power ram W150


This is a discussion on Horn doesn't work 1985 power ram W150 within the General Discussions forums, part of the 1st Gen : 1981 - 1993 category!
Horn works direct from battery. Have amperage at the steering wheel (light tested, not metered). No amperage at the connector ...


Reply
 
LinkBack Thread Tools Display Modes
Old 11-21-2016, 08:39 PM   #1 (permalink)
 
Brucecmc's Avatar
Senior Member
 
Join Date: Nov 2016
Location: At the parts store
Age: 57
Posts: 123

Ram Year: 1985 Power Ram W-150
Engine: 318 V8 5.2L
Default Horn doesn't work 1985 power ram W150
Horn works direct from battery. Have amperage at the steering wheel (light tested, not metered). No amperage at the connector wires at the horn itself. My prob is that I don't know where to check between the steering wheel and the hops heading out to the horn to check wiring and presence of current.

Seems if the fuse or the relay were fouled, I wouldn't have successful test at the connectors at the steering wheel (checked fuse, appears good. No clicking at the relay)


Sponsored Ad
Register to remove this ad.
Brucecmc is offline   Reply With Quote
Old 11-22-2016, 01:04 PM   #2 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,583

Ram Year: 81 93
Engine: 5.2
Default
it is possible that the relay has gone bad. the horn button supplies the relay with ground when you press the horn button.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is offline   Reply With Quote
Old 11-22-2016, 08:08 PM   #3 (permalink)
 
Brucecmc's Avatar
Senior Member
 
Join Date: Nov 2016
Location: At the parts store
Age: 57
Posts: 123

Ram Year: 1985 Power Ram W-150
Engine: 318 V8 5.2L
Default Horn don't work
That relay could be messed up even though I'm showing light test success at the steering wheel?
Brucecmc is offline   Reply With Quote
Old 11-22-2016, 08:17 PM   #4 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,583

Ram Year: 81 93
Engine: 5.2
Default
the horn wire gets it ground from the steering wheel and grounds the relay which let power go through the relay to the horn. you could possibly pull the horn relay and use a jumper cable to see if you can get the horn working from in the cab. if you are able to then the horn relay is most likely bad.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is offline   Reply With Quote
Old 11-22-2016, 08:25 PM   #5 (permalink)
 
Brucecmc's Avatar
Senior Member
 
Join Date: Nov 2016
Location: At the parts store
Age: 57
Posts: 123

Ram Year: 1985 Power Ram W-150
Engine: 318 V8 5.2L
Default
Cool. I'll give that a shot. Ran into a new prob today. Engine will only start/stay running if I have the ignition in the start position. Mr Google says ballast resistor or ignition switch. I'll prolly post new thread for this. But figured while you were responding I'd see if u had thoughts on that symptom.
Brucecmc is offline   Reply With Quote
Old 11-22-2016, 09:06 PM   #6 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,583

Ram Year: 81 93
Engine: 5.2
Default
that sounds like a bad ballast resister. you can try bypassing it with a jumper cable but if that fixes it you may want to replace as soon as possible. a jumper cable bypassing the ballast resister will get you off the side of the road but can kill the coil if left too long.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is offline   Reply With Quote
Old 11-22-2016, 09:19 PM   #7 (permalink)
 
Brucecmc's Avatar
Senior Member
 
Join Date: Nov 2016
Location: At the parts store
Age: 57
Posts: 123

Ram Year: 1985 Power Ram W-150
Engine: 318 V8 5.2L
Default
Lemme give that a whirl
Brucecmc is offline   Reply With Quote
Old 11-23-2016, 10:24 AM   #8 (permalink)
 
Brucecmc's Avatar
Senior Member
 
Join Date: Nov 2016
Location: At the parts store
Age: 57
Posts: 123

Ram Year: 1985 Power Ram W-150
Engine: 318 V8 5.2L
Default Horn don't work
Thought it wud be a quick Google search. But guess not. Alright,
1. On the 85 W150 where is the ballast resistor. And
2. How is it by passed?

I feel like a dork.

Thanks for the help
Brucecmc is offline   Reply With Quote
Old 11-23-2016, 12:19 PM   #9 (permalink)
 
Brucecmc's Avatar
Senior Member
 
Join Date: Nov 2016
Location: At the parts store
Age: 57
Posts: 123

Ram Year: 1985 Power Ram W-150
Engine: 318 V8 5.2L
Default
Well figured out how to by pass the ballast resistor. Truck wouldn't start at all. Reconnected the BR and again, it will start when ignition is on and dies as soon as I release.
Ignition switch maybe?
Brucecmc is offline   Reply With Quote
Old 11-23-2016, 01:12 PM   #10 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,583

Ram Year: 81 93
Engine: 5.2
Default
it could be the ignition switch but i would try testing all the fuses for power with the key in the on position. you could have had a fusible link fail which would stop your horn from working along with many other things.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1985 W150 fuel line too close to exhaust? Vapor lock? Fire? I_chew_big_red Engine & Performance 7 05-18-2016 09:26 AM
1985 W150 fuel line too close to exhaust? Vapor lock? Fire? I_chew_big_red Engine & Performance 0 05-12-2016 10:12 AM
1985 W150 repairs. Am I getting ripped off? I_chew_big_red General Discussions 3 05-07-2016 07:24 PM
1985 W150 Power Ram Deamer Member Trucks 10 04-14-2014 07:58 PM
1985 w150 acts like it runs out of gas when passing jcp dodge Engine & Performance 4 02-20-2013 12:19 PM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum