Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 1st Gen : 1981 - 1993 > Exterior


Exterior

Something weird with turn signal


This is a discussion on Something weird with turn signal within the Exterior forums, part of the 1st Gen : 1981 - 1993 category!
So my turn signals work fine when my parking/headlights are off. But if I have my park/headlights on my passenger ...


Sponsored By: BAK Factory Outlet
Reply
 
LinkBack Thread Tools Display Modes
Old 09-11-2015, 07:05 PM   #1 (permalink)
Member
 
Join Date: Sep 2015
Location: Bloomington, IN
Age: 31
Posts: 68

Ram Year: 1985
Engine: LA 318
Default Something weird with turn signal
So my turn signals work fine when my parking/headlights are off. But if I have my park/headlights on my passenger side signals work fine but my driver side the light on the cluster just stays lit and both front and back bulbs shut off completely. I thought it was a bulb problem so I replaced them all. Still having the same issue. When the parking/headlights are on but no turn signal they work fine. When they are off turn signal works fine, but not together... Please someone tell me you have had this happen and its not a whole wiring harness.


Sponsored Ad
Register to remove this ad.
Blue Chaos is offline   Reply With Quote
Old 09-11-2015, 07:14 PM   #2 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,206

Ram Year: 81 93
Engine: 5.2
Default
there is most likely a short in that side or a bad bulb. usually my truck does that when the park like is out.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Old 09-11-2015, 07:16 PM   #3 (permalink)
Member
 
Join Date: Sep 2015
Location: Bloomington, IN
Age: 31
Posts: 68

Ram Year: 1985
Engine: LA 318
Default
I figured it was a bulb tooo, so I replaced them all 15 minutes ago. No dice.
Blue Chaos is offline   Reply With Quote
Old 09-11-2015, 07:18 PM   #4 (permalink)
Member
 
Join Date: Sep 2015
Location: Bloomington, IN
Age: 31
Posts: 68

Ram Year: 1985
Engine: LA 318
Default
My connectors are in ROUGH shape, could that be it? The rear where it grabs the bulb is fine but the wings that hold it in the new tail light are rusted off. The front one half or the metal part that holds the bulb is rusted off. I had to scrub the inside connectors just to get the bulb to work.
Blue Chaos is offline   Reply With Quote
Old 09-11-2015, 07:28 PM   #5 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,206

Ram Year: 81 93
Engine: 5.2
Default
the issue will be in the front somewhere on the side that the light says. it could be a connector or socket. would really be hard to say without being there. the turn signal indicators are tied to the front turn signal wiring which is why it comes on when it is out or there is a issue.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Old 09-11-2015, 07:32 PM   #6 (permalink)
Member
 
Join Date: Sep 2015
Location: Bloomington, IN
Age: 31
Posts: 68

Ram Year: 1985
Engine: LA 318
Default
Originally Posted by crazzywolfie View Post
the issue will be in the front somewhere on the side that the light says. it could be a connector or socket. would really be hard to say without being there. the turn signal indicators are tied to the front turn signal wiring which is why it comes on when it is out or there is a issue.
Awesome! Good to know! I will begin with a new connector and then go on a wire hunt.
Blue Chaos is offline   Reply With Quote
Old 09-11-2015, 07:42 PM   #7 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,206

Ram Year: 81 93
Engine: 5.2
Default
ya. it took me a bit to realize it on my truck. also did you also check the turn signal bulb on the light in the fender? could also maybe cause it to kick on.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Old 09-11-2015, 09:34 PM   #8 (permalink)
 
TRCM's Avatar
Senior Member
 
Join Date: Jul 2012
Location: Newport News, VA
Posts: 1,195

Ram Year: 2012 1500 Laramie CC 4x4
Engine: 5.7 Hemi
Default
Also check the hazard switch...when they go bad, weird things happen


__________________
2012 Dodge Ram Laramie CC 4x4, Hemi, 3.92, LSD
1996 Cherokee Sport 4x4, 4.0, AW4, NP231, SYE, 3.55, 4.5" lift, locked rear, 31x10.5 muds
1988 Cherokee Pioneer 4x4, 4.0, AW4, NP242, 3.55, 2" lift, locked rear
TRCM is offline   Reply With Quote
Old 09-12-2015, 12:42 AM   #9 (permalink)
Member
 
Join Date: Sep 2015
Location: Bloomington, IN
Age: 31
Posts: 68

Ram Year: 1985
Engine: LA 318
Default
I pulled the little reflector bulb or whatever just to make sure it wasn't it. No dice again. And with the hazard switch. I pulled it and they work fine, but if that's the problem, do I just replace the switch??
Blue Chaos is offline   Reply With Quote
Old 09-12-2015, 05:50 AM   #10 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,206

Ram Year: 81 93
Engine: 5.2
Default
the switch is not likely the issue. your issue is still probably still under the hood in the wiring or connectors. somewhere power is getting from the park lights into the turn signal light system


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signal help milldew1963 General Discussion 0 08-18-2015 07:40 AM
LED Turn Signal Help Aluminum Tech Info 1 04-28-2015 07:00 PM
Turn signal LED toppyw Exterior 8 03-05-2015 02:49 PM
Please help with led turn signal Drc1340 Exterior 0 12-08-2014 11:26 PM
turn signal justintimemoto Audio & Electronics 3 03-27-2014 05:46 PM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum