Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 1st Gen : 1981 - 1993 > Audio & Electronics


Audio & Electronics

First the windows, then cruise now nothing!!


This is a discussion on First the windows, then cruise now nothing!! within the Audio & Electronics forums, part of the 1st Gen : 1981 - 1993 category!
I am about at my wits end... the basics 1993 D250 12v cummins 5 speed. Symptoms... Started with the Hvac ...


Reply
 
LinkBack Thread Tools Display Modes
Old 01-30-2015, 12:10 PM   #1 (permalink)
Junior Member
 
Join Date: Oct 2012
Age: 30
Posts: 14

Ram Year: 1989
Engine: 5.9l Cummins
Default First the windows, then cruise now nothing!!
I am about at my wits end... the basics 1993 D250 12v cummins 5 speed.

Symptoms...
Started with the Hvac and windows not working. I could bridge across and get them to work fine. Never found any breaks or shorts. Then the cruise control started acting funny, would cut in and out going down road some days would not work at all then stopped working all together. Finally a buddy borrowed it to pull a 5th wheel trailer as he pulled into its parking spot it died.

I have checked the fusible links all good except the one that feeds the solid red i dont believe its the link as there is no power before or after the link....

When you turn ignition NOTHING happens no dash lights, buzzing, warning light's etc when you turn to start zilch happens as well.

Been doing a lot of reading and I am thinking its either the ignitin switch itself, a bad relay or possibly a bad ecu?? How can i go through a process of elimination before i just start replacing parts! Thank you in advance!!!


Sponsored Ad
Register to remove this ad.
Nwa-ram is offline   Reply With Quote
Old 01-30-2015, 03:37 PM   #2 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,207

Ram Year: 81 93
Engine: 5.2
Default
the orange fusible link that goes to the red wire powers most of the stuff in the cab. the orange fusible link that goes to the pink wires power your heater and power window


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Old 03-23-2015, 03:24 PM   #3 (permalink)
Junior Member
 
Join Date: Oct 2012
Age: 30
Posts: 14

Ram Year: 1989
Engine: 5.9l Cummins
Default
So it was the fusible links... partially. Replaced all of it with a fuse block. However in the process noticed a missing relay... anyone know what relay this is???

Its all the way back towards the firewall
Nwa-ram is offline   Reply With Quote
Old 03-23-2015, 03:31 PM   #4 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,207

Ram Year: 81 93
Engine: 5.2
Default
you may want to keep lots of fuses on you because i don't think a fuse block will really work very well in place of the fusable links

that is your obd1 computer port.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Old 03-23-2015, 08:44 PM   #5 (permalink)
Junior Member
 
Join Date: Oct 2012
Age: 30
Posts: 14

Ram Year: 1989
Engine: 5.9l Cummins
Default
Oh. Well learned something new!

Why wouldnt fuses work in place of a fusible link? Its all the same concept
Nwa-ram is offline   Reply With Quote
Old 03-23-2015, 08:55 PM   #6 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,207

Ram Year: 81 93
Engine: 5.2
Default
fuses usually blow instantly when overloaded where fusible links don't.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Old 12-22-2016, 04:22 PM   #7 (permalink)
 
Sniper X's Avatar
Member
 
Join Date: Dec 2016
Age: 49
Posts: 86

Ram Year: 1991
Engine: 318
Default
Originally Posted by crazzywolfie View Post
fuses usually blow instantly when overloaded where fusible links don't.
I changed all my fuseable links on my 77 ramcharger a d my 1991 no power wagon and have never had a problem.

Last edited by Sniper X; 12-30-2016 at 02:38 AM.
Sniper X is offline   Reply With Quote
Old 12-22-2016, 05:58 PM   #8 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,207

Ram Year: 81 93
Engine: 5.2
Default
maybe you have got lucky so far. i personally wouldn't run them. on my 81 i got the newer style fusible links replacing the old ones. they work just like fuses and can easily be swapped out or bypassed but i also installed a power distribution center.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Old 12-30-2016, 02:40 AM   #9 (permalink)
 
Sniper X's Avatar
Member
 
Join Date: Dec 2016
Age: 49
Posts: 86

Ram Year: 1991
Engine: 318
Default
Originally Posted by crazzywolfie View Post
maybe you have got lucky so far. i personally wouldn't run them. on my 81 i got the newer style fusible links replacing the old ones. they work just like fuses and can easily be swapped out or bypassed but i also installed a power distribution center.
If you mean me getting lucky swapping them out to fuses, they have been in my Ramcharger for over 20 years, working perfectly, and in my truck for five years.


__________________
Resistance is not futile, it is voltage divided by current.
Sniper X is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Clockspring w/Cruise in Vehicle w/out Cruise - Work OK? skobydog Tech Info 3 03-15-2014 09:46 AM
Cruise not working. ronixrider82 Tech Info 2 11-18-2013 01:44 PM
Cruise control E roc General Discussions 1 11-09-2013 08:24 PM
Cruise Control JamesA General Discussion 5 10-18-2013 11:01 PM
surge on cruise Bombdigitty Tech Info 0 06-24-2013 10:46 AM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum