Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 1st Gen : 1981 - 1993 > Engine & Performance


Engine & Performance

89 ram with issues


This is a discussion on 89 ram with issues within the Engine & Performance forums, part of the 1st Gen : 1981 - 1993 category!
Hello all. New guy here. Just picked up an 89 d150 4x4 last night to use as a farm beater. ...


Like Tree1Likes

Sponsored By: Moe's Performance
Reply
 
LinkBack Thread Tools Display Modes
Old 10-29-2016, 06:08 PM   #1 (permalink)
Junior Member
 
Join Date: Oct 2016
Age: 36
Posts: 15

Ram Year: 1989
Engine: 318
Default 89 ram with issues
Hello all. New guy here. Just picked up an 89 d150 4x4 last night to use as a farm beater. Truck started out running rough but was drivable then it just completely quit. Thought it was spark issues and its a lot more than that. I have power to the coil and fuel pump with the key shut off. As soon as I flip the key over to start it all power is gone. I know I can put the pump on a toggle switch but can I put the coil on one also. If I'm having these issues is there possibly something else wrong causing all this nonsense? Im in the doghouse big time with the wifey over this because of a $91 tow bill to get it the rest of the way home. I've always had carbed engines without all this electrical stuff on it so I'm not sure where to start. Any help is greatly appreciated.


Sponsored Ad
Register to remove this ad.
robsnyder225 is offline   Reply With Quote
Old 10-29-2016, 06:28 PM   #2 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,604

Ram Year: 81 93
Engine: 5.2
Default
welcome. not seeing power at the coil or fuel pump is normal. you will only see power there for a few seconds after you turn the key on or while cranking. otherwise the computer shuts the asd relay off. can you hear the fuel pump turn on when you first turn the key on? also do you still hear noise under the hood when you turn the key on?


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is offline   Reply With Quote
Old 10-29-2016, 08:07 PM   #3 (permalink)
Junior Member
 
Join Date: Oct 2016
Age: 36
Posts: 15

Ram Year: 1989
Engine: 318
Default
Fuel pump doesn't kick on at all with the key. But hums with the key off. Not getting any spark from the coil at all. Can I put a toggle to it and give it power. Not sure if I've got a bad coil or not at this point. I know the pump is supposed to run until it builds pressure and then shut off. The wiring is pretty messy and I'm wondering if the box on the fender isn't screwed up too.
robsnyder225 is offline   Reply With Quote
Old 10-29-2016, 08:13 PM   #4 (permalink)
Junior Member
 
Join Date: Oct 2016
Age: 36
Posts: 15

Ram Year: 1989
Engine: 318
Default
It was making a funny noise when you turned off the key but we drained the battery trying to get it started. The noise only lasted a couple seconds. Just really lost as to why its doing this. I'd like to override the box and see if it will start. What all does that box on the fender control? If I can get it to run without it then that's what I'll do. Just trying to get a handle on it to figure out were to start trouble shooting it. It didn't make any noises under the hood with the key on. I'm hoping its just a dead coil and nothing more but I have a bad feeling about it. And to add to it. I hate wiring!

Last edited by robsnyder225; 10-29-2016 at 08:21 PM. Reason: more info
robsnyder225 is offline   Reply With Quote
Old 10-29-2016, 08:19 PM   #5 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,604

Ram Year: 81 93
Engine: 5.2
Default
are you sure the fuel pump hums with the key off and it is not something under the hood? normally the throttle kicker under the hood makes noise when you first turn the key on and a couple seconds after you turn the key off which is what i think you might possibly be hearing.

the box on the fender controls everything


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is offline   Reply With Quote
Old 10-29-2016, 09:05 PM   #6 (permalink)
Junior Member
 
Join Date: Oct 2016
Age: 36
Posts: 15

Ram Year: 1989
Engine: 318
Default
Oh its the fuel pump. You dont hear noise under the hood. Its back at the tank. Something is really messed up with for sure.
robsnyder225 is offline   Reply With Quote
Old 10-29-2016, 09:19 PM   #7 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,604

Ram Year: 81 93
Engine: 5.2
Default
the fuel pump should only run when the key is on. if it runs after you turn the key off then there is something wrong. you can test the asd relay connector to see if it is getting power to terminal 86 with the key in the run position. this is your ignition power wire. you also want to check to see if there is power at terminal 30 which is a constant power wire



__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is offline   Reply With Quote
Old 10-29-2016, 09:24 PM   #8 (permalink)
Junior Member
 
Join Date: Oct 2016
Age: 36
Posts: 15

Ram Year: 1989
Engine: 318
Default
Where is that relay located? This is the first one of these I've had. I'm just at a loss as to why it did it.
robsnyder225 is offline   Reply With Quote
Old 10-29-2016, 09:29 PM   #9 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,604

Ram Year: 81 93
Engine: 5.2
Default
it is the only normal sized relay on the drivers side fender. i have had my share of experience playing with these things.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is offline   Reply With Quote
Old 10-29-2016, 09:44 PM   #10 (permalink)
Junior Member
 
Join Date: Oct 2016
Age: 36
Posts: 15

Ram Year: 1989
Engine: 318
Default
I'll have to look again when I get back home. But I dont think there's even one on the fender that looks like that. The wiring is all messed up and if that's missing it could explain a lot of the problems.
robsnyder225 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
GPS issues KevTN Audio & Electronics 0 04-30-2016 05:19 PM
HID Issues lone12star Audio & Electronics 0 05-10-2014 03:06 AM
hid issues harr118 Exterior 12 07-15-2012 10:27 PM
Newbie Here. 5.9 V8 issues, pinging sounds, power issues, drivetrain clunking an more 2000DirtyDodge Engine & Performance 7 02-15-2012 09:27 AM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum