Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 1st Gen : 1981 - 1993 > Engine & Performance


Engine & Performance

89 ram with issues


This is a discussion on 89 ram with issues within the Engine & Performance forums, part of the 1st Gen : 1981 - 1993 category!
Yes put a plug in the coil wire and it threw some pretty good fire....


Like Tree1Likes

Sponsored By: Moe's Performance
Reply
 
LinkBack Thread Tools Display Modes
Old 11-07-2016, 11:22 PM   #21 (permalink)
Junior Member
 
Join Date: Oct 2016
Age: 35
Posts: 15

Ram Year: 1989
Engine: 318
Default
Yes put a plug in the coil wire and it threw some pretty good fire.


Sponsored Ad
Register to remove this ad.
robsnyder225 is offline   Reply With Quote
Old 11-07-2016, 11:32 PM   #22 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,206

Ram Year: 81 93
Engine: 5.2
Default
so it sounds like your issue is probably the distributor cap or rotor then.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Old 11-08-2016, 12:07 AM   #23 (permalink)
Junior Member
 
Join Date: Oct 2016
Age: 35
Posts: 15

Ram Year: 1989
Engine: 318
Default
Okay. I cleaned the contacts on the cap because they had a little bit of corrosion on them and the rotor looked brand new. But anything is possible.
robsnyder225 is offline   Reply With Quote
Old 11-08-2016, 12:10 AM   #24 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,206

Ram Year: 81 93
Engine: 5.2
Default
it is possible to have a bad spark plug or wire but normally they don't fail too often.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Old 11-18-2016, 05:50 PM   #25 (permalink)
Junior Member
 
Join Date: Oct 2016
Age: 35
Posts: 15

Ram Year: 1989
Engine: 318
Default
Now I dont have anything coming from the coil. Power is going to it and its brand new. Can't get any spark out now. Totally lost now.
robsnyder225 is offline   Reply With Quote
Old 11-18-2016, 07:16 PM   #26 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,206

Ram Year: 81 93
Engine: 5.2
Default
the asd relay powers the coil, injectors and everything else that needs power to run. the computer grounds the coil when it gets the signals it needs to think you the engine is turning. i would possibly be checking the hall effects sensor in the distributor.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Old 11-19-2016, 08:00 PM   #27 (permalink)
Junior Member
 
Join Date: Oct 2016
Age: 35
Posts: 15

Ram Year: 1989
Engine: 318
Default
Replaced the hall effect and it fired right up. Cleaned up the wiring a little bit more and it seems to be better. Still runs a bit rough but I'm happy its running.
robsnyder225 is offline   Reply With Quote
Old 11-19-2016, 08:31 PM   #28 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,206

Ram Year: 81 93
Engine: 5.2
Default
glad to hear it is running. it might start running a bit better once you have possibly got a tank of fuel through it. if it doesn't i would possibly try checking for codes again and maybe change the O2 sensor. these things like the NTK O2 sensors if you do replace them. they are usually pretty cheap


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is online now   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
GPS issues KevTN Audio & Electronics 0 04-30-2016 06:19 PM
HID Issues lone12star Audio & Electronics 0 05-10-2014 04:06 AM
hid issues harr118 Exterior 12 07-15-2012 11:27 PM
Newbie Here. 5.9 V8 issues, pinging sounds, power issues, drivetrain clunking an more 2000DirtyDodge Engine & Performance 7 02-15-2012 10:27 AM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum