Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 4th Gen : 2009 - Present > Tech Info


Tech Info

Brake Switch Sensor...ISSUE


This is a discussion on Brake Switch Sensor...ISSUE within the Tech Info forums, part of the 4th Gen : 2009 - Present category!
Get in the truck and start it....Touch the brake pedal, and you can hear/feel the brake sensor engage...All 3 brake ...


Reply
 
LinkBack Thread Tools Display Modes
Old 01-03-2017, 02:00 PM   #1 (permalink)
 
SHOOT2KILL's Avatar
Senior Member
 
Join Date: Oct 2015
Age: 57
Posts: 205

Ram Year: 2015...2500H.D.
Engine: 6.4
Default Brake Switch Sensor...ISSUE
Get in the truck and start it....Touch the brake pedal, and you can hear/feel the brake sensor engage...All 3 brake lights work properly...Lift your foot off the brake pedal, and you can hear the sensor dis-engage.....Then when I put the truck in forward or reverse and use the brake, I do not feel/hear the sensor open/close...Brake lights still work properly...Shut the truck off,open the door,hit the door lock switch, and when it locks the truck,I can hear the brake switch sensor quickly engage/dis-engage...New servicing dealer cant get me in till 1-9-17...I will have in hand a new sensor by noon Wednesday (special order) #68078700AE...This is the 4th part# change for this particular part since 2012...More JUNK made in Mexico/China maybe....Ironic....This oem mopar part costs around $17.00....It's the first oem part I can remember that actually costs LESS than the same part purchased from a local chain auto parts store for $23.99


Sponsored Ad
Register to remove this ad.
SHOOT2KILL is offline   Reply With Quote
Old 01-06-2017, 11:44 AM   #2 (permalink)
Member
 
Join Date: May 2016
Location: MN
Age: 42
Posts: 88

Ram Year: 2017 1500 Express 4wd RCSB
Engine: Hemi 5.7
Default
I had bought mine from Napa but lo and behold once I removed it from the Napa box it was indeed an OE switch with the Chrysler logo.
WiSH2oo0 is offline   Reply With Quote
Old 03-04-2017, 07:40 PM   #3 (permalink)
Junior Member
 
Join Date: Sep 2013
Posts: 11

Ram Year: 2010
Engine: 5.7 Hemi
Default
I disassembled my bad OEM one only to find the contacts were assembled improperly. The plated discs were put on the wrong side of the flat springs inside the switch on two of three sets of contacts. I don't know where the OEM one was made for sure, but a lot of Chrysler stuff seems to be coming from China by the labeling. The Napa replacement was definatly not OEM (lacked the molded logos etc) but otherwise nearly identical. The Napa part was clearly marked as made in China. I don't know how this part worked as long as it did...


__________________
2010 RAM 1500 SPORT CREW CAB 4X4 BLACK
5.7L Hemi / 3.92 Anti-Spin / 4" Superlift w/ Bilsteins all around / 285/65/20 BFG KO 2's
saselker is offline   Reply With Quote
Old 03-04-2017, 09:37 PM   #4 (permalink)
 
jwheeler's Avatar
Senior Member
 
Join Date: Oct 2014
Location: Washington
Posts: 1,489

Ram Year: 2010
Engine: Hemi 5.7
Default
Originally Posted by SHOOT2KILL View Post
Get in the truck and start it....Touch the brake pedal, and you can hear/feel the brake sensor engage...All 3 brake lights work properly...Lift your foot off the brake pedal, and you can hear the sensor dis-engage.....Then when I put the truck in forward or reverse and use the brake, I do not feel/hear the sensor open/close...Brake lights still work properly...Shut the truck off,open the door,hit the door lock switch, and when it locks the truck,I can hear the brake switch sensor quickly engage/dis-engage...New servicing dealer cant get me in till 1-9-17...I will have in hand a new sensor by noon Wednesday (special order) #68078700AE...This is the 4th part# change for this particular part since 2012...More JUNK made in Mexico/China maybe....Ironic....This oem mopar part costs around $17.00....It's the first oem part I can remember that actually costs LESS than the same part purchased from a local chain auto parts store for $23.99


What is not working? Why do you want to replace the switch? It sounds like the brake lights still work?


Sent from my iPhone using Tapatalk
jwheeler is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant sensor issue... kdryan Engine & Performance 2 08-07-2016 02:16 PM
Oil Temp Sensor Issue PCT Audio & Electronics 0 09-24-2015 09:10 PM
Speed sensor , ABS & Brake light canoehead Tech Info 2 03-20-2014 03:53 PM
Park brake sensor for DVD MB1500SPRT Audio & Electronics 10 06-08-2012 09:50 PM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum