Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 4th Gen : 2009 - Present > Tech Info


Tech Info

Question for your FCA techs only.


This is a discussion on Question for your FCA techs only. within the Tech Info forums, part of the 4th Gen : 2009 - Present category!
When you run a PCM or TCM update on a truck, does this have to be performed with the vehicle ...


Like Tree1Likes
  • 1 Post By jwheeler

Reply
 
LinkBack Thread Tools Display Modes
Old 09-17-2016, 01:01 AM   #1 (permalink)
 
Limeybastard's Avatar
Senior Member
 
Join Date: Jul 2015
Location: Shady Hills, Rednecksville Boro, Florida.
Age: 46
Posts: 1,561

Ram Year: 2015
Engine: Hemi 5.7
Default Question for your FCA techs only.
When you run a PCM or TCM update on a truck, does this have to be performed with the vehicle exhibiting no existing error messages on evic ? For example if your perform a PCM or TCM update on a truck that does not have TPMS sensors would it effect anything?

I ask this question since I had my truck taken in for routine work, they did a pcm and tcm update and for about a day and half my truck registered PSI on the evic for each wheel even though no tpms sensors were present.

Roll on 4 weeks later and I have tpms sensors fitted now but nothing still shows.


Sponsored Ad
Register to remove this ad.

Last edited by Limeybastard; 09-17-2016 at 01:03 AM.
Limeybastard is offline   Reply With Quote
Old 09-17-2016, 01:54 AM   #2 (permalink)
 
jwheeler's Avatar
Senior Member
 
Join Date: Oct 2014
Location: Washington
Posts: 1,494

Ram Year: 2010
Engine: Hemi 5.7
Default
PCM or TCM updates really have nothing to do with the tpms. That is very strange. Maybe they also did an update for the RF hub and didn't mention it? Never heard of that. Likely not the reason you are having issues now.


Sent from my iPhone using Tapatalk
jwheeler is offline   Reply With Quote
Old 09-17-2016, 11:35 AM   #3 (permalink)
 
Limeybastard's Avatar
Senior Member
 
Join Date: Jul 2015
Location: Shady Hills, Rednecksville Boro, Florida.
Age: 46
Posts: 1,561

Ram Year: 2015
Engine: Hemi 5.7
Default
Originally Posted by jwheeler View Post
PCM or TCM updates really have nothing to do with the tpms. That is very strange. Maybe they also did an update for the RF hub and didn't mention it? Never heard of that. Likely not the reason you are having issues now.


Sent from my iPhone using Tapatalk
Yeah it was strange. As the truck showed tpms sensors active with psi figures next to each wheel on the evic and obviously the orange tire pressure warning light had also disappeared after the updates. When there was no sensors in the wheels.

Sent from my SM-G928T
Limeybastard is offline   Reply With Quote
Old 09-28-2016, 11:37 PM   #4 (permalink)
 
Limeybastard's Avatar
Senior Member
 
Join Date: Jul 2015
Location: Shady Hills, Rednecksville Boro, Florida.
Age: 46
Posts: 1,561

Ram Year: 2015
Engine: Hemi 5.7
Default
Oh well, I doubt they will ever call me back. Trust me I was polite all smiley faced and generally nice, not an ahole like I am on here LOLzzz

So, brings me to my next question. Should they not call me back to continue the repairs that were started, will the current issue eventually time out and become my problem after the 3 year 36K mile warranty or since I have gone there and its noted ( in process alledgendly )then it doesnt matter when I go back?
Limeybastard is offline   Reply With Quote
Old 09-29-2016, 11:09 PM   #5 (permalink)
 
jwheeler's Avatar
Senior Member
 
Join Date: Oct 2014
Location: Washington
Posts: 1,494

Ram Year: 2010
Engine: Hemi 5.7
Default
What are the miles now? If you go in for a problem at 35k and it is not resolved by the time you are out of warranty, they will "Good will" the repair and will take care of it. It you are at 20k now, it's unlikely.


Sent from my iPhone using Tapatalk
Pay2play likes this.
jwheeler is offline   Reply With Quote
Old 09-29-2016, 11:10 PM   #6 (permalink)
 
jwheeler's Avatar
Senior Member
 
Join Date: Oct 2014
Location: Washington
Posts: 1,494

Ram Year: 2010
Engine: Hemi 5.7
Default Question for your FCA techs only.
You are still having problems with the TPMS? Where did your sensors go? Are the new ones that are in now the proper mopar sensors?


Sent from my iPhone using Tapatalk
jwheeler is offline   Reply With Quote
Old 11-07-2016, 11:52 PM   #7 (permalink)
 
Limeybastard's Avatar
Senior Member
 
Join Date: Jul 2015
Location: Shady Hills, Rednecksville Boro, Florida.
Age: 46
Posts: 1,561

Ram Year: 2015
Engine: Hemi 5.7
Default
Originally Posted by jwheeler View Post
You are still having problems with the TPMS? Where did your sensors go? Are the new ones that are in now the proper mopar sensors?


Sent from my iPhone using Tapatalk

Hi,

Guess what? The dealer never called me back. Not withstanding the tpms sensors, remember I had originally had my overhead console replaced since the homelink didnt transmit sometimes. They replaced the complete overhead console with homelink and it still failed, luckily also failed in front of them when I showed it .The service fella stated that they would be contacting HQ for research LOL. That was over 2 months ago?

Around that time I had also supplied to them 4 2015 genuine FCA TPMS sensors to fit for me of which none still register - double LOL.
The part number was the correct ones, which I dont have on hand. They claimed they checked the sensors for operation before installing , they also claimed one didnt work after installation, he used a device prior to check and also device to check once they were installed to say one failed. So unsure why 3 still do not register on my EVIC. Oh well, back to square one. Perhaps its time I played another round of Russian roullete and try another main dealer. Or better still just count myself lucky and move on, I really dont care much about the TPMS sensors, but wouldnt mind getting my overhead console fixed.

The only clue and hunch I have is the following, on my first ever visit to this dealer, they did a PCM tcm flash when my truck did not have TPMS sensors installed, truck showed psi on all four corners for a few hours afterwards then went back to -- -- -- -- dashes, so perhaps them flashing the truck when no TPMS sensors was present messed things up.. My wild guess. They checked the sensors with their remote tool and like I mentioned earlier, 3 of the 4 were working according to their tool / wand. But EVIC shows nothing on all corners.

Last edited by Limeybastard; 11-08-2016 at 12:05 AM.
Limeybastard is offline   Reply With Quote
Old 11-11-2016, 06:43 PM   #8 (permalink)
Senior Member
 
Join Date: Jan 2011
Name: steve
Age: 59
Posts: 1,055

Ram Year: 2016
Engine: hemi 5.7
Default
i would go back and let them attempt one more try at getting it right. i suspect they didnt install the defective sensor.
huntergreen is offline   Reply With Quote
Old 01-09-2017, 01:22 PM   #9 (permalink)
 
Limeybastard's Avatar
Senior Member
 
Join Date: Jul 2015
Location: Shady Hills, Rednecksville Boro, Florida.
Age: 46
Posts: 1,561

Ram Year: 2015
Engine: Hemi 5.7
Default
No one ever got back to me about the garage door opener. I'm going to let it go. Will just carry on using a separate garage door opener. Sucks but it is what it is.

Sent from my Z981 using Tapatalk
Limeybastard is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are all Ram Techs incompetent idiots? cptwing General Discussions 71 09-17-2015 07:47 AM
New weather techs! tradesman 1972 Interior 15 02-27-2014 11:05 AM
I need to rant on dealer service techs dpinvidic General Discussions 53 02-20-2014 11:10 AM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum