Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 3rd Gen : 2002 - 2008 > Tech Info


Tech Info

Heater blower motor - stopped working


This is a discussion on Heater blower motor - stopped working within the Tech Info forums, part of the 3rd Gen : 2002 - 2008 category!
Ok was driving & doing errands today, blower motor working good - no problems. Then after dropping stuff at home, ...


Reply
 
LinkBack Thread Tools Display Modes
Old 12-10-2016, 07:59 PM   #1 (permalink)
 
HeavyD's Avatar
Senior Member
 
Join Date: Feb 2015
Location: Medicine Hat, Alberta - Canada
Age: 35
Posts: 1,115

Ram Year: 2004
Engine: 4.7 SOHC 5 SP Auto
Question Heater blower motor - stopped working
Ok was driving & doing errands today, blower motor working good - no problems.
Then after dropping stuff at home, got back in the truck & blower motor does not do anything.
Checked the #4 fuse, even swapped it with another & still nothing.

Im guessing its mot the switch or resistor.

So is the motor gone??

Its stupid cold outside so did not check power at the motor, so don't know it has power or not.


Sponsored Ad
Register to remove this ad.


__________________
2004 Ram 1500 QC SB 2wd 4.7L - E-fan Conversion, Airaid Intake tube & Filter through Awesome Hood scoop, DJM flip kit 4 3/4" rear. 2 3/4" front. Lots of chrome added. Superchips Vivid. Borla Duals. Lund Tri-fold. 20" Dodge rims. Powertrax No-Slip. Durango R/T front Power Seats. OEM Step Bars. My Thread
HeavyD is offline   Reply With Quote
Old 12-10-2016, 10:26 PM   #2 (permalink)
Junior Member
 
Join Date: Nov 2016
Location: Bedford, va
Posts: 7

Ram Year: 2003
Engine: 5.7
Default
I could be the motor is bad. I also had one truck where the ignition switch had melted some causing the blower not to work.
Bigguy45 is offline   Reply With Quote
Old 12-11-2016, 07:18 PM   #3 (permalink)
 
HeavyD's Avatar
Senior Member
 
Join Date: Feb 2015
Location: Medicine Hat, Alberta - Canada
Age: 35
Posts: 1,115

Ram Year: 2004
Engine: 4.7 SOHC 5 SP Auto
Default
Ok had the motor out & bearings are bad not it still works on bench, it just stops fast after power is off.

so I hooked it back to the truck plug & it only works when I add power to the plug.

So I think this Is a burnt ignition switch.

Is it hard to replace the ignition switch

I will also replace the fan since it on the out.


__________________
2004 Ram 1500 QC SB 2wd 4.7L - E-fan Conversion, Airaid Intake tube & Filter through Awesome Hood scoop, DJM flip kit 4 3/4" rear. 2 3/4" front. Lots of chrome added. Superchips Vivid. Borla Duals. Lund Tri-fold. 20" Dodge rims. Powertrax No-Slip. Durango R/T front Power Seats. OEM Step Bars. My Thread
HeavyD is offline   Reply With Quote
Old 12-11-2016, 10:08 PM   #4 (permalink)
 
HeavyD's Avatar
Senior Member
 
Join Date: Feb 2015
Location: Medicine Hat, Alberta - Canada
Age: 35
Posts: 1,115

Ram Year: 2004
Engine: 4.7 SOHC 5 SP Auto
Default
found vid on y-tube, buying parts tomorrow.


__________________
2004 Ram 1500 QC SB 2wd 4.7L - E-fan Conversion, Airaid Intake tube & Filter through Awesome Hood scoop, DJM flip kit 4 3/4" rear. 2 3/4" front. Lots of chrome added. Superchips Vivid. Borla Duals. Lund Tri-fold. 20" Dodge rims. Powertrax No-Slip. Durango R/T front Power Seats. OEM Step Bars. My Thread
HeavyD is offline   Reply With Quote
Old 12-12-2016, 03:33 PM   #5 (permalink)
 
HeavyD's Avatar
Senior Member
 
Join Date: Feb 2015
Location: Medicine Hat, Alberta - Canada
Age: 35
Posts: 1,115

Ram Year: 2004
Engine: 4.7 SOHC 5 SP Auto
Default
Ignition switch & heater fan/motor.
The switch was about what prices are on the net, but the heater motor was way more.







__________________
2004 Ram 1500 QC SB 2wd 4.7L - E-fan Conversion, Airaid Intake tube & Filter through Awesome Hood scoop, DJM flip kit 4 3/4" rear. 2 3/4" front. Lots of chrome added. Superchips Vivid. Borla Duals. Lund Tri-fold. 20" Dodge rims. Powertrax No-Slip. Durango R/T front Power Seats. OEM Step Bars. My Thread
HeavyD is offline   Reply With Quote
Old 12-12-2016, 04:38 PM   #6 (permalink)
 
HeavyD's Avatar
Senior Member
 
Join Date: Feb 2015
Location: Medicine Hat, Alberta - Canada
Age: 35
Posts: 1,115

Ram Year: 2004
Engine: 4.7 SOHC 5 SP Auto
Default
New ignition switch in & with old fan it works.

Will be putting fan in yet today.





__________________
2004 Ram 1500 QC SB 2wd 4.7L - E-fan Conversion, Airaid Intake tube & Filter through Awesome Hood scoop, DJM flip kit 4 3/4" rear. 2 3/4" front. Lots of chrome added. Superchips Vivid. Borla Duals. Lund Tri-fold. 20" Dodge rims. Powertrax No-Slip. Durango R/T front Power Seats. OEM Step Bars. My Thread
HeavyD is offline   Reply With Quote
Old 12-12-2016, 07:28 PM   #7 (permalink)
 
HeavyD's Avatar
Senior Member
 
Join Date: Feb 2015
Location: Medicine Hat, Alberta - Canada
Age: 35
Posts: 1,115

Ram Year: 2004
Engine: 4.7 SOHC 5 SP Auto
Default
All back together, the ignition switch is tight but works good.







__________________
2004 Ram 1500 QC SB 2wd 4.7L - E-fan Conversion, Airaid Intake tube & Filter through Awesome Hood scoop, DJM flip kit 4 3/4" rear. 2 3/4" front. Lots of chrome added. Superchips Vivid. Borla Duals. Lund Tri-fold. 20" Dodge rims. Powertrax No-Slip. Durango R/T front Power Seats. OEM Step Bars. My Thread
HeavyD is offline   Reply With Quote
Old 12-12-2016, 10:41 PM   #8 (permalink)
Junior Member
 
Join Date: Nov 2016
Location: Bedford, va
Posts: 7

Ram Year: 2003
Engine: 5.7
Default
Glad to hear it
Bigguy45 is offline   Reply With Quote
Old 12-28-2016, 09:02 PM   #9 (permalink)
Junior Member
 
Join Date: Nov 2016
Posts: 9

Ram Year: 2004
Engine: 5.7 hemi
Default
Did the exact thing last month. Except I changed the motor, then the resistor, then the control unit, and finally, after the dealer diagnosed it, I changed the ign. switch. They wanted over 500, including diagnose, and the ign. cable, which it didn't need.
snuffysmiff is offline   Reply With Quote
Old 01-22-2017, 09:58 AM   #10 (permalink)
Junior Member
 
Join Date: Jan 2017
Age: 50
Posts: 2

Ram Year: 2006
Engine: 5.7
Default Ignition switch
I had my blower motor go out then I replaced the fan motor and it is working but got a immediate. Dash light for engine could the ignition switch be bad too. It is giving me a p750 code and can't reset it.
Browns06 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC/heater blower problems Sbuford Tech Info 4 11-27-2016 07:51 PM
Heater blower motor AkNomad Engine & Performance 4 11-08-2016 09:23 PM
Heater stopped blowing warm air. ear77 General Discussion 3 10-07-2016 07:51 PM
Low and High beams on one side stopped working...then started...then stopped Scurti5 Exterior 6 06-29-2015 01:09 AM
Heater blower question dss56 General Discussions 4 02-04-2015 01:43 PM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum