Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 2nd Gen : 1994 - 2002 > General Discussion


General Discussion

Something is killing my battery


This is a discussion on Something is killing my battery within the General Discussion forums, part of the 2nd Gen : 1994 - 2002 category!
Originally Posted by dudeman2009 4 milliamps is about right. After 10-30 minutes that would have risen slightly, but thats ok. ...


Reply
 
LinkBack Thread Tools Display Modes
Old 12-29-2016, 02:08 AM   #11 (permalink)
Junior Member
 
Join Date: Dec 2016
Location: California
Age: 25
Posts: 5

Ram Year: 1999 Dodge Ram 1500 Sport
Engine: 5.2L
Default
Originally Posted by dudeman2009 View Post
4 milliamps is about right. After 10-30 minutes that would have risen slightly, but thats ok. Any problems on this age of vehicle would've been apparent right away.

I would complete that second test I wanted you to do, or clean off the top of the battery really well.

To test the alternator, start the vehicle and let it idle for about 5 minutes. Then turn on everything, high beams, fogs, high speed blower motor, interior lights, etc. and let it idle for another minute. Then test voltage at a few places.

Across the battery terminals.
From battery positive to bare metal on the engine or the alternator casing.
From battery negative to the alternator positive stud.

The battery terminal measurement is your baseline, neither of the other two readings should vary from it by more than a volt. The battery voltage should be no lower than 12.8V during the test.

To test the battery, charge it first. To test if it is charged measure the terminal voltage with the lights off. If the reading is above 12.8V you must first remove the surface charge by running the headlights for 2 minutes. Then let the battery settle for 5-10 minutes after that. Then measure the battery voltage, it should read no lower than 12.4V. Anything less indicates a weak battery for a standard flooded lead acid battery.
I will try the second test tomorrow. The top of the battery is pretty clean as its only 3 months old.

I will also do the other test mentioned and get back to you on the results.


Sponsored Ad
Register to remove this ad.
C2ndLTpigeon is offline   Reply With Quote
Reply

Bookmarks

Tags
battery dead, volt short

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Killing some chrome! Tyler__Beck Exterior 1 10-15-2014 09:56 PM
Its killing me!!!! Razzaa Engine & Performance 5 09-20-2013 04:47 PM
Starter solenoid/alternator/battery junction for dual battery? 12TrueSport Audio & Electronics 10 07-09-2013 05:56 PM
Killing TM with Trinity UNBROKEN Engine & Performance 17 12-26-2012 06:36 PM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum