Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 2nd Gen : 1994 - 2002 > Engine & Performance


Engine & Performance

I think my fuel pump went out


This is a discussion on I think my fuel pump went out within the Engine & Performance forums, part of the 2nd Gen : 1994 - 2002 category!
Ok so I started the truck and let it idle for a rough 30 mins or so then I got ...


Like Tree4Likes

Sponsored By: Moe's Performance
Reply
 
LinkBack Thread Tools Display Modes
Old 01-06-2017, 05:13 PM   #1 (permalink)
 
e_hartzell17's Avatar
Senior Member
 
Join Date: Jul 2016
Age: 20
Posts: 110

Ram Year: 2001
Engine: 5.2 318
Default I think my fuel pump went out
Ok so I started the truck and let it idle for a rough 30 mins or so then I got in it hit the skinny pedal on the right a little and boom she died, when I went to go crank it it didn't start back up, so I left the key on and got out to hear like a hairdryer sound coming from my fuel tank and I'm pretty sure my fuel pump went bad not positive though. Any body ever have this happen if so I could really use an explanation haha.


Sponsored Ad
Register to remove this ad.
e_hartzell17 is offline   Reply With Quote
Old 01-06-2017, 05:39 PM   #2 (permalink)
Senior Member
 
Join Date: Feb 2016
Location: Lansing, Michigan
Age: 21
Posts: 1,178

Ram Year: 2001 1500 Sport with enough electrical modifications to make your head spin
Engine: Magnum 360
Default
Is their fuel in it? The gauge may be wrong.

Try hitting the tank with a hammer, or getting a fuel rail pressure test kit, you can rent them from autozone.

It should only prime for 5 seconds or less, usually if it tries to prime longer than that, it indicates a problem. Is there any fluid leaking?
dudeman2009 is offline   Reply With Quote
Old 01-07-2017, 12:15 PM   #3 (permalink)
 
dapepper9's Avatar
Supporting Member

 
Join Date: Feb 2013
Location: Iowa/Nebraska Border
Age: 21
Posts: 4,578

Ram Year: 2001
Engine: 5.9L V8
Default
Whine from the tank is a good thing. It means the pump is at minimum trying to work and is getting signal. If you hear it whine, check rail pressure for about 50psi +/- 2psi. Good pressure, pump whines, likely going to be spark
Yeret likes this.


__________________


2001 Ram 1500 QCSB, 2" HBS level 285/70/17 Toyo OpenCountry AT2s, M1 2bbl, F&B 52x55mm TB, Pacesetter Longtube headers, CarvenTR, M1 91 Octane canned tune by FlyinRyan, 4.56 gears+Eaton TrueTrack remote start, HS 1.7 RRs, Custom RetroFit 6500K HID
dapepper9 is offline   Reply With Quote
Old 01-07-2017, 11:36 PM   #4 (permalink)
 
texasrebel's Avatar
Member
 
Join Date: Jan 2017
Age: 20
Posts: 85

Ram Year: 1995
Engine: 5.9 Magnum
Default
Mine went out about a year ago. Found easiest way to access it since it had a full tank, was to lift the bed. Dropping a full tank isn't fun.

Sent from my SAMSUNG-SM-G870A using Tapatalk
texasrebel is offline   Reply With Quote
Old 01-07-2017, 11:38 PM   #5 (permalink)
 
e_hartzell17's Avatar
Senior Member
 
Join Date: Jul 2016
Age: 20
Posts: 110

Ram Year: 2001
Engine: 5.2 318
Default
Originally Posted by texasrebel View Post
Mine went out about a year ago. Found easiest way to access it since it had a full tank, was to lift the bed. Dropping a full tank isn't fun.

Sent from my SAMSUNG-SM-G870A using Tapatalk


Well luckily for me I'm under a 1/4 tank but it's weird cuz about 2 hours after I though she went out, it started right back up no problems


Sent from my iPhone using Tapatalk
e_hartzell17 is offline   Reply With Quote
Old 01-07-2017, 11:42 PM   #6 (permalink)
 
texasrebel's Avatar
Member
 
Join Date: Jan 2017
Age: 20
Posts: 85

Ram Year: 1995
Engine: 5.9 Magnum
Default
Originally Posted by e_hartzell17 View Post
Well luckily for me I'm under a 1/4 tank but it's weird cuz about 2 hours after I though she went out, it started right back up no problems


Sent from my iPhone using Tapatalk
Hm. Kinda odd. Might still want to get someone to test the system.

Sent from my SAMSUNG-SM-G870A using Tapatalk
texasrebel is offline   Reply With Quote
Old 01-07-2017, 11:43 PM   #7 (permalink)
 
e_hartzell17's Avatar
Senior Member
 
Join Date: Jul 2016
Age: 20
Posts: 110

Ram Year: 2001
Engine: 5.2 318
Default
Originally Posted by texasrebel View Post
Hm. Kinda odd. Might still want to get someone to test the system.

Sent from my SAMSUNG-SM-G870A using Tapatalk


Yeah for sure another good thing though is wishing the next few months I'm putting a turbo setup on the truck so new fuel pumps going in anyway


Sent from my iPhone using Tapatalk
e_hartzell17 is offline   Reply With Quote
Old 01-07-2017, 11:45 PM   #8 (permalink)
 
texasrebel's Avatar
Member
 
Join Date: Jan 2017
Age: 20
Posts: 85

Ram Year: 1995
Engine: 5.9 Magnum
Default
Originally Posted by e_hartzell17 View Post
Yeah for sure another good thing though is wishing the next few months I'm putting a turbo setup on the truck so new fuel pumps going in anyway


Sent from my iPhone using Tapatalk
Turbo setup? You have my interest.

Sent from my SAMSUNG-SM-G870A using Tapatalk
texasrebel is offline   Reply With Quote
Old 01-07-2017, 11:47 PM   #9 (permalink)
 
e_hartzell17's Avatar
Senior Member
 
Join Date: Jul 2016
Age: 20
Posts: 110

Ram Year: 2001
Engine: 5.2 318
Default
Originally Posted by texasrebel View Post
Turbo setup? You have my interest.

Sent from my SAMSUNG-SM-G870A using Tapatalk


Lol yeah gonna be running a remote mounted hy35 cummins turbo tuned with sct with a warlbro 225 fuel pump, ford cobra 39# injectors, 8psi wastegate and a mild comp cam


Sent from my iPhone using Tapatalk
e_hartzell17 is offline   Reply With Quote
Old 01-07-2017, 11:49 PM   #10 (permalink)
 
texasrebel's Avatar
Member
 
Join Date: Jan 2017
Age: 20
Posts: 85

Ram Year: 1995
Engine: 5.9 Magnum
Default
Originally Posted by e_hartzell17 View Post
Lol yeah gonna be running a remote mounted hy35 cummins turbo tuned with sct with a warlbro 225 fuel pump, ford cobra 39# injectors, 8psi wastegate and a mild comp cam


Sent from my iPhone using Tapatalk
You got any idea what kinda power boost your gonna get? IIRC, the stock internals can only handle around 9lbs up top before the heads start floating and around 12 on the bottom end. Got a build thread for this?

Sent from my SAMSUNG-SM-G870A using Tapatalk
texasrebel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pump Oscar hemi General Discussions 2 07-21-2016 09:53 AM
Fuel pump? Tyson Engine & Performance 1 08-06-2015 02:57 PM
Fuel Problem, not the fuel pump pwebyd90 Tech Info 23 04-23-2015 07:31 PM
Fuel Pump? sabre Engine & Performance 2 12-09-2013 06:23 PM
Fuel Pump? ramman54 Engine & Performance 2 09-10-2013 11:41 PM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum