Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 2nd Gen : 1994 - 2002 > Engine & Performance


Engine & Performance

Unknown Problems.


This is a discussion on Unknown Problems. within the Engine & Performance forums, part of the 2nd Gen : 1994 - 2002 category!
Whenever I accelerate hard (like when I pass somebody on the highway) I've noticed that my check engine light starts ...


Sponsored By: Moe's Performance
Reply
 
LinkBack Thread Tools Display Modes
Old 12-26-2016, 03:15 PM   #1 (permalink)
 
bluwarguy's Avatar
Member
 
Join Date: Oct 2016
Age: 17
Posts: 47

Ram Year: 1997
Engine: 5.9 Magnum V8
Default Unknown Problems.
Whenever I accelerate hard (like when I pass somebody on the highway) I've noticed that my check engine light starts to flash. The check engine light is also on and gives me 2 codes: 12 and 43. My oil consumption is awful and I have to constantly buy oil for my truck. Sometimes when starting it in the cold, it doesn't like to stay on and I have to slightly give it gas for about a minute and it'll stay on. If not then it sputters and dies. Are any of these problems related and what could the main problem be?


Sponsored Ad
Register to remove this ad.


__________________
http://i987.photobucket.com/albums/ae356/wwiiiprod/yeeyee_zpswapzodeh.jpg
Jegs Off Road Y-Pipe, Stant 180 Deg. Thermostat, Mota 14x2 Air Cleaner, Spectre Breather Filter, MSD Blaster Ignition Coil, BWD Distributor and Rotor, Champion Spark Plugs, AC Delete, Valvoline Fully Synthetic 10W-30
bluwarguy is offline   Reply With Quote
Old 12-26-2016, 03:26 PM   #2 (permalink)
Senior Member
 
Join Date: Feb 2016
Location: Lansing, Michigan
Age: 21
Posts: 911

Ram Year: 2001 1500 Sport with enough electrical modifications to make your head spin
Engine: Magnum 360
Default
Oil consumption followed by cylinder misfire (Generally what the flashing CEL means) on a dodge means its time for the plenum.

Code 12 just means the battery has been disconnected within a certain number of ignition cycles.

Code 43 could be a couple things but usually is random multiple cylinder misfire.

I'd go with the plenum but you can also check your ignition coil.

Measure the resistance of your coil from the tower to a pin on the input you should get about 12k-15kohms. Between the two input pins should read about 1-2ohms. If either is wildly off, replace the coil.
dudeman2009 is offline   Reply With Quote
Old 12-26-2016, 03:31 PM   #3 (permalink)
 
bluwarguy's Avatar
Member
 
Join Date: Oct 2016
Age: 17
Posts: 47

Ram Year: 1997
Engine: 5.9 Magnum V8
Default
so Code 43 could be fixed with the plenum kit?


__________________
http://i987.photobucket.com/albums/ae356/wwiiiprod/yeeyee_zpswapzodeh.jpg
Jegs Off Road Y-Pipe, Stant 180 Deg. Thermostat, Mota 14x2 Air Cleaner, Spectre Breather Filter, MSD Blaster Ignition Coil, BWD Distributor and Rotor, Champion Spark Plugs, AC Delete, Valvoline Fully Synthetic 10W-30
bluwarguy is offline   Reply With Quote
Old 12-26-2016, 03:42 PM   #4 (permalink)
 
pajeepman's Avatar
Senior Member
 
Join Date: Aug 2015
Location: SE PA
Posts: 120

Ram Year: 2003
Engine: 5.9 magnum
Default
Oil loss without visible leak is almost certainly a plenum issue. I replaced mine with an aluminum one from ebay. No issues for 4 months so far.

Sent from my SM-J320P using Tapatalk
pajeepman is offline   Reply With Quote
Old 12-26-2016, 10:18 PM   #5 (permalink)
 
dapepper9's Avatar
Supporting Member

 
Join Date: Feb 2013
Location: Iowa/Nebraska Border
Age: 21
Posts: 4,338

Ram Year: 2001
Engine: 5.9L V8
Default
Yes start with plenum and in the process of doing it do a tune up as well


__________________


2001 Ram 1500 QCSB, 2" HBS level 285/70/17 Toyo OpenCountry AT2s, M1 2bbl, F&B 52x55mm TB, Pacesetter Longtube headers, 18" Magnaflow, M1 91 Octane canned tune by FlyinRyan, remote start, HS 1.7 RRs, Custom RetroFit 6500K HID, Soon to be boosted...
dapepper9 is offline   Reply With Quote
Old 12-28-2016, 02:11 PM   #6 (permalink)
 
bluwarguy's Avatar
Member
 
Join Date: Oct 2016
Age: 17
Posts: 47

Ram Year: 1997
Engine: 5.9 Magnum V8
Default
I bought an OBDII reader and found that the code is specifically P0308, so Cylinder 8 is the one misfiring.


__________________
http://i987.photobucket.com/albums/ae356/wwiiiprod/yeeyee_zpswapzodeh.jpg
Jegs Off Road Y-Pipe, Stant 180 Deg. Thermostat, Mota 14x2 Air Cleaner, Spectre Breather Filter, MSD Blaster Ignition Coil, BWD Distributor and Rotor, Champion Spark Plugs, AC Delete, Valvoline Fully Synthetic 10W-30
bluwarguy is offline   Reply With Quote
Old 12-28-2016, 02:43 PM   #7 (permalink)
Senior Member
 
Join Date: Feb 2016
Location: Lansing, Michigan
Age: 21
Posts: 911

Ram Year: 2001 1500 Sport with enough electrical modifications to make your head spin
Engine: Magnum 360
Default
Cylinders 7 and 8 are the most common ones to go with plenum issues.
dudeman2009 is offline   Reply With Quote
Old 12-29-2016, 03:19 PM   #8 (permalink)
 
dapepper9's Avatar
Supporting Member

 
Join Date: Feb 2013
Location: Iowa/Nebraska Border
Age: 21
Posts: 4,338

Ram Year: 2001
Engine: 5.9L V8
Default
Cylinder 8? Plenum


__________________


2001 Ram 1500 QCSB, 2" HBS level 285/70/17 Toyo OpenCountry AT2s, M1 2bbl, F&B 52x55mm TB, Pacesetter Longtube headers, 18" Magnaflow, M1 91 Octane canned tune by FlyinRyan, remote start, HS 1.7 RRs, Custom RetroFit 6500K HID, Soon to be boosted...
dapepper9 is offline   Reply With Quote
Old 12-31-2016, 01:00 PM   #9 (permalink)
 
pajeepman's Avatar
Senior Member
 
Join Date: Aug 2015
Location: SE PA
Posts: 120

Ram Year: 2003
Engine: 5.9 magnum
Default
Plenum guaranteed. Same problem i had minus the not staying running.

Sent from my SM-J320P using Tapatalk
pajeepman is offline   Reply With Quote
Old 01-01-2017, 11:44 PM   #10 (permalink)
Junior Member
 
Join Date: Oct 2016
Location: Washington State
Posts: 28

Ram Year: 1999
Engine: 5.9L
Default
We recently bought an aluminum plenum kit from Hughes engines and it included all gaskets, bolts, etc. needed for $142 total for shipping and the kit.
Truemagnum15 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
unknown hose jasonb Engine & Performance 5 02-01-2016 08:47 PM
Unknown plug jabartram General Discussions 13 11-16-2015 04:47 PM
Unknown connectors? smoothee Interior 5 09-18-2015 10:22 PM
Unknown chime acejones General Discussions 5 08-06-2015 08:48 AM
unknown whine JnJ's Hemi Engine & Performance 24 04-17-2013 04:26 PM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum