Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > Dodge Ram Cummins Diesel Forum > 5.9 Common Rail


5.9 Common Rail

2007 5.9 won't crank


This is a discussion on 2007 5.9 won't crank within the 5.9 Common Rail forums, part of the Dodge Ram Cummins Diesel Forum category!
I have a 2007 5.9L and the past couple of days it's acted like the battery was starting to go. ...


Reply
 
LinkBack Thread Tools Display Modes
Old 07-15-2016, 11:10 PM   #1 (permalink)
Junior Member
 
Join Date: Jul 2016
Age: 27
Posts: 1

Ram Year: 2007
Engine: 5.9L cummins
Default 2007 5.9 won't crank
I have a 2007 5.9L and the past couple of days it's acted like the battery was starting to go. It would start to turn over then stop then keep turning over and fire up. Went back to get in it today after driving it yesterday and it won't do anything. I tried jumping it off with jumper cables and also a jump box but it wouldn't even start to turn over. I checked all fuses and none are blown. I've checked the grounds on the side of the block and the connections on the batteries. Did a load test on the batteries to make sure they were still good. All of that checked out fine, what's getting me is if you turn the key backwards then all of the accessories (radio, pillar gauges) all come on and work properly. If you turn the key forward like you're going to start it, the interior lights go dim or cut off, all of the dash lights go off, the relays behind the main gauge cluster starts flicking back and forth and it doesn't even start to turn over and acts like the batteries are dead but everything works perfectly with the key turn backwards. I pulled the grounds off of the battery to try to reset the computer and the wcm and also pulled the fuses for the wcm and let it sit for 10 minutes before hooking it back up with the same results. I'm completely stumped and would appreciate any input anyone has to try to fix this problem.


Sponsored Ad
Register to remove this ad.
Granttj55 is offline   Reply With Quote
Old 07-18-2016, 01:38 AM   #2 (permalink)
 
R.L.K.'s Avatar
Supporting Member

 
Join Date: Dec 2013
Location: Bristol , Tn.
Posts: 8,590

Ram Year: 2014 4X4 QC Express 6 speed auto 355 differentials
Engine: 5.7 Hemi
Default
Hate that for ya .
Maybe the xsmn shifting position switch is shorting out ?

Try putting it in Nutral and see if she cranks .
My last Dodge had a shift sensor go out on it , but I could start in Nutral , sometimes even in Nutral I'd have to actuate the steering wheel tilt " roughly " a couple times but it would start everytime ...

Last edited by R.L.K.; 07-18-2016 at 01:40 AM.
R.L.K. is offline   Reply With Quote
Old 08-20-2016, 01:06 AM   #3 (permalink)
 
BWC's Avatar
BWC
Member
 
Join Date: Sep 2015
Location: Northern CO
Age: 22
Posts: 72

Ram Year: 2003
Engine: Cummins
Default
Can always try to shift through the gears and put it back in park.

Also I had a buddy have a similar issue and it ended up being a bad ground in this harness


__________________
2003 Cummins plenty of fuel and plenty of air (11.3 at 123mph at 5800ft)
2002 Cummins 22" Forces on 35" toyos (Sold)
2004 Cummins twin pumps, Compounds, built trans (Sold)
BWC is offline   Reply With Quote
Old 08-20-2016, 02:40 AM   #4 (permalink)
 
crash68's Avatar
Senior Member
 
Join Date: Mar 2016
Posts: 731

Ram Year: 2015
Engine: 3.0 EcoDiesel
Default
Could be your TIPM. It looks like your fuse box under the hood but it also controls the power to just about everything in the truck including cranking the engine over.
crash68 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil on crank sensor boolinhemi Engine & Performance 12 10-13-2015 10:32 AM
No crank 03hemi Tech Info 1 04-17-2015 03:42 PM
Key Crank done!!! Notsobroke Lifted 8 05-28-2013 10:28 AM
T-Bars Crank willt10 General Discussions 8 05-13-2012 01:48 PM
Got to crank them down GhostRam94 Lifted 7 05-04-2012 12:33 AM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum