Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > Dodge Ram Cummins Diesel Forum > 6.7 Common Rail


6.7 Common Rail

Help!


This is a discussion on Help! within the 6.7 Common Rail forums, part of the Dodge Ram Cummins Diesel Forum category!
So, my '14 Ram dually 4x4 Today when I started it up in 7 degrees, after it got warm it ...


Like Tree1Likes
  • 1 Post By Power247

Reply
 
LinkBack Thread Tools Display Modes
Old 12-16-2016, 06:44 PM   #1 (permalink)
 
hounddog's Avatar
Senior Member
 
Join Date: Jun 2012
Location: Charlevoix, MI
Posts: 353

Ram Year: 2014 Bighorn CC 4x4 dually
Engine: 6.7 Cummins HO / Aisin +3.73 gears
Default Help!
So, my '14 Ram dually 4x4

Today when I started it up in 7 degrees, after it got warm it indicated "Perform Service" but otherwise acted normal, 4x4 worked fine to pull me down the snowy roads, and drove it about 25 miles. Zero performance issues, and I felt the truck was telling me to do basic services to it, fuel filter/transmission service/that sort of thing.

Hooked to my 5th wheel to move it, everything was fine.
Went to the first stoplight, truck shifted from 2nd to overdrive and wouldn't shift out of OD.

Then I got a check engine light, a light for the traction control/anti-slip system, a message to service the electric braking system, and then I discovered the 4x4 system was no longer working- won't even indicate it's trying to engage. All these lights and messages remain turned on.

This truck does have the wiring harness recall, but of course it's on permanent backorder.

The transmission will reset if I put it in park and shut it off. But, every time I get to speed and let off the throttle it shifts straight to overdrive and won't shift out. Regardless of what gear I hold it in it shifts strsight to OD and stays until I put it back in park and shut it off.

I should mention the grid heater randomly stopped working last week, and from literally one day to the next about the same time the parking brake went to working properly to not fully engaging but partially engaging.

Anyone ever heard of such a thing? Can all of this be connected to the computer? Maybe that wiring harness ram recalled?


Sponsored Ad
Register to remove this ad.

Last edited by hounddog; 12-16-2016 at 06:51 PM.
hounddog is offline   Reply With Quote
Old 12-16-2016, 09:06 PM   #2 (permalink)
 
Power247's Avatar
Senior Member
 
Join Date: Jul 2012
Location: High Point, NC
Name: Greg
Age: 41
Posts: 5,413

Ram Year: 2012
Engine: CTD 6.7
Default
Dang man. Definitely something screwy. I know low battery voltage will have the canbus going crazy but I would think that you would have trouble starting too. I guess a bad computer would cause all that too. Hope you can get it sorted quickly

Greg
2012 | RAM 2500 | CCSB | Custom tuned by Double R Diesel
2016 | Heartland Pioneer | DS310
hounddog likes this.


__________________
Build Thread Upgrading the factory Alpine system

2012 2500 4x4 CTD Big Horn CCSB 3.73|Flo~Pro|SIMS|XRT Pro w/MCC|Edge Insight CTS|Infinity|JBL
2009 1500 4x4 HEMI Big Horn CCSB 3.55|Volant CAI|18" Magnaflow|Airlift1000|Superchips Flashpaq 3865 - SOLD
Power247 is offline   Reply With Quote
Old 12-16-2016, 09:55 PM   #3 (permalink)
 
hounddog's Avatar
Senior Member
 
Join Date: Jun 2012
Location: Charlevoix, MI
Posts: 353

Ram Year: 2014 Bighorn CC 4x4 dually
Engine: 6.7 Cummins HO / Aisin +3.73 gears
Default
It seems like there's way too much going on for it to be mechanical.

It "feels" like it's all related because it all happened within the same time frame, except for the heater grid and parking brake. They happened at the same time together.


__________________


A true friend will be sitting in the jail cell next to you going, "HELL YEA that was fun!"
hounddog is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum