Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram General Forum > Garage


Garage

Power washer help


This is a discussion on Power washer help within the Garage forums, part of the Dodge Ram General Forum category!
Hey all, Need some help getting my power washer running, I'm at a loss. At the end of last season, ...


Like Tree4Likes
  • 1 Post By Pull Ya
  • 1 Post By Jwithing
  • 2 Post By chopperman1

Reply
 
LinkBack Thread Tools Display Modes
Old 09-05-2017, 02:13 PM   #1 (permalink)
Senior Member
 
Join Date: Mar 2017
Location: STL
Posts: 532

Ram Year: 2015
Engine: 5.7
Default Power washer help
Hey all,

Need some help getting my power washer running, I'm at a loss. At the end of last season, it would start but die immediately. I finally got around to looking at it. I dismantled and cleaned the carb, changed the gas, oil, and sparkplug, and cleaned the air filter. I used pump saver in it as well. I can't even get it to run. It'll turn over and act like it'll run, but doesn't fully startup. I tried spraying carb cleaner w/ the air filter off and no difference. It's an expensive unit, so I'd like to get it running vs. buying a new one.

TIA


Sponsored Ad
Register to remove this ad.
Jwithing is offline   Reply With Quote
Old 09-05-2017, 03:07 PM   #2 (permalink)
 
Pull Ya's Avatar
Supporting Member

 
Join Date: Jan 2012
Location: Cedar Creek, Tx
Posts: 3,820

Ram Year: 2016
Engine: 5.7 Hemi
Default
Did you put a new gas line on? They clog up pretty easy after the engine sits for awhile.
Jay
Skubasteve! likes this.


__________________
Semper Fi
'61-'65
Just cause it's loud don't make it fast and just cause it's shiney don't mean it's protected. Remember, going fast cost money, so just how fast do you wanna go?
Pull Ya is offline   Reply With Quote
Old 09-05-2017, 05:44 PM   #3 (permalink)
 
BlkZrx's Avatar
Senior Member
 
Join Date: Jan 2016
Location: northeast IN
Age: 65
Posts: 203

Ram Year: 2016 2500 SLT Std. cab
Engine: Hemi 6.4
Default
Do you keep relieving the pressure in the wand? Mine does that when cold. Helps if you keep the nozzle open till it's running well..

Sent from my LG-K540 using Tapatalk


__________________
Since when do pickups have more then 2 doors?
BlkZrx is offline   Reply With Quote
Old 09-05-2017, 05:47 PM   #4 (permalink)
Senior Member
 
Join Date: Mar 2017
Location: STL
Posts: 532

Ram Year: 2015
Engine: 5.7
Question
Originally Posted by BlkZrx View Post
Do you keep relieving the pressure in the wand? Mine does that when cold. Helps if you keep the nozzle open till it's running well..

Sent from my LG-K540 using Tapatalk
Yup, already considered
Jwithing is offline   Reply With Quote
Old 09-05-2017, 05:50 PM   #5 (permalink)
Senior Member
 
Join Date: Mar 2017
Location: STL
Posts: 532

Ram Year: 2015
Engine: 5.7
Default
Originally Posted by Pull Ya View Post
Did you put a new gas line on? They clog up pretty easy after the engine sits for awhile.
Jay
That could be worth checking out. Didn't think about it since gas came out when I disconnected to clean the carb, but it could have been residual after a blockage. I'd still expect it to startup after putting some carb cleaner directly into the carb. After it sits for a minute or so, it'll act like it's going to start, then nothing.
Pull Ya likes this.
Jwithing is offline   Reply With Quote
Old 09-05-2017, 07:27 PM   #6 (permalink)
 
chopperman1's Avatar
Senior Member
 
Join Date: Dec 2013
Location: Peoples Republic of Massachusetts
Posts: 239

Ram Year: 2016 Rebel
Engine: 5.7L HEMI
Default
Carb cleaner will not help start an engine, exact opposite actually. Get some starting fluid, spray a blast in the carb, if it starts the issue is gas related, if not then it's spark related.
Avgas and SYKRAMMAN like this.
chopperman1 is offline   Reply With Quote
Old 09-05-2017, 07:34 PM   #7 (permalink)
Senior Member
 
Join Date: Jul 2017
Location: Jersey shore
Age: 36
Posts: 338

Ram Year: 02 qcsb
Engine: 4.7 Dog
Default
^1 Take the plug out,put it against the head,pull start cord n see if you have spark.
SYKRAMMAN is offline   Reply With Quote
Old 09-13-2017, 06:04 PM   #8 (permalink)
 
averageguy's Avatar
Senior Member
 
Join Date: Dec 2014
Location: Belleville Mi
Age: 43
Posts: 431

Ram Year: 2015
Engine: hemi
Default
Did you actually take the jet out and make sure it wasn't plugged? Mine was stopped up last spring from sitting over the winter and have had this problem with other small engines. As stated, check for spark and use starting fluid. Do you treat your gas against ethanol damage? Stabilizers alone don't treat the ethanol problem. I have replaced one carbureator on a weed eater and one on a leaf blower.
averageguy is offline   Reply With Quote
Old 09-13-2017, 07:06 PM   #9 (permalink)
Senior Member
 
Join Date: Jun 2017
Posts: 190

Ram Year: 2015
Engine: 5.7
Default
I had a fuel filter go bad on my echo leaf blower, caused all sorts of issues and of course it was the LAST thing I checked. Didnt even know it had one.
Skubasteve! is offline   Reply With Quote
Old 09-13-2017, 07:50 PM   #10 (permalink)
 
Avgas's Avatar
Senior Member
 
Join Date: Sep 2015
Location: Florida
Posts: 478

Ram Year: 2015 Express
Engine: 3.6 Pentastar
Default
Originally Posted by chopperman1 View Post
Carb cleaner will not help start an engine, exact opposite actually. Get some starting fluid, spray a blast in the carb, if it starts the issue is gas related, if not then it's spark related.
+1

Use starting fluid, if it wont turn, check ignition coil.
Avgas is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pressure Washer mills3 Detailing 1 07-10-2017 12:00 PM
Windshield washer help lynchburg14 Tech Info 1 03-25-2016 08:01 AM
Gas or electric power washer? roadshow Detailing 13 02-04-2016 11:02 PM
Low washer fluid light Bakaehler Interior 5 04-19-2015 09:06 AM
Low washer warning USAF Long Tech Info 2 12-30-2013 06:12 PM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum