03 hemi Throwing emissions leak code- slight leak

Discussion in 'General Discussions' started by 2k2wranglerx, Feb 25, 2012.

  1. 2k2wranglerx

    2k2wranglerx Member

    Age:
    37
    Posts:
    69
    Likes Received:
    0
    Joined:
    Feb 19, 2012
    Ram Year:
    2003
    Engine:
    Hemi 5.7
    I replaced the gas cap thinking that might be it. I've heard grumblings about egr issues. Any advice on what I should check next?

    Thanks!
     
  2. 03MopaRamman

    03MopaRamman Senior Member

    Posts:
    3,578
    Likes Received:
    179
    Joined:
    Jul 3, 2010
    Location:
    Southern Alberta
    Ram Year:
    2003 Forgottens
    Engine:
    Hemi 5.7 (1 of 2)
    Good news no EGR on the 03, Bad news is you need to find the leak. I been battling this for a couple years, It yields it's ugly head in nice wether. I recommend you just keep reading about what to check. Could be as easy as some rubber hose and some small clamps or you may need to replace the two Items hidden under the Fuse Box (can't think of the Technical names right now cause I need a coffee).

    If you have a Tuner just erase the code once a week when it appears until you get it fixed that way if other probs appear on your Truck you'll want to know.
     
  3. 2k2wranglerx

    2k2wranglerx Member

    Age:
    37
    Posts:
    69
    Likes Received:
    0
    Joined:
    Feb 19, 2012
    Ram Year:
    2003
    Engine:
    Hemi 5.7
    Thanks. I rechecked this code after replacing the gas cap and it's a p0440 evap emission control system malfunction

    Any insight?
     
  4. BlackedOutHemi

    BlackedOutHemi Senior Member

    Age:
    23
    Posts:
    5,462
    Likes Received:
    186
    Joined:
    Feb 27, 2011
    Location:
    DFW, Texas
    Ram Year:
    2012 & 2012
    Engine:
    5.7L HEMI & 6.7L Cummins
    Did you clear the code after replacing the gas cap? And it came back?

    If it did. Here is what I found.
    http://www.obd-codes.com/p0440


    Sent from my iPhone using Tapatalk
     
  5. blazintowers

    blazintowers Member

    Age:
    50
    Posts:
    47
    Likes Received:
    0
    Joined:
    Feb 1, 2012
    Location:
    Santa Clarita, CA.
    Ram Year:
    2003
    Engine:
    5.7 hemi
    Happy 2014 ALL,

    i have a question regarding the possible solution on the page provided by BOH,
    it says check or replace purge valve/sensors, how do you check them? can you take them apart and clean them? also something about the canister being plugged and not working properly, can you unplug it? open and clean? oh yah, i failed my ca. smog test and this is the code read by a superchips programmer - P0440 : "general evap systems failure"

    thanks for any info! blazin
     
  6. Redtruck-VA

    Redtruck-VA Senior Member

    Posts:
    5,286
    Likes Received:
    665
    Joined:
    Jun 29, 2010
    Location:
    Virginia
    Ram Year:
    2003 & 1989 D250 RWD
    Engine:
    Hemi-5.7, 5.9 12v & 24v diesel
    There has been a lot written about this code and cures. First check is just changing the cap, but this may not fix it. Using your OEM cap try some vasoline or grease on the rubber seal to see if that does anything. Then check the emission canister and NVLD (Natural Vacuum Leak Detection system) hoses and clamps. Most likely IMO after the gas cap itself I would suspect broken clamps. The purge pump is located under the battery/IPM and has a hose running from the manifold and another going to the NVLD.
     
  7. blazintowers

    blazintowers Member

    Age:
    50
    Posts:
    47
    Likes Received:
    0
    Joined:
    Feb 1, 2012
    Location:
    Santa Clarita, CA.
    Ram Year:
    2003
    Engine:
    5.7 hemi
    thanks RedTruck, done alot of research and have checked lots of posts. lots of great info in here. still unsure if any of these pumps or nvld pump can be serviced or easier to just replace. Also where do you buy these special hoses? I have a two into one rubber connector that i cant find anywhere? who sells this special hoses. gonna see if i can attch a photo of it.....
     

    Attached Files:

  8. kx250frider617

    kx250frider617 Member

    Posts:
    41
    Likes Received:
    6
    Joined:
    Dec 13, 2013
    Ram Year:
    2003
    Engine:
    5.7
    I had that code, replaced all the hoses, fittings, gas cap etc and still got the code. It ended up being the leak detection pump. It's mounted next to the canister. It has two hose going to it along with a electrical connector. I haven't had the p0440 code since.
     
  9. blazintowers

    blazintowers Member

    Age:
    50
    Posts:
    47
    Likes Received:
    0
    Joined:
    Feb 1, 2012
    Location:
    Santa Clarita, CA.
    Ram Year:
    2003
    Engine:
    5.7 hemi
    thanks kx250f, guess that will be the next purchase. Believe it has the NVLD as opposed to the LDP? Saw it online for around $50. Hope thats it! already fixed some hoses, added clamps, new gas cap, think it needed it anyway...i will post results for future help on the P0440 repair!
     
  10. NELSONRICK

    NELSONRICK Junior Member

    Posts:
    1
    Likes Received:
    0
    Joined:
    Dec 19, 2016
    Ram Year:
    2003
    Engine:
    Hemi 5.7
    Blazintowers

    Blazintowers, did you ever find the vacuum tee you posted the picture of? Mine crumbled, and the dealer wants to sell the whole harness. Thank you!
     

Share This Page