1993 d150 no gauge lights, running lights, or horn

Discussion in 'Audio & Electronics' started by dirtydodgefromdelco, Feb 5, 2017.

  1. dirtydodgefromdelco

    dirtydodgefromdelco Junior Member

    Age:
    18
    Posts:
    2
    Likes Received:
    0
    Joined:
    Feb 5, 2017
    Ram Year:
    1993
    Engine:
    5.2L 318
    so I bought a 1993 d150 a few weeks ago, when I got the truck the stock radio did not work so I purchased an aftermarket pioneer radio. this is where the problem began. shortly after the new radio my dash and running lights went out and my horn does not work either. all of these things worked prior to installing the radio. I replaced the headlight switch and it did not help the issue. I checked the fuses and they are good but I have no power going to the fuse for gauge lights or to the horn relay. I can get the gauge lights to come on if I wiggle the switch but that's about it. any help is greatly appreciated
     
  2. dev199505

    dev199505 Member

    Age:
    22
    Posts:
    59
    Likes Received:
    2
    Joined:
    Dec 7, 2016
    Ram Year:
    1988
    Engine:
    5.2
    I feel like you might have clipped the harness and clipped the wrong one

    Sent from my Coolpad 3622A using Tapatalk
     
  3. dirtydodgefromdelco

    dirtydodgefromdelco Junior Member

    Age:
    18
    Posts:
    2
    Likes Received:
    0
    Joined:
    Feb 5, 2017
    Ram Year:
    1993
    Engine:
    5.2L 318
    I didn't clip anything. I bought a wire harness to plug right in to the new radio and the existing plugs
     

Share This Page