1998 2500 5.9L, No Crank, No Start

Discussion in 'P Pump' started by Peter L, Apr 8, 2016.

Thread Status:
Not open for further replies.
  1. Peter L

    Peter L Junior Member

    Posts:
    3
    Likes Received:
    0
    Joined:
    Apr 7, 2016
    Ram Year:
    1998
    Engine:
    5.9 Cummins
    So 1998 2500 with the 12 valve 5.9L Cummins.

    Yesterday as I got in I noticed the airbag warning and ABS lights were on as I started the motor. Thinking it odd, I shut down the motor and attempted restart hoping to clear the warning lights as I had never seen them on before. Then the engine failed to start. When the ignition key is turned from the on position to the start position there is a loud click heard from the left side of the engine compartment and the motor DOES NOT CRANK. The click will only be heard once and it takes shutting the ignition switch off and then attempting to restart to hear it again. In addition my blower switch does not work.

    Things I have done so far.

    1. Cleaned all the battery connections and recharged the batteries.

    2. Jumped the starter and the starter does crank. With the ignition switch in the on position the engine will not start when jumped.

    3. Swaped the trailer relay and starter relay. This produced one engine start ONLY and now we are back to the original symptoms...

    4. Replaced all the Multi use relays with new. Still same symptoms.

    Ok where do I go from here?

    Peter L
     
  2. MagSport

    MagSport Senior Member

    Age:
    21
    Posts:
    1,256
    Likes Received:
    499
    Joined:
    Mar 10, 2014
    Location:
    South Carolina
    Ram Year:
    1999
    Engine:
    5.9
    Two things come to mind: neutral safety switch and/or bad ignition switch. The only time my air bag and abs lights come on at the same time like your describing is when the truck is on/running but the switch is off (I have remote start). That kind of leads me to believe that perhaps some functions of the switch are working but others (maybe the starting function) are not.
    The neutral safety switch won't allow you to start if you're not in park or Nuetral. Have you tried to start it in Nuetral?
     
Thread Status:
Not open for further replies.

Share This Page