2007 5.9 won't crank

Discussion in '5.9 Common Rail' started by Granttj55, Jul 15, 2016.

  1. Granttj55

    Granttj55 Junior Member

    Posts:
    1
    Likes Received:
    0
    Joined:
    Jul 15, 2016
    Ram Year:
    2007
    Engine:
    5.9L cummins
    I have a 2007 5.9L and the past couple of days it's acted like the battery was starting to go. It would start to turn over then stop then keep turning over and fire up. Went back to get in it today after driving it yesterday and it won't do anything. I tried jumping it off with jumper cables and also a jump box but it wouldn't even start to turn over. I checked all fuses and none are blown. I've checked the grounds on the side of the block and the connections on the batteries. Did a load test on the batteries to make sure they were still good. All of that checked out fine, what's getting me is if you turn the key backwards then all of the accessories (radio, pillar gauges) all come on and work properly. If you turn the key forward like you're going to start it, the interior lights go dim or cut off, all of the dash lights go off, the relays behind the main gauge cluster starts flicking back and forth and it doesn't even start to turn over and acts like the batteries are dead but everything works perfectly with the key turn backwards. I pulled the grounds off of the battery to try to reset the computer and the wcm and also pulled the fuses for the wcm and let it sit for 10 minutes before hooking it back up with the same results. I'm completely stumped and would appreciate any input anyone has to try to fix this problem.
     
  2. R.L.K.

    R.L.K. Supporting Member

    Posts:
    10,527
    Likes Received:
    6,528
    Joined:
    Dec 1, 2013
    Location:
    Bristol , Tn.
    Ram Year:
    2014 4X4 QC Express 6 speed auto 355 differentials
    Engine:
    5.7 Hemi
    Hate that for ya .
    Maybe the xsmn shifting position switch is shorting out ?

    Try putting it in Nutral and see if she cranks .
    My last Dodge had a shift sensor go out on it , but I could start in Nutral , sometimes even in Nutral I'd have to actuate the steering wheel tilt " roughly " a couple times but it would start everytime ...
     
    Last edited: Jul 18, 2016
  3. BWC

    BWC Member

    Posts:
    79
    Likes Received:
    7
    Joined:
    Sep 2, 2015
    Location:
    Northern CO
    Ram Year:
    2003
    Engine:
    Cummins
    Can always try to shift through the gears and put it back in park.

    Also I had a buddy have a similar issue and it ended up being a bad ground in this harness
     
  4. crash68

    crash68 Senior Member

    Posts:
    900
    Likes Received:
    315
    Joined:
    Mar 20, 2016
    Ram Year:
    2015
    Engine:
    3.0 EcoDiesel
    Could be your TIPM. It looks like your fuse box under the hood but it also controls the power to just about everything in the truck including cranking the engine over.
     

Share This Page