Need help finding lost parts

Discussion in 'Tech Info' started by DK88, Dec 12, 2015.

  1. DK88

    DK88 Junior Member

    Age:
    19
    Posts:
    3
    Likes Received:
    0
    Joined:
    Nov 21, 2015
    Ram Year:
    1988
    Engine:
    5.2L 318 V8
    Okay, long story short, the guy before me was a dumba** and took all the short cuts possible when it came to the truck, so now I am missing lines and the truck is leaking gas badly. If anyone else can post pictures of their engine bays, it would be greatly appreciated (My truck is an 88 w150 5.2L V8). So, here's the issues:
    1. This piece is spewing gas when the truck runs. Not a trained mechanic, but my guess it that this is a return line or something of that sort. There was no hose connected on top or bottom, so I was wondering where this hose runs to?
    [​IMG]
    [​IMG]
    2: On my carb (Holley 2BBL) there is a hose that runs off of this, and today I realized that there is a screw in the end of this hose. I'm 99.9% sure this isn't factory spec, so I was wondering where this hose runs to?
    [​IMG]
    Any pictures/advice is greatly appreciated. Thanks guys!
     
  2. DK88

    DK88 Junior Member

    Age:
    19
    Posts:
    3
    Likes Received:
    0
    Joined:
    Nov 21, 2015
    Ram Year:
    1988
    Engine:
    5.2L 318 V8
    Also, if anyone lives near the Northwest CT area, DM me for my phone number. It'd be a lot easier to just see a truck in person.
     
  3. RonJon '06

    RonJon '06 Senior Member

    Posts:
    3,302
    Likes Received:
    1,047
    Joined:
    Jan 2, 2014
    Location:
    Southern Minnesota
    Ram Year:
    2006, 1985
    Engine:
    5.7, 360
    Here's the vacuum diagram for my '85. It's got a 5.9 and 4bbl carb but I think the vapor canisters should be the same. There are no lines hooked up to the fitting on mine either and there's a factory plug. The diagram shows it plugged as well. The hose on the front of the carb goes to the bowl vent valve seen by the second canister in the third pic. My hose connecting the two cannisters was cracked and leaking gas so I plugged it but I might hook it back up since my carb has been acting funny at times. Hope this helps.

    [​IMG]

    [​IMG]



    [​IMG]

    EDIT: Did some searching and it looks like you only have one charcoal canister and the vacuum lines are routed different. Sorry, maybe someone with a 318 can help you.
     
    Last edited: Dec 12, 2015

Share This Page