Something weird with turn signal

Discussion in 'Exterior' started by Blue Chaos, Sep 11, 2015.

Sponsored By: BAK Factory Outlet
  1. Blue Chaos

    Blue Chaos Member

    Age:
    32
    Posts:
    68
    Likes Received:
    4
    Joined:
    Sep 5, 2015
    Location:
    Bloomington, IN
    Ram Year:
    1985
    Engine:
    LA 318
    So my turn signals work fine when my parking/headlights are off. But if I have my park/headlights on my passenger side signals work fine but my driver side the light on the cluster just stays lit and both front and back bulbs shut off completely. I thought it was a bulb problem so I replaced them all. Still having the same issue. When the parking/headlights are on but no turn signal they work fine. When they are off turn signal works fine, but not together... Please someone tell me you have had this happen and its not a whole wiring harness.
     
  2. crazzywolfie

    crazzywolfie Senior Member

    Posts:
    14,039
    Likes Received:
    2,138
    Joined:
    Apr 6, 2013
    Location:
    under the truck
    Ram Year:
    81 93
    Engine:
    5.2
    there is most likely a short in that side or a bad bulb. usually my truck does that when the park like is out.
     
  3. Blue Chaos

    Blue Chaos Member

    Age:
    32
    Posts:
    68
    Likes Received:
    4
    Joined:
    Sep 5, 2015
    Location:
    Bloomington, IN
    Ram Year:
    1985
    Engine:
    LA 318
    I figured it was a bulb tooo, so I replaced them all 15 minutes ago. No dice.
     
  4. Blue Chaos

    Blue Chaos Member

    Age:
    32
    Posts:
    68
    Likes Received:
    4
    Joined:
    Sep 5, 2015
    Location:
    Bloomington, IN
    Ram Year:
    1985
    Engine:
    LA 318
    My connectors are in ROUGH shape, could that be it? The rear where it grabs the bulb is fine but the wings that hold it in the new tail light are rusted off. The front one half or the metal part that holds the bulb is rusted off. I had to scrub the inside connectors just to get the bulb to work.
     
  5. crazzywolfie

    crazzywolfie Senior Member

    Posts:
    14,039
    Likes Received:
    2,138
    Joined:
    Apr 6, 2013
    Location:
    under the truck
    Ram Year:
    81 93
    Engine:
    5.2
    the issue will be in the front somewhere on the side that the light says. it could be a connector or socket. would really be hard to say without being there. the turn signal indicators are tied to the front turn signal wiring which is why it comes on when it is out or there is a issue.
     
  6. Blue Chaos

    Blue Chaos Member

    Age:
    32
    Posts:
    68
    Likes Received:
    4
    Joined:
    Sep 5, 2015
    Location:
    Bloomington, IN
    Ram Year:
    1985
    Engine:
    LA 318
    Awesome! Good to know! I will begin with a new connector and then go on a wire hunt.
     
  7. crazzywolfie

    crazzywolfie Senior Member

    Posts:
    14,039
    Likes Received:
    2,138
    Joined:
    Apr 6, 2013
    Location:
    under the truck
    Ram Year:
    81 93
    Engine:
    5.2
    ya. it took me a bit to realize it on my truck. also did you also check the turn signal bulb on the light in the fender? could also maybe cause it to kick on.
     
  8. TRCM

    TRCM Senior Member

    Posts:
    1,531
    Likes Received:
    460
    Joined:
    Jul 30, 2012
    Location:
    Newport News, VA
    Ram Year:
    2012 1500 Laramie CC 4x4
    Engine:
    5.7 Hemi
    Also check the hazard switch...when they go bad, weird things happen
     
  9. Blue Chaos

    Blue Chaos Member

    Age:
    32
    Posts:
    68
    Likes Received:
    4
    Joined:
    Sep 5, 2015
    Location:
    Bloomington, IN
    Ram Year:
    1985
    Engine:
    LA 318
    I pulled the little reflector bulb or whatever just to make sure it wasn't it. No dice again. And with the hazard switch. I pulled it and they work fine, but if that's the problem, do I just replace the switch??
     
  10. crazzywolfie

    crazzywolfie Senior Member

    Posts:
    14,039
    Likes Received:
    2,138
    Joined:
    Apr 6, 2013
    Location:
    under the truck
    Ram Year:
    81 93
    Engine:
    5.2
    the switch is not likely the issue. your issue is still probably still under the hood in the wiring or connectors. somewhere power is getting from the park lights into the turn signal light system
     

Share This Page