trans issue

Discussion in 'Engine & Performance' started by Timstrohaver, Jan 2, 2017.

Sponsored By: Moe's Performance
  1. Timstrohaver

    Timstrohaver Junior Member

    Posts:
    1
    Likes Received:
    0
    Joined:
    Jan 2, 2017
    Location:
    michigan
    Ram Year:
    2009
    Engine:
    5.7
    Anyone have a issue with there transmission delaying going into gear ? I have a 09 ram and it has a 6second delay before it actually goes into gear. Also went into limp mode and stuck in 4th gear on me a couple times, I stopped the truck and shut it off, let it set for a couple seconds, started it back up and it was fine, I did a code check and it had one for tcm low voltage. Can anyone help me out
     
  2. MADDOG

    MADDOG CTD Driver Staff Member

    Posts:
    7,091
    Likes Received:
    1,872
    Joined:
    Dec 26, 2011
    Location:
    Oregon
    Ram Year:
    2017
    Engine:
    Cummins 6.7L Turbo Diesel
    Welcome to RamForum.

    A TCM low voltage code is coming from the transmission control module circuit, caused by low battery voltage or an open or short circuit.

    I'd check the data cable plug into the transmission case to make sure it's clean, not corroded and has no damage. Also, check the harness from the trans to the PCM to make sure the harness is in good condition.

    Good luck!
     
    Burla likes this.
  3. Burla

    Burla Senior Member

    Posts:
    6,116
    Likes Received:
    4,878
    Joined:
    Apr 28, 2012
    Ram Year:
    2010 Hemi Reg Cab 4x4
    Engine:
    Hemi
    Does it happen in tow haul mode?
     
    huntergreen likes this.
  4. 2bndrt

    2bndrt Junior Member

    Age:
    49
    Posts:
    1
    Likes Received:
    0
    Joined:
    Nov 27, 2017
    Ram Year:
    2009
    Engine:
    5.7
    Can you give an update on this issue. I had the same problem this morning and my trans is still stuck in 4th gear.

    Thanks

    Sent from my XT1585 using Tapatalk
     

Share This Page