Weak horn sound

Discussion in 'General Discussions' started by Dan40, Nov 11, 2016.

  1. Dan40

    Dan40 Junior Member

    Posts:
    2
    Likes Received:
    0
    Joined:
    Nov 2, 2016
    Ram Year:
    1985
    Engine:
    slant 6
    first time post. 1985 ram custom 100. It didn't pass state inspection, horn sound is very weak. I looked for a relay but couldn't find one. If I connect the horn directly to the battery the sound is normal. I thought about adding a switch just to get thru the inspection. Any help would be appreciated.
     
  2. crazzywolfie

    crazzywolfie Senior Member

    Posts:
    14,039
    Likes Received:
    2,138
    Joined:
    Apr 6, 2013
    Location:
    under the truck
    Ram Year:
    81 93
    Engine:
    5.2
    the relay for the stock horn is under the dash in the fuse panel.
    [​IMG]
     
  3. Dan40

    Dan40 Junior Member

    Posts:
    2
    Likes Received:
    0
    Joined:
    Nov 2, 2016
    Ram Year:
    1985
    Engine:
    slant 6
    relay switch

    Thanks for the info. I put a new relay in and still the same problem. If I attach a jumper to the horn form the battery it works fine. If I fine the problem I will let yu know.
     
  4. crazzywolfie

    crazzywolfie Senior Member

    Posts:
    14,039
    Likes Received:
    2,138
    Joined:
    Apr 6, 2013
    Location:
    under the truck
    Ram Year:
    81 93
    Engine:
    5.2
    have you tried testing what the voltage is at the relay? you could possibly install a relay under the hood that is activated by the stock horn wire. a aftermarket relay would take less power to activate than the horn would use.
     

Share This Page