'03 2500-left turn works on truck but nothing on 7 pin?

Dad's 1990 Ram

Junior Member
Joined
Aug 3, 2010
Posts
6
Reaction score
0
Location
Kanabec County Minnesota
Ram Year
1990
Engine
318ci V8
My '03 2500 is a regular cab, long box. I've been towing a camper trailer and a tilt-bed car trailer and everything was working great.
The last time I towed my camper trailer I had no left turn signal on the trailer but the left turn signal on the front and back of the truck worked as they should.
There was no flashing using a test light at the left turn signal pin in the 7 pin receptacle.
I checked the wiring from the left turn pin on the 7 pin receptacle to where they wire is inside the loom above the rear axle.
The inspection was visual and using a multi-meter.
The wire, (yellow with a red tracer), checks out good to that point.

Without digging through the loom all the way to the front, testing as I go, can anyone tell me where it goes so I can start at that end?
 

Fast69Mopar

Senior Member
Joined
May 10, 2019
Posts
1,992
Reaction score
1,658
Location
Texas
Ram Year
2004
Engine
5.7 HEMI
My '03 2500 is a regular cab, long box. I've been towing a camper trailer and a tilt-bed car trailer and everything was working great.
The last time I towed my camper trailer I had no left turn signal on the trailer but the left turn signal on the front and back of the truck worked as they should.
There was no flashing using a test light at the left turn signal pin in the 7 pin receptacle.
I checked the wiring from the left turn pin on the 7 pin receptacle to where they wire is inside the loom above the rear axle.
The inspection was visual and using a multi-meter.
The wire, (yellow with a red tracer), checks out good to that point.

Without digging through the loom all the way to the front, testing as I go, can anyone tell me where it goes so I can start at that end?
If fuse #46 and #47 are good in the IPM under the hood I would suspect the circuit board has failed in the IPM for the left trailer lamps..

There are multiple post about the 2003-2004 IPM and left/right trailer turn failure. If you remove the PCB from the IPM you will probably find a burned circuit.
 

Dad's 1990 Ram

Junior Member
Joined
Aug 3, 2010
Posts
6
Reaction score
0
Location
Kanabec County Minnesota
Ram Year
1990
Engine
318ci V8
Fast69Mopar, I have fixed my issue, thanks for the help. I found a couple youtube videos with my specific issue and they had solutions for the issue. It ended up being a bad relay soldered to the underside of the IPM circuit board. There were 3 relays so instead of diagnosing which one was bad I replaced them all. I'm so glad I had youtube to guide me in the disassembly of the IPM and the repair. Those were lifesavers!
 
Top