2004 ram 1500 5.7 hard and delayed shift into drive

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Williammoody150

Junior Member
Joined
Apr 26, 2024
Posts
3
Reaction score
0
Location
Monroe la
Ram Year
2004
Engine
5.7
Hey fellas. I’ve got a 2004 ram 1500 5.7 with about 230,000 miles. It’s been a great truck and still is but starting to have an issue with shifting. It will go into reverse with just a second delay or so as normal, but Putting it into drive there is about a 4 to 5 second delay and shifts very hard. It only shifts hard going into first though and once you’re in drive and going, it shifts just fine. It has that delay whether you’re going from Park Neutral or reverse into drive. Any ideas on what could be causing that would be appreciated.
Thanks!
 

Octane

Senior Member
Joined
Jun 8, 2019
Posts
1,542
Reaction score
2,095
Location
U S.A.
Hey fellas. I’ve got a 2004 ram 1500 5.7 with about 230,000 miles. It’s been a great truck and still is but starting to have an issue with shifting. It will go into reverse with just a second delay or so as normal, but Putting it into drive there is about a 4 to 5 second delay and shifts very hard. It only shifts hard going into first though and once you’re in drive and going, it shifts just fine. It has that delay whether you’re going from Park Neutral or reverse into drive. Any ideas on what could be causing that would be appreciated.
Thanks!
Just a guess.But old filters may be having an effect.Or bad shift solenoids.Or...with 230k it might be time to replace the whole she-bang.No codes? Take it and have a good tech check it out anyway.Wouldn't hurt.
 

Daw14

Senior Member
Joined
Nov 29, 2017
Posts
2,269
Reaction score
2,579
Ram Year
2014
Engine
5.7 hemi
When was the last time it was serviced ? New filters ,fresh fluid ?
 

Hanover Fiste

Senior Member
Military
Joined
Apr 29, 2020
Posts
409
Reaction score
1,092
Location
NW Florida
Ram Year
2005 SLT, 2018 Sport
Engine
5.7L Hemi
Check your transmission fluid level. If it's too low, it will cause those symptoms.
 

Marshall

Senior Member
Joined
Apr 17, 2013
Posts
1,195
Reaction score
996
Location
Sk, Canada
Ram Year
2014 sport
Engine
5.7 hemi
I would think a plugged up filter and worn out dirty oil would be the first thing to check.
you still have a dipstick what does the oil on the stick look like??????
after that I am out of my depth, the old 1960's I have torn apart.
On mine no way to check as no dipinstick anymore. Stupid idea.
 
Top