2005 Ram 3500 Electrical Issues

Duffejo

Junior Member
Joined
Oct 31, 2021
Posts
6
Reaction score
0
Location
Alabama
Ram Year
2005
Engine
5.9L Cummins
I have a 2005 Ram 3500 5.9L Cummins 6 speed manual DRW single cab, and I’m having electrical issues.. seems that the cluster sometimes flickers, radio as well. I am curious if there are any known issues that I can go check to correct this.
 

Attachments

  • 8FB6ACB5-E83F-4090-89EA-BC9313E3C6FB.jpeg
    8FB6ACB5-E83F-4090-89EA-BC9313E3C6FB.jpeg
    68.3 KB · Views: 3

Smokeybear01

Senior Member
Military
Joined
Jan 25, 2020
Posts
273
Reaction score
109
Location
US
Ram Year
2005
Engine
Cummins 5.9l
I would start by checking the radio fuse. That's where my issues started. The fuse was good, the connections weren't. Good luck,
 

Duffejo

Junior Member
Joined
Oct 31, 2021
Posts
6
Reaction score
0
Location
Alabama
Ram Year
2005
Engine
5.9L Cummins
Do you think this could lead to the cluster and PCM not working properly, preventing motor from starting? It turns over but not crank.
I would start by checking the radio fuse. That's where my issues started. The fuse was good, the connections weren't. Good luck,
 

Smokeybear01

Senior Member
Military
Joined
Jan 25, 2020
Posts
273
Reaction score
109
Location
US
Ram Year
2005
Engine
Cummins 5.9l
Do you think this could lead to the cluster and PCM not working properly, preventing motor from starting? It turns over but not crank.
Mine always cranked and started, just dash flickered and other electrical issues without throwing any codes. Sometimes it would suddenly go into limp mode and then come back out on its own. After cleaning the connection under the PCM everything started working correctly again until I replaced the batteries. Now the radio is acting weird again, but nothing else, so I'm ignoring it.
 
Top