2011 Ram 2500. No Crank. No Start. U0100 Code

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

echo89

Junior Member
Joined
Jun 21, 2024
Posts
1
Reaction score
0
Location
Missouri
Ram Year
2011
Engine
6.7 Cummins
Hi Everyone,

I have been chasing my tail for some time now and am hoping someone could shed some light on my issue. I have been searching through the forum with no luck as of yet.

I have a 2011 Ram 2500 that has developed a no crank no start issue.

I can turn the key to the ON position and power up the usual dash lights and accessories (radio, hvac, lights) but when I turn the key to the START position the truck does nothing and will not start.

In the beginning, I have had certain times where I would start my truck up no problem but then drive somewhere and shut my truck off and then it gives me this trouble when trying to start back up. Now I can’t use the key at all to start my truck.

So far, I have replaced the WIN module with a new reprogrammed unit, installed a new starter, installed new batteries, cleaned the grounds, taken apart and cleaned the TIPM, and checked relays.

I am at a loss right now on figuring out the culprit. I did notice that I am not getting 12 volts to the signal wire going to the starter solenoid.

I checked codes with AlfaOBD and am getting a U0100 code. Any gurus out there that can help guide through AlfaOBD to help pinpoint the problem? I do have a tune on the truck and am curious on what the chances are that the tune has become corrupted and is creating the communication issues.

I have installed a jumper with a push button to bypass the WIN module for the moment but would really like to solve the problem.

How common is it for a neutral safety switch on the 68RFE to fail and how can one go about testing it without dropping the pan?

Are there any other safety switches on the truck that would cause the no crank no start issue?

Any help would be greatly appreciated.
 

GTyankee

Senior Member
Supporting Member
Military
Joined
Nov 2, 2020
Posts
10,519
Reaction score
13,710
Location
El Cajon Calif. 92021
Ram Year
2016
Engine
3.0 ecodiesel

U0101 Lost Communication with Transmission Control Module (TCM)

Read more at: https://www.obd-codes.com/u0101

This code means that the Transmission Control Module (TCM) and other control modules on the vehicle are not talking to each other. The circuit most often used to communicate with is known as Controller Area Network bus communications, or simply put, CAN bus. Without this CAN bus, control modules cannot exchange information, and your scan tool may not be able to get information from the vehicle, depending on which circuit is affected.

Malfunction Indicator Lamp (MIL) on
Vehicle will not shift
Vehicle stays in one gear (usually 2nd or 3rd)

Typically the causes for this code to set are:
Open in the CAN bus + circuit
Open in the CAN bus - circuit
Short to power in either CAN bus circuit
Short to ground in either CAN bus circuit
Rarely - faulty control module

Diagnostic and Repair Procedures are below

Read more at: https://www.obd-codes.com/u0101
Copyright OBD-Codes.com
 
Top