2013 Ram Outdoorsman Major Codes

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

PHStaeben

Junior Member
Joined
May 2, 2024
Posts
1
Reaction score
0
Location
NL Canada
Ram Year
2013
Engine
5.7 Hemi
So I was having shifting Issues with the transmission (auto) and determined it was the Shift Solenoid Block that needed replacement. Had that completed by a fairly reputable transmission shop. Everything was going well for the first 50km drive of a 160km return home drive, until she went into limp mode. Having said this I live in fairly remote rural area that is 250 km distance from the nearest dealer. The list below are errors and codes I now have. I was able to get home by shutting the engine off and restarting to get about another 20-35 kms before limp mode reactivated.

  1. PCM P2127 - Accelerator Pedal Position Sensor
  2. PCM P0652 Sensor Reference Voltage 2 circuit low
  3. PCM P0340 Camshaft Position Sensor Circuit Bank 1 Sensor 1
  4. U0401-00 Implausible Data received from ECM/PCM
  5. ABS C121C-00 Torque Request Signal Denied
  6. EPS C2129-16 Battery Voltage Circuit Voltage Below Threshold
  7. ITBM U0415-00 Implausible Data received from ABS
  8. DTMC U0401 Implausible Data received from ECM/PCM
  9. TPMS C1510-00 Sensor Error
Beside these errors the dash warnings are as follows:

  1. Service Electronic Throttle Control Module
  2. Service Trailer Break System
  3. Service Electronic Breaking
  4. 4x4 Not Available
What I fail to understand are so many errors. Local mechanics do not think I should start replacing sensors but do not know where to start. Please help me find out or suggest where I should start/go to get this gremlin out of my truck.
 

Black-Wolf

Senior Member
Supporting Member
Military
Joined
Nov 21, 2018
Posts
288
Reaction score
338
Location
North Carolina
Ram Year
2017
Engine
Hemi 5.7
Check your gas pedal connections, wiring, and pins. Do you have a Pedal Commander installed? If not, check the CAN Buss Star Connectors (total of three of them all under the dash on each side and in the center). Multiple codes being thrown like that across different circuits indicates possible CAN Buss Star Connector having a bad capacitor - hard to diagnose though. Other issue could be bad ECM or PCM, or bad connection from the harness to them (lose plug or bent pin). If you do have a PC installed, remove it out of the circuit. If that clears up the errors, you may have a broken wire/bad pin in the PC (my situation with mine - PC repaired it for $10 + S/H).
 

Ken226

Senior Member
Military
Joined
Mar 12, 2017
Posts
623
Reaction score
627
Location
Washington State
Ram Year
2013
Engine
Hemi
That sounds very much like a connector was left loose, or not reconnected. I would start with the big one above the left kick panel. I think it's the BCM connector. It has a big cam lever disconnector.

I accidentally pulled mine loose with my foot once, and got a couple dozen codes and limp mode. If that one is secure, check others
 

Ken226

Senior Member
Military
Joined
Mar 12, 2017
Posts
623
Reaction score
627
Location
Washington State
Ram Year
2013
Engine
Hemi
So I was having shifting Issues with the transmission (auto) and determined it was the Shift Solenoid Block that needed replacement. Had that completed by a fairly reputable transmission shop. Everything was going well for the first 50km drive of a 160km return home drive, until she went into limp mode. Having said this I live in fairly remote rural area that is 250 km distance from the nearest dealer. The list below are errors and codes I now have. I was able to get home by shutting the engine off and restarting to get about another 20-35 kms before limp mode reactivated.

  1. PCM P2127 - Accelerator Pedal Position Sensor
  2. PCM P0652 Sensor Reference Voltage 2 circuit low
  3. PCM P0340 Camshaft Position Sensor Circuit Bank 1 Sensor 1
  4. U0401-00 Implausible Data received from ECM/PCM
  5. ABS C121C-00 Torque Request Signal Denied
  6. EPS C2129-16 Battery Voltage Circuit Voltage Below Threshold
  7. ITBM U0415-00 Implausible Data received from ABS
  8. DTMC U0401 Implausible Data received from ECM/PCM
  9. TPMS C1510-00 Sensor Error
Beside these errors the dash warnings are as follows:

  1. Service Electronic Throttle Control Module
  2. Service Trailer Break System
  3. Service Electronic Breaking
  4. 4x4 Not Available
What I fail to understand are so many errors. Local mechanics do not think I should start replacing sensors but do not know where to start. Please help me find out or suggest where I should start/go to get this gremlin out of my truck.

In case you haven't checked back in on this thread yet, this is the connector I was talking about. The last reply in this guys thread:

 

Latest posts

Members online

Forum statistics

Threads
197,440
Posts
2,894,164
Members
159,321
Latest member
paularmstrong
Top