2014 5.7 misfire, now won't start.

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Ronnie Smith

Junior Member
Joined
Aug 17, 2020
Posts
6
Reaction score
4
Location
South Carolina
Ram Year
2006
Engine
5.7
With low fuel pressure it will throw a mist fire code and a lot of other codes. My 2006 just did the same thing about 3 weeks ago going to work. It was running rough and stumbling at lights. But when I came out from work it would turn over but would not start. New fuel pump took care of it. 30 psi looks like a good stream but not enough to run the fuel injection.
 
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
Am I missing something here? You said you shot a small amount of starting fluid in the air cleaner and it ran smooth for 3 to 4 seconds. Have you checked the fuel pressure with a gage. You should be reading 50 to 60 psi.
It's on my list of things to check, fuel pressure that is, just need time to. How often do the pumps fail and NOT throw fuel pressure codes?
Are the fuel pressure sensors typically faulty in this regard? I realize almost all sensors have been know to fail and not trip CEL, I'm just curious how common it is with Rams..

Also, this:

"Pulled the fuel supply line to injectors and cycled ignition to see if I was getting flow, it pumped what looked like a very strong volume into a bucket. Obviously this isn't a performance test, but the volume should've been enough to start the engine at least. Hooked fuel lines back up and it still wouldn't start though."

It should try to start a lot harder than it is, since the volume of fuel it produced, again not pressure/load test but still impressive stream observed, was a considerably higher volume fuel source than the 1/64 of an ounce of starting fluid.

In my mind, it should start up ok initially at least(like run for a few seconds), once the fuel pump gets some pressure built up early, and then promptly die off once the "possibly failing" pump cannot keep up with the demand; yet it's not even trying to start, but it will pump a lot of fuel into a bucket. Again, I realize the fuel it's moving could be too little to keep engine running for significant amount of time, but it's moving a decent enough volume to at least start up and run for the amount of time it did on the ether....

I hope this could be the cause, I just don't buy it yet.
Reallllly interesting the mech that looked at it couldn't talk to those modules he spoke about. I really wish he was a more thourough/modern individual, but alas. Would've been nice to get a detailed list of what he tried exactly and what he actually observed, but he was just doing a quick check to be nice, and I wasn't around.
 
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
What's the sequence for fuel pump running when starting up the engine?

When the ignition is first cycled, it runs the pump for a few seconds to prime things, correct?

Once that prime step is complete, what's the next trigger for running the pump all out?
 
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
Anyone recall what the startup sequence is?
Does the pump just run a few seconds to prime, then runs full out once engine is ON?
Or does it cycle on until the fuel pressure sensor is made and then kick off until the pressure switch opens and it has "demand" again.
 

Dusty

Senior Member
Joined
Jun 6, 2013
Posts
1,332
Reaction score
1,454
Location
Rochester, New York
Ram Year
2019
Engine
5.7 Hemi
Anyone recall what the startup sequence is?
Does the pump just run a few seconds to prime, then runs full out once engine is ON?
Or does it cycle on until the fuel pressure sensor is made and then kick off until the pressure switch opens and it has "demand" again.
On most vehicles I've worked on at initial Key On (ignition run, but not start) the fuel pump will operate for a few seconds to charge the fuel rails to ensure the injectors have enough fuel pressure to operate properly. This is usually at full system pressure.

This may not happen all of the time and is dependent on how much pressure is detected at Key On. For example: If the engine has just been fuel charged to max and the engine was not run, another Key On a few minutes later may not engage the pump.

In the past the typical full pressure is around 65 PSI on these systems. After the engine is started it usually drops about 5-8 PSI (normal operating mode). If the system declares a fault, fuel pressure is delivered to maximum pressure.

Regards,
Dusty
2019 Ram 1500 Billet Silver Quad Cab 2WD, 5.7 Hemi, 8HP75, 3.21 axle, 33-gallon fuel tank, factory dual exhaust, 18” wheels. Build date: 3 June 2018. Now at 85402 miles
 

Lee Peterson

Senior Member
Joined
Dec 22, 2017
Posts
214
Reaction score
147
Location
Hamilton ON Canada
Ram Year
2009
Engine
5.7 Hemi
My fuel pump went last month! It was weird and threw throttle peddle codes. What ever you do don't go budget after market pump. I got a TYC and the thing doesn't hold prime!
 
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
I've got a fitting coming so I can actually test my pressure this week.

Had a friend's kid hook up his scan tool(Snap-On Solus I think) to it to check things over the weekend, and he ran the fuel pump manually just to look at the flow with hose off, he thought it had plenty of volume. He didn't find any other revealing codes either, AND he had no trouble communicating with modules, so I'm more leaning towards erratic fuel delivery...

Tried cycling the ignition several times the next day, just on and off, to see if it might eventually build enough pressure to fire up, and it wouldn't do anything; BUT when I unhooked the fuel line for fun after all the On/Off cycling it had nothing but a few dribbles. Pump is definitely running though, I was underneath it listening and smacking the bottom of tank while wife cycled the ignition. I wonder if the regulator/pump internals are shot. Maybe with the scan tool telling it to run non-stop it could muster up enough pressure over time, but cannot deliver enough for normal operation?
 
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
Can you maybe pull the fuel rail and see if the injectors are spraying fuel?
Possibly. I wanna check this pressure first once my fittings get here. Leaning towards sketchy pump, but haven't had a good way to test pressure thus far; kid that scanned it the other night with pump running constant couldn't find a pressure reading anywhere when hooked up, I was hoping he could see the reading from the sensor but he couldn't.
 
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
Anyone have a snippet of the wiring diagram from TIPM to fuel pump for a 2014??? I've seen variance online, most of what I search only brings up like a 2009...or older.
 

1 MEAN66

Senior Member
Joined
Aug 20, 2022
Posts
305
Reaction score
341
Location
Waterford NY
Ram Year
2016
Engine
Hemi 5.7 VVT-MDS
Everything made now a days has injectors. A lot of vehicle do not have "fuel' codes. Three basic thing to start any engine of any year: 1)fuel, 2) compression, and 3) spark. So from what I am reading I also agree problem sounds fuel related. Yes you say you had a good "stream" of fuel. So does a garden hose but you can squeeze the hose with your fingers and almost stop it, Fuel systems can require near 90psi, pumps are capable of more. Buy a fuel pressure gauge set, I am sure harbor freight has an inexpensive one. Test it for pressure. Once you have one you can even test for injector leaks, etc. I also believe YOU have already found the problem. Plug a scanner in crank the engine if you are getting an RPM reading then the computer knows it is cranking. You added fuel and it went VRoom. I believe you found it. It has been since 2017 since I have been full time tech but I would guess pressure with just key on will be in the 50-60 PSI range. Computer just opens and closes the injector "door" to let fuel spray, it then can also vary the time it is open (duty cycle) to vary the quantity that they actually spray. No pressure-no juice! NO juice no VROOM!
 
Last edited:
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
Does uh....does anyone have the wiring snippet then?

TIPM to pump? Saw numerous posts online with links supposedly going to sites with diagrams, but none of the sites had what I was looking for.

As stated earlier I plan to test it, today even I hope. I'm just looking to save a few trips back and forth from home; I want to know the wiring path before I head out, for troubleshooting mostly, and for operation/bypass reasons IF I can't get ahold of the dude that had the scanner that could turn the pump on, i.e., I want the pump to run constantly again to test it really well.
 
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
On most vehicles I've worked on at initial Key On (ignition run, but not start) the fuel pump will operate for a few seconds to charge the fuel rails to ensure the injectors have enough fuel pressure to operate properly. This is usually at full system pressure.

This may not happen all of the time and is dependent on how much pressure is detected at Key On. For example: If the engine has just been fuel charged to max and the engine was not run, another Key On a few minutes later may not engage the pump.

In the past the typical full pressure is around 65 PSI on these systems. After the engine is started it usually drops about 5-8 PSI (normal operating mode). If the system declares a fault, fuel pressure is delivered to maximum pressure.

Regards,
Dusty
2019 Ram 1500 Billet Silver Quad Cab 2WD, 5.7 Hemi, 8HP75, 3.21 axle, 33-gallon fuel tank, factory dual exhaust, 18” wheels. Build date: 3 June 2018. Now at 85402 miles
I'm really very curious if the initial pump run upon turning the ignition is strictly time-based, time-based with a pressure condition too, or if it's strictly pressure based, i.e., runs until that pressure sensor is satisfied.
 
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
Appreciate all the responses thus far.
I really do.

Just looking to arm up before I venture out to the front
 
Joined
Oct 1, 2021
Posts
55
Reaction score
68
Location
Manhattan, KS USA
Ram Year
2012
Engine
stock 5.7 with 6.4l cam and MDS delete
i've stated this before in some other threads similar to this one.
You state that it ran smooth briefly with starting fluid yet the codes are for a transmission and cyl 7.
anther member posted it could be a fuel-pressure regulator which i could definitely see.
What i posted in other threads is that the main harness that goes down the back of the engine and on top of the bell-housing and back is known to have a pinch point and also carries just about all of the power-train wires from the computer. I would definitely check this first for frayed wires and such before attempting anything else.
this sounds like a good place to start considering your having more than just 1 misfire.
 

Wild one

Senior Member
Joined
Jan 17, 2016
Posts
14,818
Reaction score
26,482
Ram Year
14 Sport
Engine
5.7
Does uh....does anyone have the wiring snippet then?

TIPM to pump? Saw numerous posts online with links supposedly going to sites with diagrams, but none of the sites had what I was looking for.

As stated earlier I plan to test it, today even I hope. I'm just looking to save a few trips back and forth from home; I want to know the wiring path before I head out, for troubleshooting mostly, and for operation/bypass reasons IF I can't get ahold of the dude that had the scanner that could turn the pump on, i.e., I want the pump to run constantly again to test it really well.
Pull the fuel pump relay and jump the terminals,if you don't have the scan tool to turn the pump on
 
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
Pull the fuel pump relay and jump the terminals,if you don't have the scan tool to turn the pump on
The relay is soldered onto the TIPM board on these. I have no serviceable relay to pull. Luckily, the fuse for the pump is post-relay so I was able to jump it there.

Again, wanted specific info prior to heading out; at least I got lucky this time.

Pump supplied 60+ psi while deadheaded, and was ~36-40 working pressure while discharging(gauge has handy bleedoff to check working pressure). It only lost maybe 4psi in 20 minutes when I killed the pump. Stayed north of 50psi with pump off for quite a while.
 
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
Shop got it running.. Fuel had a lot of water in it........sample they pulled was close to 50% water.. I should've checked a sample, but it smelled so damn strong while testing the pump that I just ignored that possibility, for some stupid reason.

I can't figure it out. I looked back and I fueled it up on Super bowl Sunday, and it ran fine that day into the night. Ran fine next AM -water should settle out instantly at the bottom, so I would think it would run poor almost right away IF I got bad fuel at the station- and I proceeded to run through close to 3/4 of a tank before any issues manifested.

Thinking either some piece of work pored some in the tank, or I have a hole/intrusion point somewhere.
 
OP
OP
A

AStanE

Member
Joined
Feb 27, 2023
Posts
35
Reaction score
20
Location
West Central Iowa
Ram Year
2014
Engine
5.7
How in the H3ll did I accumulate that much water? I'm coming up with nothing for the most part.

I did find an emissions hose off the front of the tank has been chewed into, but it's such a small line, and I haven't been mud-bogging or driving through significant rain events; I would think if the water was a cumulative thing, then the truck wouldn't run worth a damn sucking that water off the bottom once it reached a decent concentration..

Anyone have any ideas? I looked filler neck and the rest of the tank over best I could, just not seeing any super good intrusion points.
 

Attachments

  • hose.jpg
    hose.jpg
    63.8 KB · Views: 4
Top