2021 Ram Key fob doesn't work, alarm goes off when opened with key

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

adsjayhawj

Junior Member
Joined
Jun 14, 2024
Posts
1
Reaction score
0
Location
venice, fl
Ram Year
2021
Engine
5.7L eTorque Hemi
Key fob does not work. Open with emergency key, alarm goes off. Truck won't start no electronics work. Alarm only goes off when locked with key???
 

mikeru

Super Moderator
Staff member
Super Moderator
Joined
Nov 3, 2016
Posts
3,114
Reaction score
4,609
Location
The Palouse
Ram Year
2020 Limited
Engine
Hemi 5.7L non-Etorque
I suspect your RF hub has failed. Do you have a second fob to try? The symptoms you described are exactly what I saw when the RF hub failed on our 2020 Limited. It was caused by a leaking rear window. I would recommend that you check for water leaking into your cab. The RF hub is located on the rear wall of the cab and is susceptible to any water that might leak in through the rear of the cab. If your truck is still covered under the factory warranty you want to get it to a dealership ASAP.
 

mikeru

Super Moderator
Staff member
Super Moderator
Joined
Nov 3, 2016
Posts
3,114
Reaction score
4,609
Location
The Palouse
Ram Year
2020 Limited
Engine
Hemi 5.7L non-Etorque
Have you replaced the battery in your fob?

That's why I was asking about a second fob. I guess that's what I get for assuming people would make that connection. :waytogo:

Edit: Read the OP's first post again. There's more going on here than just a fob issue. Truck won't start and no electronics work. Even if the battery in the fob is dead you can still start the truck if you push the start button with the fob. It's not a fob issue.
 
Last edited:

Zoe Saldana

Senior Member
Joined
Nov 12, 2020
Posts
1,011
Reaction score
842
Location
california
Ram Year
2016
Engine
6.4l
Key fob does not work. Open with emergency key, alarm goes off. Truck won't start no electronics work. Alarm only goes off when locked with key???

Open up the fob - search Youtube.

Sometimes the contacts get dirty. My fob had some melted rubber in between the outside pressure point and the mechanism.
Also, add a new battery while it is open.
 

BossHogg

Senior Member
Joined
Feb 23, 2014
Posts
1,970
Reaction score
2,534
Location
Oakland Township, Michigan
Ram Year
2015
Engine
6.7L Cummins
Key fob does not work. Open with emergency key, alarm goes off. Truck won't start no electronics work. Alarm only goes off when locked with key???
My 2015 has done this to me, twice. Alarm with key entry, no FOB response, no cluster illumination, no crank, just interior lighting, and horn, the same behavior you are seeing. Through a process of elimination, I discovered leaving my Banks iDash Data Monster connected to the OBD port was the cause. Strange, my 2022 also has the data monster but never demonstrated this problem so I'm thinking the iDash may have an issue screwing up the CAN bus thus paralyzing the truck.

Do you have any after-market devices connected to your OBD?
 

RichieW13

Member
Joined
Jun 30, 2014
Posts
73
Reaction score
16
Location
Thousand Oaks, CA
Ram Year
2022
Engine
Gas
Key fob does not work. Open with emergency key, alarm goes off. Truck won't start no electronics work. Alarm only goes off when locked with key???
I had a similar problem nearly 2 years ago with my 2022 Ram.

It only happened once, and I never figured out why.

But in general, my proximity keyfob has been unreliable (I have replaced batteries and swapped fobs, it doesn't help). This morning I couldn't unlock my truck by touching the door handle. I had to push "unlock" on the fob. And when I tried to start the truck, it wouldn't start by just pushing the button. I got the notification "keyfob not detected", so I had to push the fob on the ignition button to get it to start up. I expect I won't have this same problem later today, but we'll see.

This has been an intermittent problem for me basically since I bought the truck new 2 years ago. It seems to be getting slightly worse over time.
 

Blake903

Junior Member
Joined
Jun 20, 2024
Posts
6
Reaction score
0
Location
Kentucky
Ram Year
2015
Engine
3.0 ed
My 2015 has done this to me, twice. Alarm with key entry, no FOB response, no cluster illumination, no crank, just interior lighting, and horn, the same behavior you are seeing. Through a process of elimination, I discovered leaving my Banks iDash Data Monster connected to the OBD port was the cause. Strange, my 2022 also has the data monster but never demonstrated this problem so I'm thinking the iDash may have an issue screwing up the CAN bus thus paralyzing the truck.

Do you have any after-market devices connected to your OBD?
I'm having this exact issue on my 2015. But I have nothing connected to the OBD2 port.
 

BossHogg

Senior Member
Joined
Feb 23, 2014
Posts
1,970
Reaction score
2,534
Location
Oakland Township, Michigan
Ram Year
2015
Engine
6.7L Cummins
I'm having this exact issue on my 2015. But I have nothing connected to the OBD2 port.
I wish I could give you a direction so you can find the issue but I don't. In my case, simply unplugging the iDash from the OBD port brought the vehicle back to life. I do need to investigate this issue, I'm assuming it is the iDash that is the cause but based on your experience, the issue may be something else.

If I discover anything I'll let you know. In the meantime, if you have the equipment and skill, look at the CAN buses on the OBD port to see if they look right. You can find examples of what good CAN bus signals look like on many YT videos.
 

Blake903

Junior Member
Joined
Jun 20, 2024
Posts
6
Reaction score
0
Location
Kentucky
Ram Year
2015
Engine
3.0 ed
I wish I could give you a direction so you can find the issue but I don't. In my case, simply unplugging the iDash from the OBD port brought the vehicle back to life. I do need to investigate this issue, I'm assuming it is the iDash that is the cause but based on your experience, the issue may be something else.

If I discover anything I'll let you know. In the meantime, if you have the equipment and skill, look at the CAN buses on the OBD port to see if they look right. You can find examples of what good CAN bus signals look like on many YT videos.
I'm getting no signal to the obd2 port. Only 12v power. I have no voltage at the fuses in the TICM for ecm or PCM. Any idea if I can put 12v to them and maybe get a scanner hooked up?
 

blue ghost

Senior Member
Supporting Member
Joined
Mar 11, 2017
Posts
103
Reaction score
63
Location
Pennsylvania
Ram Year
2013 Ram 1500 sport
Engine
hemi 5.7
Call Uconnect they will help you reset the Hub, i am not sure but it is similar to resetting the radio.
 

BossHogg

Senior Member
Joined
Feb 23, 2014
Posts
1,970
Reaction score
2,534
Location
Oakland Township, Michigan
Ram Year
2015
Engine
6.7L Cummins
I'm getting no signal to the obd2 port. Only 12v power. I have no voltage at the fuses in the TICM for ecm or PCM. Any idea if I can put 12v to them and maybe get a scanner hooked up?
All I know is when you first open the door, the CAN bus should be active. For how long I don't know. I just don't have the knowledge to go further.
 
Top