Alfaobd help aux switches

Joined
Aug 10, 2021
Posts
34
Reaction score
3
Location
Minnesota
Ram Year
2013
Engine
Hemi 5.7
I recently installed an aux panel onto my ram 13' 1500 but now my traction control and tow haul do not work and I'm looking on what features do I enable to turn on the aux switches and fix my traction control and tow haul, I looked for aux switches in car configuration and didn't find anything
 

joelmic

Senior Member
Supporting Member
Joined
Jul 17, 2019
Posts
493
Reaction score
445
Location
stl mo
Ram Year
2017 Ram 1500 Express Quad Cab 3.6L 4x4 20x9 Wheels
Engine
3.6
I recently installed an aux panel onto my ram 13' 1500 but now my traction control and tow haul do not work and I'm looking on what features do I enable to turn on the aux switches and fix my traction control and tow haul, I looked for aux switches in car configuration and didn't find anything
Where did you buy it from?
 
Joined
Aug 10, 2021
Posts
34
Reaction score
3
Location
Minnesota
Ram Year
2013
Engine
Hemi 5.7

DodgeV10

Junior Member
Joined
May 21, 2013
Posts
1
Reaction score
0
Location
Omaha, NE
Ram Year
2015 2500 4X4
Engine
5.7 V8
Close to the same thing happened to me. I didn't have the aux switches in my truck when I first got it. I got a panel with the same controls only with the aux switches added. Put in the aux wiring. Did the AlfaOBD. Got the commercial controls in the instrument cluster. The problem I started having was the aux 3, 4, and 5 buttons wouldn't work. 1 and 2 just fine. Checked everything. I was told when you do a switch, make sure you unplug the battery and wait about 10 mins before replacing any electronics.
Got another switch control with the aux off of eBay. Did the battery unplug. Put in the new switches. And that fixed everything.
I was also told that these switches are a hit and miss. Some may work fine. Some my half work. and some my not work at all.
My suggesting to you is put in the old switches and see if they work again. If they do, find and buy another switch control panel.
 

mtnrider

Senior Member
Joined
Sep 25, 2014
Posts
2,263
Reaction score
1,964
Location
Georgia
Ram Year
2016
Engine
6.7 Cummins
^ What DodgeV10 said, most likely a bad switch. Throw the old one in and see if it works





.
 

Latest posts

Forum statistics

Threads
170,774
Posts
2,554,077
Members
118,283
Latest member
pudhy
Top