Dead cummins

Scots

Junior Member
Joined
Dec 2, 2021
Posts
7
Reaction score
3
Location
Oregon
Ram Year
2016
Engine
6.7
Hello,

My 2016 2500 6.7 did not start this morning. Engine started for a spit second and shut back down. Stored messages on dash are Park Sense Unavailable and Service Airbags.
I went and rented a code reader and there 8 trouble codes. P0882, p0341, p0087, p0541, p0254, p0750, u0290 and u0001. None of them will clear.
Truck was running great when I parked yesterday. Had new fuel and oil filters 2wks ago and they sold me on using BG 245 diesel system cleaner when I was in. Probably have close to 1000mile since all that.
Other strange things I noticed, hvac fan not working, can’t hear fuel pump and horn doesn’t sound when locking with Fob.
I’m at a loss with so many codes..
Truck has 72k on it and I have the extended warranty but can’t get in till January.. crazy, I know.

Any help would be greatly appreciated

Scott
 

rule18

Admin
Administrator
Supporting Member
Joined
Jan 31, 2013
Posts
4,000
Reaction score
5,050
Location
Orange County, NY
Ram Year
2017 Rebel
Engine
3.6, 3.92 and a Pedal Commander
Hello,

My 2016 2500 6.7 did not start this morning. Engine started for a spit second and shut back down. Stored messages on dash are Park Sense Unavailable and Service Airbags.
I went and rented a code reader and there 8 trouble codes. P0882, p0341, p0087, p0541, p0254, p0750, u0290 and u0001. None of them will clear.
Truck was running great when I parked yesterday. Had new fuel and oil filters 2wks ago and they sold me on using BG 245 diesel system cleaner when I was in. Probably have close to 1000mile since all that.
Other strange things I noticed, hvac fan not working, can’t hear fuel pump and horn doesn’t sound when locking with Fob.
I’m at a loss with so many codes..
Truck has 72k on it and I have the extended warranty but can’t get in till January.. crazy, I know.

Any help would be greatly appreciated

Scott
Have you been here to see what the codes are (in case the reader you rented didn't define them): https://www.obd-codes.com/trouble_codes/

This seems like it's going to turn out to be a computer thing, not mechanical issues.
 

Scots

Junior Member
Joined
Dec 2, 2021
Posts
7
Reaction score
3
Location
Oregon
Ram Year
2016
Engine
6.7
Yes I did, sorry for not adding that info.

P0882- tcm power input signal low.
P0341- camshaft sensor A, bank A
P0087- fuel rail/system pressure too low
P0541- intake air heater A circuit low
P0254- injection pump metering control A high
P0750- shift solenoid A
U0290- lost comms with NOX sensor A
U0001- high speed CAN comms Bus
 

rule18

Admin
Administrator
Supporting Member
Joined
Jan 31, 2013
Posts
4,000
Reaction score
5,050
Location
Orange County, NY
Ram Year
2017 Rebel
Engine
3.6, 3.92 and a Pedal Commander
I'm gonna move this thread to the 4th Gen Heavy Duty area, you might get more views.
 

Scots

Junior Member
Joined
Dec 2, 2021
Posts
7
Reaction score
3
Location
Oregon
Ram Year
2016
Engine
6.7
Yes, truck turns over and starts for a split second still. Although it’s cranking longer now to get that split second start.


Thank you Rule18 for moving it to the right area. Newb mistake
 

EdGs

Senior Member
Joined
Nov 29, 2020
Posts
1,015
Reaction score
1,170
Location
FL
Ram Year
2015
Engine
Hemi 5.7L
Will the truck turn over at all now? Are you on the original batteries? If I had to take a wild guess it would be your batteries.


.
If the batteries are low, electronics start doing weird sh*t when they are starved for power.

A shorted cell would definately drag the power down a bit. I've even seen bad connections at the battery itself prevent the battery from recharging.

It will be interesting to see what the outcome is. I hope you get it sorted out.
 

mtnrider

Senior Member
Joined
Sep 25, 2014
Posts
2,319
Reaction score
2,051
Location
Georgia
Ram Year
2016
Engine
6.7 Cummins
Yes, truck turns over and starts for a split second still. Although it’s cranking longer now to get that split second start.


Thank you Rule18 for moving it to the right area. Newb mistake

Well shoot, was hoping for a simple fix for you. Those are unusual codes to have all at once that's why I'm thinking a power issue? I would check all your power and grounds just to illuminate those.

.
 
Top