INFO - 2013-2018 8.4A /AN FW Notes (RA3/VP3-NA & RA4/VP4-NA & UAx)

SitKneelBend

Senior Member
Joined
Jan 8, 2015
Posts
7,506
Reaction score
3,559
Location
St. Louis
Ram Year
2014
Engine
3.6 Pentastar
Looking for some help on a 14.

My current software is 13.38.52 and I've downloaded the newest 18.45.01 update but of course it doesn't work. In the instructions it mentions that if you currently have anything older than 16.16.13 to "proceed to your local dealer."

Can I go through and update each update to get me to the current one? I saved all the files off the main page for the 14's: 14.25.5, 15.26.1, 16.13.13, 17.11.07, 17.43.01. And eventually be able to update to the latest 18.45.01? Do I need to do all? What would you all recommend? Reason I'm updating, other than to update is that I bought new maps.
You might be able to get away with just 15.26.1 and 16.13.13. I think a security change is included in 15.26.1 that 16.13.13 is dependent on. You could try just doing 16.13.13 and see what happens.

Edit: just listen to @Mpgrimm2...
 

Journeyman83

Junior Member
Joined
Jun 29, 2021
Posts
13
Reaction score
0
Location
Kansas City
Ram Year
2017
Engine
Hemi 5.7
My truck is Canadian, but I used the US software update. If I remember correctly, it's been awhile. And mine is the RA3.

Yes, I believe I still have the file on a removeable hard drive. I'll look right quick.

ETA: yes, I have the file.
Is it possible to get the Canadian files?
 

Mpgrimm2

Senior Member
Preferred Vendor
Military
Joined
Mar 30, 2014
Posts
5,528
Reaction score
3,638
Location
Anderson, SC
Ram Year
2019 Laramie QC (5th Gen)
Engine
5.7L eTorque
Let me be more specific

v15 to v17 are Canadian specific

V18.45.x is a North America USA/Canada specific update to fix a specific GPS y2k Time sync bug.

Hopefully @Ken226 @bloup or someone else has a 2017 RA3 VP3-CA fw update fine for v17.x.x you can get
 
Top