Help Support Ram Forum by donating:


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"LAMP OUT" displayed

Discussion in 'General Discussions' started by Snarley, Apr 25, 2021.

  1. Snarley

    Snarley Junior Member

    Age:
    71
    Posts:
    1
    Likes Received:
    0
    Joined:
    Nov 22, 2020
    Location:
    Saint Bonifacius, MN
    Ram Year:
    2003
    Engine:
    5.7 Hemi
    Periodically, the "LAMP OUT" message is displayed on instrument panel and alarm sounds off. I have checked all the bulbs and they all seem to work. 2003 2500 4x4 with 5.7L.
    I suspect there is a loose wire somewhere. Anyone else experienced this?
     
  2. XDarkMaelstromX

    XDarkMaelstromX Junior Member

    Age:
    32
    Posts:
    4
    Likes Received:
    0
    Joined:
    Apr 26, 2020
    Location:
    Texss
    Ram Year:
    2003
    Engine:
    4.7
    I had that recently on my 03 4.7. Checked all my lights, had my wife push the brakes/reverse. found out that my drivers brake light was out. bulb was good so cleaned up the connectors and push everything in nice and snug. that fixed it. check your bulbs again, if theyre all good then like you said, it might be a loose wire.
     
  3. GTyankee

    GTyankee Senior Member Supporting Member Military

    Age:
    77
    Posts:
    1,350
    Likes Received:
    1,913
    Joined:
    Nov 2, 2020
    Location:
    El Cajon Calif. 92021
    Ram Year:
    2016
    Engine:
    3.0 ecodiesel
    If your going to the trouble of taking the covers off of bulbs
    I would have some Emory cloth & some Electric Contact Cleaner with me & use it

    Preventative Maintenance
     
    tron67j likes this.
  4. Smokeybear01

    Smokeybear01 Senior Member Military

    Age:
    71
    Posts:
    200
    Likes Received:
    88
    Joined:
    Jan 25, 2020
    Location:
    US
    Ram Year:
    2005
    Engine:
    Cummins 5.9l
    I had that occasionally since swapping out all my bulbs with LEDs even though I used resistors and the whole 9 yards. Turned out to be a loose connection in the driver's side rear fender running light. I cleaned, greased and reassembled and never had it since. (duallies have running lights frt and rr on the fenders)
     
  5. tron67j

    tron67j Senior Member

    Posts:
    1,400
    Likes Received:
    1,150
    Joined:
    Oct 14, 2019
    Location:
    Maryland
    Ram Year:
    2018
    Engine:
    6.4 Hemi
    Best way to eliminate potential problems is replace all external light bulbs and clean up the sockets while doing it. If you still get error warning, that becomes a wire check next.
     

Share This Page