LED Mirror Lights

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Badger 13

Senior Member
Joined
Jul 30, 2018
Posts
1,189
Reaction score
1,160
Location
North Idaho
Ram Year
2013 Dodge Ram 1500
Engine
5.7 Hemi

1SloRam

Senior Member
Joined
Sep 17, 2020
Posts
542
Reaction score
581
Location
Ms
Ram Year
2013
Engine
Hemi 5.7
Over on the Ram FB groups there are a few guys running the eBay/Amazon ones and have no issues. I’ll be going that route as well. They’re maybe $45.
 
OP
OP
Badger 13

Badger 13

Senior Member
Joined
Jul 30, 2018
Posts
1,189
Reaction score
1,160
Location
North Idaho
Ram Year
2013 Dodge Ram 1500
Engine
5.7 Hemi
Thanks, I don't do FB stuff, but I'll look around. They seem to be a nice addition.
 

haleme

Senior Member
Joined
Aug 26, 2021
Posts
145
Reaction score
177
Location
VA
Ram Year
2018
Engine
6.4
Dang, that is expensive. Is this a combo turn and puddle light housing? I have towing mirror and got the $25 pair of puddle light upgrades from Amazon.
 

1SloRam

Senior Member
Joined
Sep 17, 2020
Posts
542
Reaction score
581
Location
Ms
Ram Year
2013
Engine
Hemi 5.7
Dang, that is expensive. Is this a combo turn and puddle light housing? I have towing mirror and got the $25 pair of puddle light upgrades from Amazon.
Yes, with a chasing style turn signal animation. Supposed to be brighter.
 

Heatstud

Junior Member
Joined
Feb 24, 2024
Posts
8
Reaction score
4
Location
NW Washington
Ram Year
2009
Engine
5.7
I bought a pair for my 2009 Laramie. Installed them and have been sorry ever since. The first pair (well, both pairs so far) blink, but not consistently. They might blink twice then stop, then blink 3 times, then stop, then not stop for 2 minutes, with no rhyme or reason. And each side is different in its blinking.
Contacted Morimoto and filed a warranty claim. First person said send them a video of the issue and they’d get back to me. The second person emailed me that they the lights are faulty and they’re starting a warranty claim. After 4 emails and 2 phone calls over the course of 5-6 weeks, I finally got them to send me a second set.

Which did the same thing.
So, I called them back and they said, “Let’s throw another set at it”. Their tech support could give me no answers as to what the problem is, whether its my truck or the lights. Since they’re willing to send another set, I’d guess its the lights.
I love the way they look when working, but dealing with has been an ordeal. Emailing new video of the issue today. I’ll update with positive results, hopefully.
 
OP
OP
Badger 13

Badger 13

Senior Member
Joined
Jul 30, 2018
Posts
1,189
Reaction score
1,160
Location
North Idaho
Ram Year
2013 Dodge Ram 1500
Engine
5.7 Hemi
That has to be frustrating, especially coming form a company like Morimoto. I did get a set for my 2013 last summer and so far they have been just fine. I sure hope it works out for you.
 

Turbo67

Member
Supporting Member
Joined
Jun 25, 2018
Posts
82
Reaction score
82
Location
Somerset, PA
Ram Year
2018, 2007
Engine
5.7, 5.9
I love mine, I was a ******* and cracked the auto dimming glass installing them. That was an expensive oops. I love the smoked look and the turn signal switch backs. Very satisfied with them
 

RamDiver

Senior Member
Joined
Jan 23, 2022
Posts
2,391
Reaction score
4,163
Location
Marlborough, Ontario, Canada
Ram Year
2021
Engine
Hemi 5.7
I bought a pair for my 2009 Laramie. Installed them and have been sorry ever since. The first pair (well, both pairs so far) blink, but not consistently. They might blink twice then stop, then blink 3 times, then stop, then not stop for 2 minutes, with no rhyme or reason. And each side is different in its blinking.
Contacted Morimoto and filed a warranty claim. First person said send them a video of the issue and they’d get back to me. The second person emailed me that they the lights are faulty and they’re starting a warranty claim. After 4 emails and 2 phone calls over the course of 5-6 weeks, I finally got them to send me a second set.

Which did the same thing.
So, I called them back and they said, “Let’s throw another set at it”. Their tech support could give me no answers as to what the problem is, whether its my truck or the lights. Since they’re willing to send another set, I’d guess its the lights.
I love the way they look when working, but dealing with has been an ordeal. Emailing new video of the issue today. I’ll update with positive results, hopefully.

This behaviour sounds remarkably like the headlight flicker after upgrading to LED bulbs.

I wonder if AlfaOBD might have any solutions to resolve this issue. I'll have a look when I fire up my PC.

Update:
I scanned every option available, AlfaOBD has an LED option for every other bulb on the truck including reverse lights and license plate bulbs but nothing for the puddle lamps.

This was the only mention of puddle lamps that I could find;

Puddle lamp present.jpg

It might be an interesting test to see how this option is set while having the LED bulbs installed and then setting it to yes, if it's not already there. The LED bulbs may not be providing a sufficient load to be sensed by the BCM.

.
 
Last edited:

Heatstud

Junior Member
Joined
Feb 24, 2024
Posts
8
Reaction score
4
Location
NW Washington
Ram Year
2009
Engine
5.7
RamDriver, thanks for checking it out. I also whipped out the AlfaOBD to check it out and found what you did. I could have sworn when I first looked through the Alfa that it mentioned “LED” mirror lights, but I can’t find it anywhere.

As an aside, Alfa does say I have a short in the power mirrors for both right and left sides. I thought this is related to the mirrors not being “centered” after the installation. You have to manually move them to their stops to do it correctly. I also felt there was a technique with the truck itself that the mirrors could be centered. Like the windows and sunroof.
 

RamDiver

Senior Member
Joined
Jan 23, 2022
Posts
2,391
Reaction score
4,163
Location
Marlborough, Ontario, Canada
Ram Year
2021
Engine
Hemi 5.7
RamDriver, thanks for checking it out. I also whipped out the AlfaOBD to check it out and found what you did. I could have sworn when I first looked through the Alfa that it mentioned “LED” mirror lights, but I can’t find it anywhere.

As an aside, Alfa does say I have a short in the power mirrors for both right and left sides. I thought this is related to the mirrors not being “centered” after the installation. You have to manually move them to their stops to do it correctly. I also felt there was a technique with the truck itself that the mirrors could be centered. Like the windows and sunroof.

You're most welcome.

I'll scan AlfaOBD again when I find the time, I was nodding off while scanning early this morning. LOL

Does the option for 'Puddle lamp present' indicate Yes?

I'm not familiar with the mirrors 'not being centred'. Did your truck come with the mirrors or did you add them?

If AlfaOBD is showing an error on your mirrors, was that present before changing to LED puddle lamps?

.
 

Heatstud

Junior Member
Joined
Feb 24, 2024
Posts
8
Reaction score
4
Location
NW Washington
Ram Year
2009
Engine
5.7
Ramdriver
Yes, my truck had factory puddle lamps and turn signals, but they didn’t work when I bought it. The only reason I looked was because I saw an add on youtube. Mine were toast. I didn’t have a reason to check Alfa at the time. Thinking back, it was one of the reasons I bought alfa.
 

HarryS

Member
Joined
Jan 29, 2024
Posts
55
Reaction score
17
Location
Clovis NM
Ram Year
2014
Engine
Hemi 5.7
The reason you can't find LED option for puddle lamps is because the originals are LED.
 

Heatstud

Junior Member
Joined
Feb 24, 2024
Posts
8
Reaction score
4
Location
NW Washington
Ram Year
2009
Engine
5.7
The reason you can't find LED option for puddle lamps is because the originals are LED.

From what I pulled off of the truck, I figured. My original question was why have 2 sets of Morimoto replacements have had the same issue. I find it difficult to believe they were both faulty, but I work in HVAC and am well aware of bad runs of a usually quality part. So I threw the question out there. It has been answered. Thank you, sir.
 
Top