Help Support Ram Forum by donating:


Service 4wd

Discussion in 'Heavy Duty' started by bowhunt32, Feb 11, 2015.

  1. bowhunt32

    bowhunt32 Junior Member

    Posts:
    6
    Likes Received:
    3
    Joined:
    Feb 11, 2015
    Ram Year:
    2015
    Engine:
    6.4 Hemi
    First post, and thank you all in advance for any information you all may have. I have a 2015 Ram 2500, 6.4 Hemi. Starting last weekend I began getting the "Service 4wd" message on the information screen. Typically it lasts only a minute or two directly upon start up, then goes out. Today it came on and stayed on most of the day. I took the truck in yesterday to the dealer. They seemed stumped, checked all connections and said all was good. No codes when scanning the computer. Today it came on and off three times. I call them back, again met with a stumped sounding service manager. He said he'd discuss with his tech and get back to me. He called me back and said they were going to replace the powertrain control module. I'd like to be confident in what they are doing, but have to say, I sensed a lot of doubt in his voice with this suggestion. So, my question for you all is, does this sound right and have any of you encountered a similar problem?
     
  2. Ratket

    Ratket Senior Member

    Posts:
    3,411
    Likes Received:
    1,172
    Joined:
    Jul 14, 2014
    Location:
    Arizona-
    Ram Year:
    2018 1500
    Engine:
    Hemi 5.7
    wich problem? the one the truck is having with the codes? or the one the dealership can't figure out so they are just gonna start throwing new parts at it? .. On the bright side at least they are gonna throw new parts at it, that's better than them doing nothing. best of luck hopefully it gets corrected with the new parts
     
  3. SouthTexan

    SouthTexan Senior Member

    Posts:
    1,896
    Likes Received:
    955
    Joined:
    Jan 24, 2015
    Ram Year:
    2014
    Engine:
    408 CTD
    @bowhunt32

    Tell them to reflash the Drive Train Control Module (DTCM). There was a TSB on the very same issue on some of our fleet trucks a few years ago. That fixed the issue on most, but some had to have all front drivetrain sensor connectors regreased to get the issue fixed.
     
  4. Ratket

    Ratket Senior Member

    Posts:
    3,411
    Likes Received:
    1,172
    Joined:
    Jul 14, 2014
    Location:
    Arizona-
    Ram Year:
    2018 1500
    Engine:
    Hemi 5.7
    ^ what he said
     
  5. bowhunt32

    bowhunt32 Junior Member

    Posts:
    6
    Likes Received:
    3
    Joined:
    Feb 11, 2015
    Ram Year:
    2015
    Engine:
    6.4 Hemi
    Thanks for the suggestions, but thus far none of any of this has fixed the truck. After the initial visit and several hours of checking connections and programming updates, the "SERV 4wd" light returned. Called them back, they ordered a drive train control module and replaced. Again on way home, light returned and continued to come on and off. Over the next few days, light came on when I actually needed the use of the 4wd system which irritated me. I contacted RAM and they forwarded to a case manager. Case manager proceeds to tell me about how he works on atv's and dirt bikes and how 4 wheeling and "rock crawling" is hard on 4wd systems. I'm further irritated at this point as at this time truck has 1900 mile or so on it. I remind him that this is not a wear and tear issue and the truck has not yet made it to it's first oil change. I also remind that on the first day I bought the truck, the touch screen radio was blanking out. It took two trips to get this fixed as well, so in all this was now going to be my 5th trip into the dealership, again on a vehicle that has not even seen its first oil change. Fast forward, a couple weeks go by, dealership is supposedly in contact with engineers. This time they crack into the transfer case. They report finding a "coil" with a high draw and a melted connection. Those parts along with transfer case wiring harness ordered. Dealer has the truck for 10 days at this point. Repairs are made again (this being now the third attempt at same issue). Again driving home, light returns and has now come on and off 4 times in 30 miles or so. At this point I have 2500 miles on the truck, and will now need a 6th trip to the dealer. I have asked RAM for a replacement vehicle and intend on obtaining legal counsel should they refuse. So, I guess that's the update if any of you run into a similar issue.
     
  6. Ratket

    Ratket Senior Member

    Posts:
    3,411
    Likes Received:
    1,172
    Joined:
    Jul 14, 2014
    Location:
    Arizona-
    Ram Year:
    2018 1500
    Engine:
    Hemi 5.7
    you are on the right track. that totally sucks, you are prolly thinking of brand jumping now, as I would be. Best of luck man.
     
  7. regularcab2500

    regularcab2500 Senior Member

    Posts:
    1,321
    Likes Received:
    341
    Joined:
    Aug 21, 2014
    Location:
    Buffalo
    Ram Year:
    1997
    Engine:
    5.9 Magnum
    Look into your state lemon laws and shove the truck back up their behinds. Clearly something is seriously wrong.
     
  8. bowhunt32

    bowhunt32 Junior Member

    Posts:
    6
    Likes Received:
    3
    Joined:
    Feb 11, 2015
    Ram Year:
    2015
    Engine:
    6.4 Hemi
    So, to put a bookend on this, my dealership did get this issue fixed. Turned out to be a wire that tied into the 4wd shift motor was rubbing and had an intermittent short. I've put about 3000 miles on it since they found the wire issue and have had no other problems. Now truck works perfectly! Thank you for your input on the issue!
     
    Matt Jobe, RAMYOU and regularcab2500 like this.
  9. JAILER 23

    JAILER 23 Junior Member

    Posts:
    3
    Likes Received:
    3
    Joined:
    May 14, 2015
    Location:
    New York
    Ram Year:
    2015
    Engine:
    6.4 HEMI
    2015 RAM 2500 (OUTDOORSMAN - CREW CAB) 6.4 GASSER - 4.10 DIFF. - ORDERED 3/31/15 - PICKED UP FROM DEALERSHIP THURSDAY 5/28/15 WITH 7.5 MILES -----SUNDAY 5/31/15 GOING 25 M.P.H. TURNED DIAL 2WD TO 4WD (GOING STRAIGHT - NO SHARP TURNS) ON WET ROAD (RAINING) - "SERV 4WD" CAME ON - NO 4WD ENGAGED - 123 MILES ON ODO. --- TRIED FIGURE 8's IN EMPTY PARKING LOT - SWITCHING 2WD 4WD 4WD LOW - ENGINE ON ENGINE OFF WITH IGNITION ON STILL " SERV 4WD" ------ALSO E.V.I.C. SHOWING "SERV 4WD" ----
     
  10. Ratket

    Ratket Senior Member

    Posts:
    3,411
    Likes Received:
    1,172
    Joined:
    Jul 14, 2014
    Location:
    Arizona-
    Ram Year:
    2018 1500
    Engine:
    Hemi 5.7
    Caps lock is not ur friend. What's that placed called where they fix New vehicles that have problems... starts with a D.. they also sell new vehicles.. take it to the dealer.
     

Share This Page