UConnect system malfunction and compass issue

putergeeks

Junior Member
Joined
Oct 29, 2021
Posts
2
Reaction score
0
Location
Milwaukee, WI
Ram Year
2019
Engine
Hemi 5.7L
I recently picked up a used 2019 Ram 1500 Laramie. Previously had a 2017 Ram 1500 Big Horn.

The Uconnect system with remote start was very useful to me in my 2017, so I subscribed my 2019 as well. The problem is that it never works. It always says failed, no matter if I try to remote start or lock/unlock doors, etc.

When I press the Assist button in the overhead console, I noticed something. Although my phone has good signal, the Uconnect has zero signal. Notice the bars next to "Activate Connected Services" as compared to the bars at the bottom by "Phone". Has anyone had this problem? Is there a fuse or something that may have blown that powers the 4G modem?

Also, my onboard compass rarely indicates the correct direction. Many times I am heading South and it says N or W or whatever it wants. It hardly ever indicates the direction that I am actually travelling. This is more of an annoyance than anything, but I wonder if the two issues may be related.

Finally, my onboard GPS always says that I am driving in Lake Michigan (who knew the Ram could float?!). I use Carplay with Waze anyway, but again, it is an annoyance that may be related.


You must be registered for see images attach
 

putergeeks

Junior Member
Joined
Oct 29, 2021
Posts
2
Reaction score
0
Location
Milwaukee, WI
Ram Year
2019
Engine
Hemi 5.7L
Nobody had this problem? Is there anything that I can clarify? Sometimes my thoughts don't fully make it from my head to the keyboard.
 

Dean2

Senior Member
Joined
Jun 17, 2021
Posts
483
Reaction score
449
Location
Near Edmonton
Ram Year
2021
Engine
6.4
Common problem. The GPS pooched itself on the Grand Cherokee with 12,000 miles. Dealer replaced whole radio under warranty. Replacement radios are refurbished units and it took 3 months to get it in. Buddy had the same problem with his. If you Google Unconnect GPS doesn't work you will find a ton of complaints and threads. In fact if you look at the related threads jut below the posts when you open this one you will find a bunch from right on this site. The 8.4 UConnect has a lot of problems, probably the weakest component on the trucks and Jeeps.
 
Top