Upgraded Radio still no Carplay

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

ramchuck

Junior Member
Joined
May 13, 2016
Posts
11
Reaction score
3
Location
Shadyside, Ohio
Ram Year
2010
Engine
5.7 Hemi
I have a 2017 2500 Laramie Limited and recently purchased a 2021 8.4 Uconnect radio, an adapter and new usb media hub. No Carplay and no charging of my Iphone. Everything else works on the new Uconnect radio. Any help is appreciated. Is there a setting? I purchased a new "Apple" cable, tried 2 different media hubs, 2 different adapters, and also another 2021 radio. So, I am at a loss.

Thanks
 

Atcer2018

Senior Member
Military
Joined
Aug 10, 2019
Posts
1,241
Reaction score
1,857
Location
Virginia
Ram Year
2018
Engine
3.6
No charging point to an electrical issue. Even if the radio wasn’t capable of CP the hub should still charge. Most likely your problem is between the hub and radio. But first let me ask is the radio unlocked and recognized by the BCM? Is the hub and cable you purchased OEM or aftermarket?
 

ric221

Senior Member
Joined
Nov 18, 2013
Posts
196
Reaction score
131
Ram Year
2016
Engine
5.7L Hemi
@ramchuck, I can't help with your question and I'm Sry to hijack your thread, but did you have any issues with this unit fitting in you dash, and are the connectors the same?
 

diymirage

Senior Member
Joined
Jan 24, 2024
Posts
367
Reaction score
389
Location
Michigan
Ram Year
2017
Engine
5.7
i know many of the aftermarket radios dont seem to incorporate the media hub properly
 
OP
OP
R

ramchuck

Junior Member
Joined
May 13, 2016
Posts
11
Reaction score
3
Location
Shadyside, Ohio
Ram Year
2010
Engine
5.7 Hemi
Appreciate the feedback:
1. I will get a picture of the radio, but it is a 2021 Mopar 8.4 and bolts exactly into the dash. The connections plug into the radio although they are in a different order right to left or left to right. Oddly if I don't use the adapter and plug the original harness and original USB hub in the phone will charge, but of course no CP. I will get a pic of both radios and post them. Thanks
 

crash68

ACME product engineer
Staff member
Administrator
Supporting Member
Joined
Mar 20, 2016
Posts
10,913
Reaction score
17,206
Ram Year
2015
Engine
3.0 EcoDiesel
did you have any issues with this unit fitting in you dash, and are the connectors the same?
The only adapter you should need is the one for the Media USB hub that needs to be replaced. Even the UAQ I installed in my '15 bolted in place and all radio plugs worked.
a 2021 8.4 Uconnect radio, an adapter and new usb media hub. No Carplay and no charging of my Iphone.
You need to resolve why the phone doesn't show that it's charging when plugged into the Media USB port. Possibly the new Media USB hub is bad or there's a problem with the wiring adapter. The power for charging the phone comes from the truck via 12V wire that goes to the hub, it's not charged via the USB power coming from the radio.
 

tron67j

Senior Member
Joined
Oct 14, 2019
Posts
3,023
Reaction score
3,206
Location
Maryland
Ram Year
2018
Engine
6.4 Hemi
Appreciate the feedback:
1. I will get a picture of the radio, but it is a 2021 Mopar 8.4 and bolts exactly into the dash. The connections plug into the radio although they are in a different order right to left or left to right. Oddly if I don't use the adapter and plug the original harness and original USB hub in the phone will charge, but of course no CP. I will get a pic of both radios and post them. Thanks
Who did you purchase your adapter from? The fact that it doesn't allow charging could mean it isn't correct. Harnesses for 2018+ trucks are different than prior years and it is possible you have the wrong harness.

For the pictures, you need the sticker(s) on the back as that will show exactly what radio you purchased.
 

CoZo6

2021 Longhorn Limited 1500
Joined
Feb 25, 2018
Posts
129
Reaction score
79
Location
Colorado
Ram Year
2021
Engine
5.7 eTorque
I would suggest follow this thread in the 4th generation group :

How To: Install a 2018 4C (UAQ/UAS) Radio in 2013 - 2017 RAM​

You will see I posted a few comments, and even though many pages I can’t recall more specifically to help you out. I recall turning something in alfaobd “on” but that thread may help. I installed a UAQ in my 2017 2500 at the time and that thread helped ((I think it was called SCAR or something like that)
 
Last edited:
OP
OP
R

ramchuck

Junior Member
Joined
May 13, 2016
Posts
11
Reaction score
3
Location
Shadyside, Ohio
Ram Year
2010
Engine
5.7 Hemi
OK I took some pictures. Media hub, adapter cable, top of the new radio, back of the new radio, old radio. Again nothing with the phone plugged in, no charging, no CP. When I plugged in the original usb hub, the new radio displayed the message USB not supported, but the phone was charging through the old USB.
hub.jpg
harness.jpgnew radio top.jpg
new radio.jpg
old radio 2.jpg
 

Attachments

  • old radio.jpg
    old radio.jpg
    88.6 KB · Views: 9

crash68

ACME product engineer
Staff member
Administrator
Supporting Member
Joined
Mar 20, 2016
Posts
10,913
Reaction score
17,206
Ram Year
2015
Engine
3.0 EcoDiesel
Again nothing with the phone plugged in, no charging, no CP. When I plugged in the original usb hub, the new radio displayed the message USB not supported, but the phone was charging through the old USB.
The problem is either that hub or the wiring adapter. The hub appears to be the correct part number.

This hub (68283703AA) will fill the opening completely but you do need to enlarge the opening a little bit.
 

tron67j

Senior Member
Joined
Oct 14, 2019
Posts
3,023
Reaction score
3,206
Location
Maryland
Ram Year
2018
Engine
6.4 Hemi
I generally don't like throwing money at a problem, but not sure if the harness can really be tested. You could reach out to @Mpgrimm2 from M²Mods and get a new one, this would eliminate the harness being the issue. Sorry can't help more.
 

ric221

Senior Member
Joined
Nov 18, 2013
Posts
196
Reaction score
131
Ram Year
2016
Engine
5.7L Hemi
As far as C/P goes I don't think you are going to get it with this unit. IIRC the Harmon units did not have C/P ability. I currently have a Harmon unit in my truck and it does not have C/P.
 

Mpgrimm2

Senior Member
Preferred Vendor
Military
Joined
Mar 30, 2014
Posts
6,112
Reaction score
4,201
Location
SC
Ram Year
2022 Ram 1500 (5th Gen)
Engine
5.7L
OK I took some pictures. Media hub, adapter cable, top of the new radio, back of the new radio, old radio. Again nothing with the phone plugged in, no charging, no CP. When I plugged in the original usb hub, the new radio displayed the message USB not supported, but the phone was charging through the old USB.
View attachment 539796
View attachment 539797View attachment 539798
View attachment 539799
View attachment 539800

1st - who did you buy the radio, hub adapter and hub from? (what do they have to say? ... before I can consider offering support)

2nd - The Hub adapter looks like a near exact copy of ours (they even copied our wire colors. dang!)

3rd - What's the new Radio PN? I can't read the Part Number sticker on side of the new Panasonic 4c radio?? (but it appears to be 2020 or newer version with SL02 or SL03 screen... I can tell from the back & should support AA/CP ).

4th - Your 2017 laramie/limited should have Dual Zone Auto Climate correct?
(do the temp controls work correctly. Did the SXM button and BuCam show up/work yet?)

5th - Are you running a custom engine tune?

6th - Did you enable Smartphone Projection in radio settings?

7th - What "Application Version" is the radio running ?
(key in RUN. Press and hold : driver side TEMP Up + TEMP Down + Front Defrost for 5-10 secs for dealer menu)
 
Last edited:

tron67j

Senior Member
Joined
Oct 14, 2019
Posts
3,023
Reaction score
3,206
Location
Maryland
Ram Year
2018
Engine
6.4 Hemi
Yes, I forgot to add that you should always reach out to the selling entity first for assistance. If they are unwilling to help, then one should expect to shell out funds to buy the correct parts from our vendors to obtain support on install. In this case Mike above has very graciously given you a few areas to focus on but you may still need to consider upgrading components to get to the desired state of use. Also Benny from All Mopar Parts can supply the correct hub if all else fails and you can't get yours working after trying other fixes. It is possible you have one or more defective items.
 
OP
OP
R

ramchuck

Junior Member
Joined
May 13, 2016
Posts
11
Reaction score
3
Location
Shadyside, Ohio
Ram Year
2010
Engine
5.7 Hemi
1st - who did you buy the radio, hub adapter, and hub from? (what do they have to say? ... before I can consider offering support) An Ebay seller, "Genuine AutoTech', no complaints with them, their support was to exchange the radio, which they did. So, this issue is with two different 2021 radios, two different adapters, and two different media hubs. So, I tend to think there is an issue with my particular truck or some setting within the radio.

2nd - The Hub adapter looks like a near exact copy of ours (they even copied our wire colors. dang!) I tried 2 hubs, the one pictured from "bicycleparts99" and another from "wallacecjdr" which I returned it was the wider hub with 2 USB ports. The adapters are from "CarPlay" out of Canada, recommended by the radio seller, and the other, I think from "motorcycle126"

3rd - What's the new Radio PN? I can't read the Part Number sticker on side of the new Panasonic 4c radio?? (but it appears to be 2020 or newer version with SL02 or SL03 screen... I can tell from the back & should support AA/CP ). P/N 68518262AF

4th - Your 2017 laramie/limited should have Dual Zone Auto Climate correct?
(do the temp controls work correctly. Did the SXM button and BuCam show up/work yet?) yes everything works, dual zone, cameras, etc.

5th - Are you running a custom engine tune? No completely stock truck

6th - Did you enable Smartphone Projection in radio settings? I am guessing not? don't know where I would do that.

7th - What "Application Version" is the radio running ?
(key in RUN. Press and hold : driver side TEMP Up + TEMP Down + Front Defrost for 5-10 secs for dealer menu) I will have to do this.

Thanks for the help!! much appreciated.
 

Mpgrimm2

Senior Member
Preferred Vendor
Military
Joined
Mar 30, 2014
Posts
6,112
Reaction score
4,201
Location
SC
Ram Year
2022 Ram 1500 (5th Gen)
Engine
5.7L
68518262AF is a 2020/21 Jeep Compass 4c UAQ radio. (not a Ram Model... but they 'sometimes' work... just not this time?).
Panasonic HW PN: CN-SC6ANxxx
Appl. Version: ???

Found an Example (on ebay)

Should be plug n play. Check "projection settings". If still an issue. Get a genuine 4th Gen Ram model 4c UAx (See Post # 3881)
 

tron67j

Senior Member
Joined
Oct 14, 2019
Posts
3,023
Reaction score
3,206
Location
Maryland
Ram Year
2018
Engine
6.4 Hemi
thanks for the information, and help.
Someone just posted this, might help.

 

fishnpo

Junior Member
Joined
Dec 20, 2022
Posts
1
Reaction score
1
Location
Oklahoma
Ram Year
2019
Engine
6.7L
2019 with the 8 inch radio, had trouble with car play. There is a setting in the radio where you have to tell it, can screen share each phone. I think it’s called screen projection, nothing worked until I turned it on for our phones, bout drove me crazy. Even the 2019 won’t do wireless CarPlay, it has to be connected by wire
 
Top