Weird A/C issue

breal201999

Senior Member
Joined
Aug 7, 2016
Posts
246
Reaction score
149
Ram Year
2016
Engine
Hemi 5.7

MRFREEZE57

Senior Member
Joined
Nov 18, 2019
Posts
334
Reaction score
411
Location
pacific northwest
Ram Year
2016
Engine
5.7 hemi
you could be icing up the evaporator and shutting off the compressor with the fan running will allow it to de ice. icing can be caused by low refrigerant condition. the best way to check it out is to have someone put a set of gauges on the system to see what is going on. also check to see if you have a cabin air filter that could be plugged up.
 

breal201999

Senior Member
Joined
Aug 7, 2016
Posts
246
Reaction score
149
Ram Year
2016
Engine
Hemi 5.7
you could be icing up the evaporator and shutting off the compressor with the fan running will allow it to de ice. icing can be caused by low refrigerant condition. the best way to check it out is to have someone put a set of gauges on the system to see what is going on. also check to see if you have a cabin air filter that could be plugged up.
I thought of the cabin filter and I cleaned it (K&N reusable). Also sometimes it’s right from the start it won’t blow cold. Not just after so many minutes running. I have a service appointment Wednesday and will have them check again. May even go ahead and have them extract the coolant and weigh it. Last time they couldn’t duplicate it.
 

breal201999

Senior Member
Joined
Aug 7, 2016
Posts
246
Reaction score
149
Ram Year
2016
Engine
Hemi 5.7
So again, they weighed the oil and it’s low… and couldn’t find the leak. Suspect it’s leaking at the evap core which is behind the dash. The good news is we have the Max Care warranty, and it’s covered minus our $100 deductible. Just crossing our fingers the appointment for next Wednesday goes as expected without any surprises because we leave for Florida that Friday!
 
Top