Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 4th Gen : 2009 - Present > Engine & Performance


Engine & Performance

trans issue


This is a discussion on trans issue within the Engine & Performance forums, part of the 4th Gen : 2009 - Present category!
Anyone have a issue with there transmission delaying going into gear ? I have a 09 ram and it has ...


Like Tree2Likes
  • 1 Post By MADDOG
  • 1 Post By Burla

Sponsored By: Moe's Performance
Reply
 
LinkBack Thread Tools Display Modes
Old 01-02-2017, 04:08 PM   #1 (permalink)
Junior Member
 
Join Date: Jan 2017
Location: michigan
Posts: 1

Ram Year: 2009
Engine: 5.7
Default trans issue
Anyone have a issue with there transmission delaying going into gear ? I have a 09 ram and it has a 6second delay before it actually goes into gear. Also went into limp mode and stuck in 4th gear on me a couple times, I stopped the truck and shut it off, let it set for a couple seconds, started it back up and it was fine, I did a code check and it had one for tcm low voltage. Can anyone help me out


Sponsored Ad
Register to remove this ad.
Timstrohaver is offline   Reply With Quote
Old 01-02-2017, 04:12 PM   #2 (permalink)
 
MADDOG's Avatar
Super Moderator

 
Join Date: Dec 2011
Location: Oregon
Posts: 6,867

Ram Year: 2017
Engine: Cummins 6.7L Turbo Diesel
Default
Welcome to RamForum.

A TCM low voltage code is coming from the transmission control module circuit, caused by low battery voltage or an open or short circuit.

I'd check the data cable plug into the transmission case to make sure it's clean, not corroded and has no damage. Also, check the harness from the trans to the PCM to make sure the harness is in good condition.

Good luck!
Burla likes this.


__________________
MICHAEL
SUPER MODERATOR
2017 RAM LARAMIE CTD


MADDOG is offline   Reply With Quote
Old 01-02-2017, 04:27 PM   #3 (permalink)
 
Burla's Avatar
Senior Member
 
Join Date: Apr 2012
Age: 51
Posts: 5,575

Ram Year: 2010 Hemi Reg Cab 4x4
Engine: Hemi
Default
Does it happen in tow haul mode?
huntergreen likes this.


Burla is offline   Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trans issue Dizzy13 Tech Info 1 04-07-2016 11:40 AM
04 trans issue .. ??? coolbikeguy Engine & Performance 1 07-14-2015 08:59 PM
Trans or MDS issue? dtru1222 General Discussions 30 10-27-2014 02:56 PM
Trans issue WildWilly Engine & Performance 4 09-15-2014 03:10 PM
Trans Issue RoadRunner Tech Info 5 12-15-2012 06:25 PM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum