Go Back   DODGE RAM FORUM - Dodge Truck Forums > Dodge Ram Generations Forum > 1st Gen : 1981 - 1993 > Audio & Electronics


Audio & Electronics

electrical issue on 1987 w100


This is a discussion on electrical issue on 1987 w100 within the Audio & Electronics forums, part of the 1st Gen : 1981 - 1993 category!
Hello forum, looking for some advice on my 1987 dodge w100. i am currently having a few electrical issue that ...


Reply
 
LinkBack Thread Tools Display Modes
Old 04-18-2015, 01:01 PM   #1 (permalink)
Junior Member
 
Join Date: May 2014
Posts: 4

Ram Year: 1987
Engine: La small block 318
Default electrical issue on 1987 w100
Hello forum, looking for some advice on my 1987 dodge w100. i am currently having a few electrical issue that are keeping this truck off the road, and will need some help finding a solution.
the first issue is with the headlights. i have installed new replacement bulbs everywhere on this truck. all of the lights work as they should, all but the headlamps themselves. i have checked the fuse box (i could only locate a box located under the steering column) and no blown fuses that i could see.

also, the wiper/washer system does not currently work. i am unsure what the source of this issue is, as a faint buzzing sound can be heard when i turn on the wipers, but the wipers do not move at all. no noise noticed when i engage the washers.


also, on a side note, what would be the best way to wire in a CB radio? i have an old cb and an antenna that was installed by the previous owner, unsure how best to approach that situation.

thanks!


Sponsored Ad
Register to remove this ad.
Moparkid is offline   Reply With Quote
Old 04-18-2015, 04:14 PM   #2 (permalink)
 
Dan70's Avatar
Member
 
Join Date: Dec 2014
Location: westminster, co
Age: 24
Posts: 37

Ram Year: 1993
Engine: 5.9 magnum
Default
Have you checked the fuseable links on the driver side wheel well?

have you tried lightly tapping the wiper motor with a hammer while its on? Is it getting enough voltage?

As far as a cb most of the ones i've ever seen are wired to the batter. Is it going to be a single whip or dual? The front bed corners are the most common places to mount an antenna.


__________________
1993 dodge w350 reg cab, 5.9 magnum, nv4500, dana 60/70, electric fan conversion.
Dan70 is offline   Reply With Quote
Old 04-18-2015, 08:26 PM   #3 (permalink)
 
crazzywolfie's Avatar
Senior Member
 
Join Date: Apr 2013
Location: under the truck
Posts: 13,654

Ram Year: 81 93
Engine: 5.2
Default
have you checked the dimmer switch? that is a common thing that will stop the head lights on these trucks from working.

if the radio is working then i think the fusible link should be fine since i think the radio and wipers share a fusible link. i would possibly look at cleaning the ground connections on the wiper motor. they are a known problem. also does the truck have delayed wipers? if the module is dead the wipers may stop working.


__________________

81 dodge d150 custom long box 318 670CFM Holley Street Avenger Carb
89 RamCharger 4x4 318/727/3.21 on 33's
93 ramcharger 318 FI 2wd
crazzywolfie is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
IDK maybe electrical issue? flyers21fan Audio & Electronics 16 09-09-2014 04:59 PM
electrical issue DDean Interior 2 06-07-2013 04:40 AM
Electrical issue... iSlacker816 Tech Info 24 02-14-2012 09:36 PM
electrical issue? Montgomery Farms P Pump 5 12-30-2011 10:39 AM
possible electrical issue.... Bad Habit Interior 5 07-16-2011 12:50 AM

<




GM Truck Forum
Ford Raptor Forum
Chevy Tahoe Forum
Chevy Cobalt Forum
Chevy Camaro Forum
Toyota FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum