89 ram with issues

Discussion in 'Engine & Performance' started by robsnyder225, Oct 29, 2016.

Sponsored By: Moe's Performance
  1. robsnyder225

    robsnyder225 Junior Member

    Posts:
    15
    Likes Received:
    0
    Joined:
    Oct 29, 2016
    Ram Year:
    1989
    Engine:
    318
    Yes put a plug in the coil wire and it threw some pretty good fire.
     
  2. crazzywolfie

    crazzywolfie Senior Member

    Posts:
    14,102
    Likes Received:
    2,147
    Joined:
    Apr 6, 2013
    Location:
    under the truck
    Ram Year:
    81 93
    Engine:
    5.2
    so it sounds like your issue is probably the distributor cap or rotor then.
     
  3. robsnyder225

    robsnyder225 Junior Member

    Posts:
    15
    Likes Received:
    0
    Joined:
    Oct 29, 2016
    Ram Year:
    1989
    Engine:
    318
    Okay. I cleaned the contacts on the cap because they had a little bit of corrosion on them and the rotor looked brand new. But anything is possible.
     
  4. crazzywolfie

    crazzywolfie Senior Member

    Posts:
    14,102
    Likes Received:
    2,147
    Joined:
    Apr 6, 2013
    Location:
    under the truck
    Ram Year:
    81 93
    Engine:
    5.2
    it is possible to have a bad spark plug or wire but normally they don't fail too often.
     
  5. robsnyder225

    robsnyder225 Junior Member

    Posts:
    15
    Likes Received:
    0
    Joined:
    Oct 29, 2016
    Ram Year:
    1989
    Engine:
    318
    Now I dont have anything coming from the coil. Power is going to it and its brand new. Can't get any spark out now. Totally lost now.
     
  6. crazzywolfie

    crazzywolfie Senior Member

    Posts:
    14,102
    Likes Received:
    2,147
    Joined:
    Apr 6, 2013
    Location:
    under the truck
    Ram Year:
    81 93
    Engine:
    5.2
    the asd relay powers the coil, injectors and everything else that needs power to run. the computer grounds the coil when it gets the signals it needs to think you the engine is turning. i would possibly be checking the hall effects sensor in the distributor.
     
  7. robsnyder225

    robsnyder225 Junior Member

    Posts:
    15
    Likes Received:
    0
    Joined:
    Oct 29, 2016
    Ram Year:
    1989
    Engine:
    318
    Replaced the hall effect and it fired right up. Cleaned up the wiring a little bit more and it seems to be better. Still runs a bit rough but I'm happy its running.
     
  8. crazzywolfie

    crazzywolfie Senior Member

    Posts:
    14,102
    Likes Received:
    2,147
    Joined:
    Apr 6, 2013
    Location:
    under the truck
    Ram Year:
    81 93
    Engine:
    5.2
    glad to hear it is running. it might start running a bit better once you have possibly got a tank of fuel through it. if it doesn't i would possibly try checking for codes again and maybe change the O2 sensor. these things like the NTK O2 sensors if you do replace them. they are usually pretty cheap
     

Share This Page