Help!

Discussion in '6.7 Common Rail' started by hounddog, Dec 16, 2016.

  1. hounddog

    hounddog Senior Member

    Posts:
    377
    Likes Received:
    79
    Joined:
    Jun 2, 2012
    Location:
    Charlevoix, MI
    Ram Year:
    2017 laramie 2500 credit cab 4x4 cummins
    Engine:
    6.7 Cummins
    So, my '14 Ram dually 4x4

    Today when I started it up in 7 degrees, after it got warm it indicated "Perform Service" but otherwise acted normal, 4x4 worked fine to pull me down the snowy roads, and drove it about 25 miles. Zero performance issues, and I felt the truck was telling me to do basic services to it, fuel filter/transmission service/that sort of thing.

    Hooked to my 5th wheel to move it, everything was fine.
    Went to the first stoplight, truck shifted from 2nd to overdrive and wouldn't shift out of OD.

    Then I got a check engine light, a light for the traction control/anti-slip system, a message to service the electric braking system, and then I discovered the 4x4 system was no longer working- won't even indicate it's trying to engage. All these lights and messages remain turned on.

    This truck does have the wiring harness recall, but of course it's on permanent backorder.

    The transmission will reset if I put it in park and shut it off. But, every time I get to speed and let off the throttle it shifts straight to overdrive and won't shift out. Regardless of what gear I hold it in it shifts strsight to OD and stays until I put it back in park and shut it off.

    I should mention the grid heater randomly stopped working last week, and from literally one day to the next about the same time the parking brake went to working properly to not fully engaging but partially engaging.

    Anyone ever heard of such a thing? Can all of this be connected to the computer? Maybe that wiring harness ram recalled?
     
    Last edited: Dec 16, 2016
  2. Power247

    Power247 Senior Member

    Age:
    42
    Posts:
    5,495
    Likes Received:
    807
    Joined:
    Jul 26, 2012
    Location:
    High Point, NC
    Ram Year:
    2012
    Engine:
    CTD 6.7
    Dang man. Definitely something screwy. I know low battery voltage will have the canbus going crazy but I would think that you would have trouble starting too. I guess a bad computer would cause all that too. Hope you can get it sorted quickly

    Greg
    2012 | RAM 2500 | CCSB | Custom tuned by Double R Diesel
    2016 | Heartland Pioneer | DS310
     
    hounddog likes this.
  3. hounddog

    hounddog Senior Member

    Posts:
    377
    Likes Received:
    79
    Joined:
    Jun 2, 2012
    Location:
    Charlevoix, MI
    Ram Year:
    2017 laramie 2500 credit cab 4x4 cummins
    Engine:
    6.7 Cummins
    It seems like there's way too much going on for it to be mechanical.

    It "feels" like it's all related because it all happened within the same time frame, except for the heater grid and parking brake. They happened at the same time together.
     
  4. hounddog

    hounddog Senior Member

    Posts:
    377
    Likes Received:
    79
    Joined:
    Jun 2, 2012
    Location:
    Charlevoix, MI
    Ram Year:
    2017 laramie 2500 credit cab 4x4 cummins
    Engine:
    6.7 Cummins
    For what it's worth now, PCM went kaput. The perform service and the heater grid were a matter of replacing the CCV filter. Did those things and all was well.
     
  5. Power247

    Power247 Senior Member

    Age:
    42
    Posts:
    5,495
    Likes Received:
    807
    Joined:
    Jul 26, 2012
    Location:
    High Point, NC
    Ram Year:
    2012
    Engine:
    CTD 6.7
    Good deal man. Glad you got it sorted out.

    Greg
    2012 | RAM 2500 | CCSB | Custom tuned by Double R Diesel
    2016 | Heartland Pioneer | DS310
     

Share This Page