All shifter lights on with no shifting out of gear

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Noob

Junior Member
Joined
Apr 2, 2024
Posts
1
Reaction score
0
Location
Tennessee
Ram Year
2009
Engine
Hemi 5.7L
Hi, I am new to this forum and need help with my 09 ram 1500. A few days ago driving home all the shifter lights lit up green except reverse was in red and multiple lights came on( transmission oil temp, battery, cel, esp, service 4wd, traction control, the lightning bolt in parenthesis, and abs). When we got home and turned the truck off and tried to start it, shifter lights still lit up but truck was not starting. After waiting for about 30 minutes, the truck started right up but after letting it idle for a few minutes all the lights returned. Went and got a cheap scanner and found codes p3400, p1128, p1129, u110c, u1110, u1120, u0141, p0157, p0158, u1403, u110e. Thanks Noob
 

Ken226

Senior Member
Military
Joined
Mar 12, 2017
Posts
542
Reaction score
526
Location
Washington State
Ram Year
2013
Engine
Hemi
It sounds like your PCM lost communications with pretty much everything.

Mine did something like this once when a loose boot lace tangled in the big computer connector up under driver side kick panel, by the emergency brake pedal, and disconnected that big cable from the computer.


Maybe a computer cable or ground cable is loose or got disconnected somewhere near the kick panel or under the hood.


Edit to add: I looked up those codes, and u1403 seems to be related to that big connector above the e-brake pedal. Check that connector.
 
Last edited:
Top