Idle Misfire 2011

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

shawn46176

Junior Member
Joined
Apr 14, 2024
Posts
4
Reaction score
0
Location
Indiana
Ram Year
2011
Engine
5.7
I really need some ideas here, been fighting this for about six months now, the truck runs great and is my daily driver. Scanner shows misfires on cylinder 1 and 7 only when idling and after its warmed up. at 800rpms it misses like crazy at 900rpm its smooth

5.7 166000 miles

These are the things I've done so far
New Plugs (twice)
New coils
Tested Injectors with noid light and replaced 1 and 7
New 02 Sensors (for the hell of it)
New Cam
New lifters
New MDS solenoids
New VVT sensor
New ECM (no tune) from Flagship one

the only code is P300. After a reset sometimes it is days (several miles) before CEL comes back on

2 Dodge Dealers, 2 well known mechanics in my area and my ******** cant figure it out and Im tired of throwing parts at it

Any adivce is greatly appreciated
 

jws123

Senior Member
Joined
May 16, 2018
Posts
2,182
Reaction score
2,155
Location
nj
Ram Year
2014
Engine
5.7
I really need some ideas here, been fighting this for about six months now, the truck runs great and is my daily driver. Scanner shows misfires on cylinder 1 and 7 only when idling and after its warmed up. at 800rpms it misses like crazy at 900rpm its smooth

5.7 166000 miles

These are the things I've done so far
New Plugs (twice)
New coils
Tested Injectors with noid light and replaced 1 and 7
New 02 Sensors (for the hell of it)
New Cam
New lifters
New MDS solenoids
New VVT sensor
New ECM (no tune) from Flagship one

the only code is P300. After a reset sometimes it is days (several miles) before CEL comes back on

2 Dodge Dealers, 2 well known mechanics in my area and my ******** cant figure it out and Im tired of throwing parts at it

Any adivce is greatly appreciated
Which cam and which lifters did you install and when you did do the cam/lifters where any of the lobes chewed up?
 
OP
OP
S

shawn46176

Junior Member
Joined
Apr 14, 2024
Posts
4
Reaction score
0
Location
Indiana
Ram Year
2011
Engine
5.7
The cam and lifters were OEM, im not sure the crystler part number, the roller bearing was gone on cylinder 3 and it was starting to cut on the lobe
 

jws123

Senior Member
Joined
May 16, 2018
Posts
2,182
Reaction score
2,155
Location
nj
Ram Year
2014
Engine
5.7
The cam and lifters were OEM, im not sure the crystler part number, the roller bearing was gone on cylinder 3 and it was starting to cut on the lobe
Are you sure you put the MDS lifters in the correct spots? it matters also did anyone check for vacuum leaks ect aswell as compression test.
 
OP
OP
S

shawn46176

Junior Member
Joined
Apr 14, 2024
Posts
4
Reaction score
0
Location
Indiana
Ram Year
2011
Engine
5.7
Can’t say for sure on the mds lifters. Compression was tested not sure about vacuum
 

jws123

Senior Member
Joined
May 16, 2018
Posts
2,182
Reaction score
2,155
Location
nj
Ram Year
2014
Engine
5.7
Can’t say for sure on the mds lifters. Compression was tested not sure about vacuum
Any idea what your compression readings where? You may want to do a test yourself its not hard to do.
 
OP
OP
S

shawn46176

Junior Member
Joined
Apr 14, 2024
Posts
4
Reaction score
0
Location
Indiana
Ram Year
2011
Engine
5.7
I haven not found the issue, still misses out when idling but Im suspecting it has the non MDS cam and lifters. even though it has MDS and VVT. I just havent had time to pull it still driving it daily
 

jws123

Senior Member
Joined
May 16, 2018
Posts
2,182
Reaction score
2,155
Location
nj
Ram Year
2014
Engine
5.7
DID YOU FIND THE ISSUE. I HAVE 2011 AND WE HAVE REPLACED CAM AND LIFTERS WITH OEM PARTS AND IT IS MISSING ON CYLINDER 6
Chek your push rods very common for them to not click in and check your compression on that cylinder.
 

jws123

Senior Member
Joined
May 16, 2018
Posts
2,182
Reaction score
2,155
Location
nj
Ram Year
2014
Engine
5.7
COMPRESSION HAS BEEN CHECKED AND LIFTERS ALSO. STILL CANT FIND ISSUE.
what cam what and lifters did you use? make sure you used mds cam mds lifters and they all went in the right spot. Its not rocket science if its only one cylinder you need spark fuel and compression take it to a locak pcivate owned shop they can find it quickly.
 
Top