2005 Ram 2500 Hemi 5.7 Goes to neutral at low speed

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Ram2500dude

Junior Member
Joined
Apr 9, 2024
Posts
2
Reaction score
0
Location
beloit
Ram Year
2005
Engine
5.7 hemi
I am having a issue with my Ram 2500 4x4 where when accelerating from a rolling stop the trucks trans seams to slip like in neutral. I come to rolling stop and then hit gas. The truck goes through 1st gear then when it should go to 2nd it slips. If I step on gas more nothing happens. If I come off gas and then back on gas the truck goes again and shifts up. I drove it for a hour with no issues then it happened again so issue seams to be semi random. In both cases though truck was coming out of a left turn at a slow speed. I don't know if the turn has something to do with it but basically rolling stop accelerate into turn, slips, off gas on, goes again. I want to use this truck to pull my boat but am unsure if it is safe. I work on all kinds of things but am not familiar enough with these transmissions. I see people doing Band adjustments but can't locate the band nut on outside of trans so I think I have a different model transmission(or am looking in wrong spot). I also see one model is under trans cover for bans. I see people talking about a vent too and valves. Is there a way to narrow down the cause before i start taking trans appart?
 

HemiLonestar

Senior Member
Military
Joined
Jun 1, 2012
Posts
6,067
Reaction score
3,133
Location
MD
Ram Year
2016
Engine
5.7 hemi
You have an RFE; no bands on the RFE. You need to see if it's popping codes, starting with p0700 and praying it isn't p0734 & p0735.
 
OP
OP
R

Ram2500dude

Junior Member
Joined
Apr 9, 2024
Posts
2
Reaction score
0
Location
beloit
Ram Year
2005
Engine
5.7 hemi
I ran the codes getting a P0335...crankshaft position sensor....I totally forgot I had a scan tool till you mentioned it...
 
Top