Parking light out message after using Alfaobd

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Ggoosstt413

Junior Member
Joined
Dec 6, 2023
Posts
13
Reaction score
3
Location
Massachusetts
Ram Year
2016
Engine
5.7 Hemi
I converted my headlights and taillights to led, I have update my 2016 ram in Alfaobd to all led lights. I’m stilll getting light out codes.
B16D7 - left tail lamp control circuit
B16DF - right tail lamp circuit
B16BF - front left side marker lamp control circuit
B16C3 - front right side marker lamp control circuit

Have seen lots of comments about adding resistors but I’m not expieriencing hyperflash and all the lights are working as they should. Still just getting those errror codes. The first thing I changed was the reverse light led option and that saved and held. But my ram is still throwing these codes. Any advice? Will resistors solve this problem even though I don’t have hyperflash? And if so, could someone point me in the right direction as to what kind of resistor I would need? I know nothing about resistors.
 

NETim

Senior Member
Supporting Member
Joined
Feb 22, 2020
Posts
521
Reaction score
910
Location
Nebraska
Ram Year
2014
Engine
5.7L
I have been S-L-O-W-L-Y and carefully updating to LED's on my '14. I install one set of lights at a time, do the Alfa thing and drive it for a week to see how things go. If it's all clear, then I'll update the next set.

For example, a few weeks ago, I had installed LED tail/brake lights. Ran the truck for awhile. No issues. A week later, the front marker/turns to switchback LED's. Seemed to go okay. Drove it a day or two and presto! Started to get lamp out messages, parking assist error messages and hyperflash. (Usually the hyperflash would occur after several seconds of turn signal usage.)

I gave up on them and installed other turn/marker lights that were "CANBUS/Error free" as well. Same issues. Nice n' bright but errors

I pulled them and re-installed the incandescent bulbs. I'll add resistors to the front LED's when I install them when the weather warms up. :)

I had previously updated the 3rd brake lights/bed lights and reverse lights to LED's with no issues.

That's how I go at it. If things don't go as planned I want the assurance of knowing the last step I performed was most likely the cause of the problems

Good luck!
 

chri5k

Senior Member
Supporting Member
Joined
May 24, 2019
Posts
1,941
Reaction score
2,935
Location
USA
Ram Year
2016
Engine
Diesel
What brand(s) of LED's do you have? I have Hakari Ultra for high beam; Auxlight for tail, stop; Auxito for reverse, CHMSL and bed light; Oxilam for low beams. No bulb out errors on my 2016 6.7. I'll check my AlfaOBD settings tomorrow. Pretty sure it is set for LED all around.
 
OP
OP
G

Ggoosstt413

Junior Member
Joined
Dec 6, 2023
Posts
13
Reaction score
3
Location
Massachusetts
Ram Year
2016
Engine
5.7 Hemi
It’s the leds that came with the headlamp and tail lamp. Those are the only codes that are throwing. Not my headlight bulb. Just like everyone else, when my lights are on and I brake or use a turn signal, that’s when I get the message. Worst part is it never stores so it just keeps coming back.
 

GTyankee

Senior Member
Supporting Member
Military
Joined
Nov 2, 2020
Posts
10,120
Reaction score
12,732
Location
El Cajon Calif. 92021
Ram Year
2016
Engine
3.0 ecodiesel
I have not tried any LED lights

I just seem to remember that sometimes AlfaOBD is super sensitive & can grab codes that don't show up on Code Readers that cost several thousands of dollars
 

White six four

Senior Member
Joined
Dec 31, 2019
Posts
469
Reaction score
762
Location
Wisconsin
Ram Year
2016
Engine
6.4
When I added fog lights to my tradesman it took a few drive cycles for them to "take". I thought I remember reading something about every time you start your truck the truck doesn't always go through the whole "system" and check for changes within itself. I could be remembering that wrong as it was a few years ago when I was searching for why my fog lights weren't working after adding them with the correct harness. After a few days they did work and have worked ever since.
 

indept

Senior Member
Joined
Sep 10, 2017
Posts
3,217
Reaction score
4,755
Location
South Jersey
Ram Year
2017
Engine
Hemi 5.7L
I've had LEDs for all bulbs for years, used alfaOBD to set for LEDS.
Usually no problem. Every spring & fall I get 1 or 2 parking & turn signal out warnings but all bulbs are fine. The only issue is the dash turn signal arrows hyperflash when that happens. The bulbs blink normal speed while the dash hyperflashes. After a few minutes all goes to normal.
 
OP
OP
G

Ggoosstt413

Junior Member
Joined
Dec 6, 2023
Posts
13
Reaction score
3
Location
Massachusetts
Ram Year
2016
Engine
5.7 Hemi
Thank you for all your experiences guys. Keep them coming. Hopefully I can figure this out. My last step is just disabling the chime bell that you hear when it happens but honestly that is just a last resort.
 

hunterdan

Senior Member
Joined
May 7, 2018
Posts
843
Reaction score
781
Location
SE PA
Ram Year
2019 classic
Engine
5.7 Hemi
Keep in mind, there are 2 settings that need to change for the front, and 3 for the rear. If you didn't change all of them, you'll have codes.
 
OP
OP
G

Ggoosstt413

Junior Member
Joined
Dec 6, 2023
Posts
13
Reaction score
3
Location
Massachusetts
Ram Year
2016
Engine
5.7 Hemi
Would adding resistors get rid of the error message? I’m not getting hyperflash but maybe add them for the error message?
 
OP
OP
G

Ggoosstt413

Junior Member
Joined
Dec 6, 2023
Posts
13
Reaction score
3
Location
Massachusetts
Ram Year
2016
Engine
5.7 Hemi
Update. After like a day my tailights have taken to the computer and they are not throwing codes anymore, even when I brake. Now I’m only getting the two headlight codes and they are only flashing when I use the turn signal. So at least now I know the culprit and it’s less annoying because I’m not hearing the chirp everytime I brake. Still only gives me the message when my lights are on.
 

CADFather

Junior Member
Military
Joined
Dec 26, 2023
Posts
4
Reaction score
6
Location
Georgia
Ram Year
2003
Engine
4.7
Leave it to the auto industry to create an issue where one didn't exist, all in the name of progress. If it ain't broke I can fix it until it is.
 
Top