2016 Ram 1500 hemi limp mode

bryantdoss

Junior Member
Joined
Nov 15, 2022
Posts
4
Reaction score
5
Location
springfield, mo
Ram Year
2016
Engine
5.7 Hemi
I have searched all over the internet and cannot find anyone with the same symptoms that I am having.

Starting about 2 years ago, I came home from deployment and my pickup was stuck in 3rd gear. CEL and traction control light were on. Cruise control did not work. cleared the codes and reset PCM via disconnecting the battery. Threw itself back into limp mode every couple months since. recently it has gotten worse and it happens everytime I drive it. As a results, i clear the codes (P1DD2, U0402, U0001, and a cam sensor code) on a daily basis. I have since replaced the cam sensor.

From the research i have done on the code, it is either the TCM, ECM, or PCM. If they werent $600 a piece i would just replace all of them. The biggest thing is that on Mopar parts website i cant find a TCM for a 5.7 Hemi, they are all for the ecodiesel. I see a valve body that has the whole deal, but I dont know that that is the right part.

I guess my first question is if anyone has had anything like this happen to them? and secondly, does this pickup even have a TCM?
 

GTyankee

Senior Member
Supporting Member
Military
Joined
Nov 2, 2020
Posts
7,134
Reaction score
8,169
Location
El Cajon Calif. 92021
Ram Year
2016
Engine
3.0 ecodiesel
p1DD2 explained



Looks like your Transmission is not communicating with your PCM

possibly rodents chewed on the wires
 
OP
OP
B

bryantdoss

Junior Member
Joined
Nov 15, 2022
Posts
4
Reaction score
5
Location
springfield, mo
Ram Year
2016
Engine
5.7 Hemi
Right! And that’s where I’m at digging into this. I just can’t figure out why it’s not. I have check all the wiring and what not, doesn’t seem to be an issue. With that being said, I think it is one of the modules mentioned in the thread, just trying to figure out which one.

And if my truck even has a TCM, If so where? And where can I find the part?
 

JHoward

Senior Member
Supporting Member
Joined
Jul 26, 2021
Posts
275
Reaction score
602
Location
NW Louisiana
Ram Year
2017
Engine
5.7 Liter
Right! And that’s where I’m at digging into this. I just can’t figure out why it’s not. I have check all the wiring and what not, doesn’t seem to be an issue. With that being said, I think it is one of the modules mentioned in the thread, just trying to figure out which one.

And if my truck even has a TCM, If so where? And where can I find the part?

Just throwing this out there, but have you load tested your battery? How old is your battery? What I've read here in the forums is these trucks electronics are sensitive to a weak battery and cause all kinds of codes/issues to pop up.

I haven't had issues with my five year old battery yet, but when the dash lights up like a Christmas tree I'll know what the culprit might be.

I've learned a lot here in the forums reading all the good info.
I'm just making a suggestion for a more simple place to start from
 

Wild one

Senior Member
Joined
Jan 17, 2016
Posts
9,842
Reaction score
14,692
Ram Year
14 Sport
Engine
5.7
Right! And that’s where I’m at digging into this. I just can’t figure out why it’s not. I have check all the wiring and what not, doesn’t seem to be an issue. With that being said, I think it is one of the modules mentioned in the thread, just trying to figure out which one.

And if my truck even has a TCM, If so where? And where can I find the part?
It's inside the transmission,hit up Benny he's a Mopar vendor on here, you should be able to find him in the vendor section.You might be able to find a used one,as the last time i looked into buying a new TCM,it was cheaper to buy a complete used 8 speed

 
Last edited:

GTyankee

Senior Member
Supporting Member
Military
Joined
Nov 2, 2020
Posts
7,134
Reaction score
8,169
Location
El Cajon Calif. 92021
Ram Year
2016
Engine
3.0 ecodiesel
on 3rd Gen Rams, the TCM is between the air filter & the firewall

the video that i saw showed the guy fighting some wires

Maybe he did not know that the whole air filter box lifts out, just needs a good jerk

This video shows how to trouble shoot U0001, on a Chrysler

 
OP
OP
B

bryantdoss

Junior Member
Joined
Nov 15, 2022
Posts
4
Reaction score
5
Location
springfield, mo
Ram Year
2016
Engine
5.7 Hemi
Just throwing this out there, but have you load tested your battery? How old is your battery? What I've read here in the forums is these trucks electronics are sensitive to a weak battery and cause all kinds of codes/issues to pop up.

I haven't had issues with my five year old battery yet, but when the dash lights up like a Christmas tree I'll know what the culprit might be.

I've learned a lot here in the forums reading all the good info.
I'm just making a suggestion for a more simple place to start from
Just throwing this out there, but have you load tested your battery? How old is your battery? What I've read here in the forums is these trucks electronics are sensitive to a weak battery and cause all kinds of codes/issues to pop up.

I haven't had issues with my five year old battery yet, but when the dash lights up like a Christmas tree I'll know what the culprit might be.

I've learned a lot here in the forums reading all the good info.
I'm just making a suggestion for a more simple place to start from
Battery is less than 2 years old and it was doing this before I replaced it. That’s where I started haha thank you for your input though!
 

JHoward

Senior Member
Supporting Member
Joined
Jul 26, 2021
Posts
275
Reaction score
602
Location
NW Louisiana
Ram Year
2017
Engine
5.7 Liter
Battery is less than 2 years old and it was doing this before I replaced it. That’s where I started haha thank you for your input though!

@Wild one and @GTyankee are two very knowledgeable fellers following your post and hopefully they can help you resolve your trucks issue.

I've driven RAM trucks a long time and I'm fortunate that I haven't had any serious/strange issues ...ha! ... knocking on wood! But I know where to go to find the answers if something pops up.
 

Wild one

Senior Member
Joined
Jan 17, 2016
Posts
9,842
Reaction score
14,692
Ram Year
14 Sport
Engine
5.7
@Wild one and @GTyankee are two very knowledgeable fellers following your post and hopefully they can help you resolve your trucks issue.

I've driven RAM trucks a long time and I'm fortunate that I haven't had any serious/strange issues ...ha! ... knocking on wood! But I know where to go to find the answers if something pops up.
Baffle them with bullshitt,lol
 

Jeffrey D

Junior Member
Joined
Nov 21, 2022
Posts
1
Reaction score
0
Location
Thomasville Ga
Ram Year
2010
Engine
Hemi 5.7
Hope you got it solved. I suddenly have the same problem. Whenever I disconnect the neg battery terminal, the code clears, and truck goes into all gears, runs perfectly. Well almost. It's got 230k miles on it. Turn it off and it throws a code and stays in limp mode. Dealership shrugs their shoulders and says it will take some time to figure out...
 
Top