Po740 help...

Discussion in 'Tech Info' started by Whiteloweredhemi, Dec 6, 2018.

  1. Whiteloweredhemi

    Whiteloweredhemi Junior Member

    Age:
    25
    Posts:
    5
    Likes Received:
    0
    Joined:
    Nov 8, 2018
    Location:
    Macomb mi
    Ram Year:
    2011
    Engine:
    5.7 hemi
    I had a torque converter installed early spring March of this year. Ran great till about a month ago. Issue I was having was at any speed 60+ my rpms would be at 2500+ if I gave it a little gas they would jump instantly to 3000+. CEL came on and threw the code po740 (tcc solenoid) I went ahead and replaced the “solenoid pack” changed fluid, filters ect. Put it all back together and still having same issue. So then I thought maybe the converter went bad. Took it out and shipped it to edge performance converters bc that’s where I bought it. Still had my warranty. They took it apart and said there is nothing wrong with it. Currently being shipped back. I’m stumped at this point and I don’t know what to do. Any help would be appreciated.
     
  2. Tach_tech

    Tach_tech Senior Member

    Age:
    32
    Posts:
    1,386
    Likes Received:
    879
    Joined:
    Jun 1, 2014
    Ram Year:
    2017
    Engine:
    5.7L HEMI
    Could be passages in the valve body/input shaft etc are blocked not allowing flow for the converter clutch.
     
  3. Whiteloweredhemi

    Whiteloweredhemi Junior Member

    Age:
    25
    Posts:
    5
    Likes Received:
    0
    Joined:
    Nov 8, 2018
    Location:
    Macomb mi
    Ram Year:
    2011
    Engine:
    5.7 hemi
    Okay I’ll take a look at that. Anything will help. I’m leaning more on some kind of electrical issue. Bad wire or ground, loose wire somewhere, low ohms.
     

Share This Page