Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

RKHF

Junior Member
Joined
Dec 28, 2023
Posts
5
Reaction score
3
Location
Washington
Ram Year
2014
Engine
6.7 cummins
Ram brothers and sisters…I’m at a loss tonight. I finally got the Alfa OBD for my 2014 3500. I did the usual, watched a YouTube video, and successfully programmed a new key fob and I was ecstatic. Figured I’d go ahead and adjust my tire size (37’s) so I’d actually know my speed. I must’ve been the sucker that watched the wrong video or read the wrong thread but I got all sorts of issues. I programmed my tire size and thought that was it. A little later I got in the truck to drive the trash can to the end of our lane and holy $hit were the dash Christmas lights aglow! I have traction control, ABS, 4WD, trailer brake warning lights, reverse park sense won’t turn on, my digital speedometer is just “- - -“ and the analog speedometer doesn’t even move.
With a little reading I saw that I had to do an ABS initialization, but when I select that it’s grayed out. The instructions for ABS initialization state to first perform a static ECU initialization. HERE’s where my problem begins. The static ECU initialization keeps failing stating “coding data not received”. I am completely stumped and don’t dare to drive my truck anywhere. Can someone help a brother out?!
 

Attachments

  • IMG_1043.jpeg
    IMG_1043.jpeg
    113.8 KB · Views: 7
  • IMG_1042.jpeg
    IMG_1042.jpeg
    96 KB · Views: 7
  • IMG_1044.jpeg
    IMG_1044.jpeg
    141.7 KB · Views: 7

Brandon-w

Senior Member
Joined
Jan 2, 2019
Posts
3,299
Reaction score
5,035
Location
Yukon
Ram Year
2015 Ram 1500
Engine
6.4
Change it back? Disconnect your batteries and hook the two cables together to drain the electronics of all power. Either the shtf of youre having a little glitch. Battery is the easiest place to start.
 

SitKneelBend

Senior Member
Military
Joined
Jan 8, 2015
Posts
9,241
Reaction score
5,020
Location
St. Louis
Ram Year
2014
Engine
3.6 Pentastar
Ram brothers and sisters…I’m at a loss tonight. I finally got the Alfa OBD for my 2014 3500. I did the usual, watched a YouTube video, and successfully programmed a new key fob and I was ecstatic. Figured I’d go ahead and adjust my tire size (37’s) so I’d actually know my speed. I must’ve been the sucker that watched the wrong video or read the wrong thread but I got all sorts of issues. I programmed my tire size and thought that was it. A little later I got in the truck to drive the trash can to the end of our lane and holy $hit were the dash Christmas lights aglow! I have traction control, ABS, 4WD, trailer brake warning lights, reverse park sense won’t turn on, my digital speedometer is just “- - -“ and the analog speedometer doesn’t even move.
With a little reading I saw that I had to do an ABS initialization, but when I select that it’s grayed out. The instructions for ABS initialization state to first perform a static ECU initialization. HERE’s where my problem begins. The static ECU initialization keeps failing stating “coding data not received”. I am completely stumped and don’t dare to drive my truck anywhere. Can someone help a brother out?!
Which OBDII adapter are you using?
 
OP
OP
R

RKHF

Junior Member
Joined
Dec 28, 2023
Posts
5
Reaction score
3
Location
Washington
Ram Year
2014
Engine
6.7 cummins
Change it back? Disconnect your batteries and hook the two cables together to drain the electronics of all power. Either the shtf of youre having a little glitch. Battery is the easiest place to start.
I changed it back, well should say I decided to just select the 35’s from the drop down rather than enter my own value. Ran the static ECU initialization and it passed right away! Everything is working as advertised now. Haven’t been able to verify accuracy but I’m relieved to say the least.
Any idea what may have cause this???

Thanks for the assist!
 

SitKneelBend

Senior Member
Military
Joined
Jan 8, 2015
Posts
9,241
Reaction score
5,020
Location
St. Louis
Ram Year
2014
Engine
3.6 Pentastar
I changed it back, well should say I decided to just select the 35’s from the drop down rather than enter my own value. Ran the static ECU initialization and it passed right away! Everything is working as advertised now. Haven’t been able to verify accuracy but I’m relieved to say the least.
Any idea what may have cause this???

Thanks for the assist!
We have all (AlfaOBD users) had this scare. Persistence, double checking and good backups usually get people squared away. Panick posting here is also a good idea! We have a great support group on this forum!
 

Brandon-w

Senior Member
Joined
Jan 2, 2019
Posts
3,299
Reaction score
5,035
Location
Yukon
Ram Year
2015 Ram 1500
Engine
6.4
I changed it back, well should say I decided to just select the 35’s from the drop down rather than enter my own value. Ran the static ECU initialization and it passed right away! Everything is working as advertised now. Haven’t been able to verify accuracy but I’m relieved to say the least.
Any idea what may have cause this???

Thanks for the assist!
Honestly and not knocking aleksy in any way (alfaobd creator). But sometimes there's a glitch on either our end or His. Always revert back of there is an issue and never change too much at once or you won't know what caused the issue. I had a problem with my Alfa a couple years ago and he had it fixed so fast, with support like his I don't mind dropping money on an app. Especially with the power this thing has. You can change EVERYTHING! As posted above too there are alot of great knowledgeable people on here, not trolls like most the Facebook groups... Unless you ask something realllll stupid, then I'll jump on it lol.
 

chri5k

Senior Member
Supporting Member
Joined
May 24, 2019
Posts
1,983
Reaction score
3,041
Location
USA
Ram Year
2016
Engine
Diesel
Did you make a backup of your current config? If not, do it now before changing anything else. The instructions are on the first post of the AlfaOBD thread.
 
OP
OP
R

RKHF

Junior Member
Joined
Dec 28, 2023
Posts
5
Reaction score
3
Location
Washington
Ram Year
2014
Engine
6.7 cummins
I did not and I absolutely will! Already screenshot the directions so I can follow along closely on my phone while using the tablet.
 
OP
OP
R

RKHF

Junior Member
Joined
Dec 28, 2023
Posts
5
Reaction score
3
Location
Washington
Ram Year
2014
Engine
6.7 cummins
Honestly and not knocking aleksy in any way (alfaobd creator). But sometimes there's a glitch on either our end or His. Always revert back of there is an issue and never change too much at once or you won't know what caused the issue. I had a problem with my Alfa a couple years ago and he had it fixed so fast, with support like his I don't mind dropping money on an app. Especially with the power this thing has. You can change EVERYTHING! As posted above too there are alot of great knowledgeable people on here, not trolls like most the Facebook groups... Unless you ask something realllll stupid, then I'll jump on it lol.
Lol, I expect nothing less. And yeah, I can’t stand how ridiculous some of the so called FB groups are. I’ve never learned a thing from them other than how to attack someone trying to learn the right way. Never understood why they have those groups when the common answer is “Google it”.
 
Top