Retrofit of the 12” UAX radio and screen into a Tradesman

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

skuppy069

Senior Member
Joined
Feb 26, 2017
Posts
795
Reaction score
362
Location
canada alberta
Ram Year
2018 1500 cc
Engine
hemi 5.7
As of now another member made me a harness to allow the connection of the in cabin temperature sensor. It's got the auto climate control working much better than without it, however it still behaves strange under certain circumstances. Next component I'm going to add is an ATC light sensor on the dash, apparently the MTC one is different and only runs 2 wires instead of 4.

I'm hoping the new 4 wire sensor may do more than just light and dark and may allow the ATC to factor in the heat from sunlight on the dash.
I think it will help based on some stuff I’ve seen around etc
 

g00fy

Senior Member
Joined
Aug 30, 2015
Posts
250
Reaction score
107
Ram Year
2019
Engine
Cummins 6.7
So I found something interesting since Alfa obd updated to support the 2020 HVAC models.

I was monitoring the different sensors in the truck and HVAC set points and I noticed that the Main (driver/left) HVAC temperature set point is not showing any value. However the Cabin temperature sensor value is NOT showing the temperature in the truck, it's showing whatever I set the temperature to on the uconnect.

Here's some Photos of what i'm talking about.

Here's with the Uconnect set on low:
6TDT2qGyQCEiJkP5U8OWPpi6iPDUk2hD1bHzGjjXAhX8=w2400.png

Here's with it set on 70:
wtRuuO811jd0AZQBtr0RtxYzcj-y92vFV7i78BdjhGJg=w2400.png

And finally here's with it set on high:
DhifyJQREYGXaNSDTVVcQnqCEyx02KH4AOVfOIpaoRwg=w2400.png


This to me would explain why between 66 - 70, depending on what the outside temperature is, it gives me mild warm air, but still ultimately makes the truck too warm, and if i start turning the Temperature DOWN it starts throwing MORE heat at me until i get to the LO set point.

It makes me wonder if the single zone manual Climate control is capable of accepting input from a cabin temperature sensor or if maybe i have to swap in a control module from a dual zone truck.

I think if i can get these 2 signals sorted out, the ATC will probably work as desired.
 
Last edited:

g00fy

Senior Member
Joined
Aug 30, 2015
Posts
250
Reaction score
107
Ram Year
2019
Engine
Cummins 6.7
If anyone with a factory dual zone climate control can get me some logs like the ones i posted above, that would be a big help.

A thread on hdrams.com has people describing the same problems with their FACTORY dual zone climate control that i'm having with my retrofit. Their ATC is always running a little hot, and they can't get cool air out of it until they push it to LO.

I'm having the same issue, when the temperature outside is below 60, and i have the temperature set to 70, it'll set the blower speed to 1 and blow luke warm air, but eventually it still gets too warm, so as i turn the temperature down to say, 68, the blower speed increases, and changes the output to the dash vents, but it start blowing WARMER air. So i turn the temperature down to 64, blower speed increases, and the air it's blowing gets even HOTTER. It's not until i force the temperature to LO that i actually start to get cool air.

And this behavior makes sense based on the log data I posted above, as i turn the set temperature on the Uconnect Down, the truck is seeing that value as the in cabin air temperature, so instead of the truck seeing that I want cooler air, it's seeing the cabin is colder, so it throws more heat at me.

I suspect when the weather here switches to hot summer weather where it's 80+ most days, I may have the opposite problem, where it's always making it too cool in the truck and as i turn the temp up it's going to continue throwing COLDER air at me, thinking the temperature in the cab is rising.
 

skuppy069

Senior Member
Joined
Feb 26, 2017
Posts
795
Reaction score
362
Location
canada alberta
Ram Year
2018 1500 cc
Engine
hemi 5.7
If anyone with a factory dual zone climate control can get me some logs like the ones i posted above, that would be a big help.

A thread on hdrams.com has people describing the same problems with their FACTORY dual zone climate control that i'm having with my retrofit. Their ATC is always running a little hot, and they can't get cool air out of it until they push it to LO.

I'm having the same issue, when the temperature outside is below 60, and i have the temperature set to 70, it'll set the blower speed to 1 and blow luke warm air, but eventually it still gets too warm, so as i turn the temperature down to say, 68, the blower speed increases, and changes the output to the dash vents, but it start blowing WARMER air. So i turn the temperature down to 64, blower speed increases, and the air it's blowing gets even HOTTER. It's not until i force the temperature to LO that i actually start to get cool air.

And this behavior makes sense based on the log data I posted above, as i turn the set temperature on the Uconnect Down, the truck is seeing that value as the in cabin air temperature, so instead of the truck seeing that I want cooler air, it's seeing the cabin is colder, so it throws more heat at me.

I suspect when the weather here switches to hot summer weather where it's 80+ most days, I may have the opposite problem, where it's always making it too cool in the truck and as i turn the temp up it's going to continue throwing COLDER air at me, thinking the temperature in the cab is rising.
What temp sensors are missing from the plenum box etc that would be installed if the truck came with the dual zone atc ?
 

g00fy

Senior Member
Joined
Aug 30, 2015
Posts
250
Reaction score
107
Ram Year
2019
Engine
Cummins 6.7
What temp sensors are missing from the plenum box etc that would be installed if the truck came with the dual zone atc ?

The only sensors missing at this time are the 4 in duct sensors.
 

skuppy069

Senior Member
Joined
Feb 26, 2017
Posts
795
Reaction score
362
Location
canada alberta
Ram Year
2018 1500 cc
Engine
hemi 5.7
I think maybe the reason it works when set to lo is the climate module neglects the plenum box sensors and only monitors cab temp
If it was me I would pin the missing sensors into the module wiring etc and try and install the correct locations
Did you try the new sun sensor ?
 

g00fy

Senior Member
Joined
Aug 30, 2015
Posts
250
Reaction score
107
Ram Year
2019
Engine
Cummins 6.7
I think maybe the reason it works when set to lo is the climate module neglects the plenum box sensors and only monitors cab temp
If it was me I would pin the missing sensors into the module wiring etc and try and install the correct locations
Did you try the new sun sensor ?

Yes, i did install the new sun sensor, and it works like it's supposed to according to the logs. I just don't understand why in my logs there is no Value showing up for the left side temperature setting, but the left side temperature setting is showing up and the cabin temperature value.
 

skuppy069

Senior Member
Joined
Feb 26, 2017
Posts
795
Reaction score
362
Location
canada alberta
Ram Year
2018 1500 cc
Engine
hemi 5.7
Yes, i did install the new sun sensor, and it works like it's supposed to according to the logs. I just don't understand why in my logs there is no Value showing up for the left side temperature setting, but the left side temperature setting is showing up and the cabin temperature value.
Making any head way with this ?
 

g00fy

Senior Member
Joined
Aug 30, 2015
Posts
250
Reaction score
107
Ram Year
2019
Engine
Cummins 6.7
Making any head way with this ?

Nay, all that's happened is a few other people unhappy with their factory dual some climate control confirmed their logs show the same issues. Now we're kinda at a standstill since it seems like a software issue only ram can correct.
 

g00fy

Senior Member
Joined
Aug 30, 2015
Posts
250
Reaction score
107
Ram Year
2019
Engine
Cummins 6.7
I had the Air Conditioning TSB# 24-001-20 performed on my truck this week. It fixed all the stupid BS issues i was having with the ATC. So my 12" UAX Retrofit now works pretty flawlessly with infotainment & ATC even without the 5 duct temperature sensors.

Couple things to note for anyone else doing this swap in an MTC truck, to get the ATC to work right on 2019 - 2020 retrofits, the TSB#24-001-20 must be performed on the truck, you must get a jumper harness made to be able to add the in cabin temperature sensor to the system, and you must get the upgraded sun sensor for the front of the dashboard (Direct Plug & Play Swap no harness needed).

Part Numbers:

Sun Sensor - Mopar (68230114AB)

Temperature Cabin Air Sensor - Mopar (55111178AC)
 

Staff online

Forum statistics

Threads
195,338
Posts
2,868,957
Members
155,973
Latest member
Bobby023
Top